Not very good tape performance

Everything about backing up to tape

Not very good tape performance

Veeam Logoby syscom » Tue Dec 23, 2014 3:24 am

Hello,

Sorry for my bad English, French speaking. ;-)

I have set up Veeam for VMware V8 for a customer. They have a dedicated server (IBM x3650M4 HD) with 32 GB of RAM.

They have a LTO-6 tape library connected via FC into a dedicated Qlogic card.

We have tested full backup to tape and here are the results :

Size : 183,2 GB
Read : 183,2 GB
Transferred : 183,2 GB
Duration : 1:31:17

An average of ~33 MB/s

It seems to be not very fast... What do you think about that ? I expected over 100 MB/s.
syscom
Novice
 
Posts: 7
Liked: 2 times
Joined: Thu Jun 18, 2009 2:50 am
Full Name: Syscom SARL

Re: Not very good tape performance

Veeam Logoby torendil » Tue Dec 23, 2014 8:50 am

Hello,

identical problem with a DELL TL4000 library (LTO4) and V8, 40-80MB/s expected but tape backup speed is 10MB/s...i wait a support solution.

you are not alone :-p
torendil
Novice
 
Posts: 8
Liked: 2 times
Joined: Fri Nov 28, 2014 9:10 am
Full Name: jeremy

Re: Not very good tape performance

Veeam Logoby v.Eremin » Tue Dec 23, 2014 9:17 am 1 person likes this post

Guys, can you confirm that you're not affected by one of those known issues? Thanks.
v.Eremin
Veeam Software
 
Posts: 13290
Liked: 973 times
Joined: Fri Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin

Re: Not very good tape performance

Veeam Logoby torendil » Tue Dec 23, 2014 9:24 am

I confirm, registry key for encryption was added and .dll was udapted...(only on the veeam "master" server) but i have also the fix for slow reverse incremental...my backup and tape proxy service are on the same (physical) server.
torendil
Novice
 
Posts: 8
Liked: 2 times
Joined: Fri Nov 28, 2014 9:10 am
Full Name: jeremy

Re: Not very good tape performance

Veeam Logoby v.Eremin » Tue Dec 23, 2014 9:28 am

And what is identified as a major bottleneck in the tape job session statistics? Thanks.
v.Eremin
Veeam Software
 
Posts: 13290
Liked: 973 times
Joined: Fri Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin

Re: Not very good tape performance

Veeam Logoby torendil » Tue Dec 23, 2014 9:39 am

target. I see network trafic on ressources monitor for 2 veeam services 1 send and the other receive...10MB/s by service
proxy is a 2008 R2 physical server and "master" is a windows 2012 VM.

(case id 00709443)
torendil
Novice
 
Posts: 8
Liked: 2 times
Joined: Fri Nov 28, 2014 9:10 am
Full Name: jeremy

Re: Not very good tape performance

Veeam Logoby Dima P. » Tue Dec 23, 2014 10:00 pm

Jeremy,
What was selected as a source for the job in the question? Any chance you could run a performance test with the tape vendor native tool and let us know the results? Thank you.
Dima P.
Veeam Software
 
Posts: 6257
Liked: 440 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Not very good tape performance

Veeam Logoby torendil » Tue Dec 23, 2014 11:22 pm

It's a file to tape job with only veeam backup files.
If i do the same job with netbackup backup of 5To take 22hours=> 63MB/s
torendil
Novice
 
Posts: 8
Liked: 2 times
Joined: Fri Nov 28, 2014 9:10 am
Full Name: jeremy

Re: Not very good tape performance

Veeam Logoby Dima P. » Sun Dec 28, 2014 11:27 pm

Jeremy, got it. Let’s wait for the result of support team investigation, meanwhile – please make sure you have installed the latest patch > KB1982. Thank you.
Dima P.
Veeam Software
 
Posts: 6257
Liked: 440 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Not very good tape performance

Veeam Logoby syscom » Tue Dec 30, 2014 2:11 am 2 people like this post

We have disabled "Use hardware compression if available" on every tape jobs and it seems to have solve the perfomance issues... 150 MB/s right now ! :D
syscom
Novice
 
Posts: 7
Liked: 2 times
Joined: Thu Jun 18, 2009 2:50 am
Full Name: Syscom SARL

Re: Not very good tape performance

Veeam Logoby Dima P. » Tue Dec 30, 2014 1:18 pm

Syscom,
Glad you nailed it and thank you for sharing the solution with the community. Honestly, I was always thinking that tape library built-in hardware compression does not affect the performance (since it is inline compression). Just out of the curiosity what was the model of the library?
Dima P.
Veeam Software
 
Posts: 6257
Liked: 440 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Not very good tape performance

Veeam Logoby torendil » Tue Dec 30, 2014 2:15 pm 2 people like this post

update 1 solve the problem, speed increase from 10MB to 100-130MB/s !! :mrgreen:
torendil
Novice
 
Posts: 8
Liked: 2 times
Joined: Fri Nov 28, 2014 9:10 am
Full Name: jeremy

Re: Not very good tape performance

Veeam Logoby syscom » Sun Jan 04, 2015 10:53 pm

d.popov wrote:Syscom,
Glad you nailed it and thank you for sharing the solution with the community. Honestly, I was always thinking that tape library built-in hardware compression does not affect the performance (since it is inline compression). Just out of the curiosity what was the model of the library?

IBM TS3200
syscom
Novice
 
Posts: 7
Liked: 2 times
Joined: Thu Jun 18, 2009 2:50 am
Full Name: Syscom SARL

Re: Not very good tape performance

Veeam Logoby Dima P. » Mon Jan 05, 2015 2:22 am

Syscom,
Great, thanks for the heads up!
Dima P.
Veeam Software
 
Posts: 6257
Liked: 440 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov


Return to Tape



Who is online

Users browsing this forum: No registered users and 9 guests