Tape backups failing due to SQL issue

Everything about backing up to tape

Tape backups failing due to SQL issue

Veeam Logoby lightsout » Mon Sep 08, 2014 9:42 pm

Hi,

My setup is as follows:

Server - 2012 R2 physical with lots of RAM + processors. :) Running deduplication.
SQL - SQL 2012 SP2 installed locally. On C:, so not deduplicated.
Veeam - v7 patch 4.

I'm seeing this error on my tape jobs:

9/8/2014 1:04:35 PM :: Task D:\Backup\XYZ.vbk failed: Microsoft SQL server hosting the configuration database is currently unavailable. Possible reasons are heavy load, networking issue, server reboot, or hot backup.
Please wait, and try again later.

Error information:
Subquery returned more than 1 value. This is not permitted when the subquery follows =, !=, <, <= , >, >= or when the subquery is used as an expression.
The statement has been terminated.


This fails when no other jobs/deduplication processes are running. My normal backup jobs run fine, so it seems to be a tape issue.

Any ideas?
lightsout
Expert
 
Posts: 185
Liked: 47 times
Joined: Thu Apr 10, 2014 4:13 pm

Re: Tape backups failing due to SQL issue

Veeam Logoby Gostev » Mon Sep 08, 2014 9:46 pm

Hi, please include support case ID for this issue, as requested when you click New Topic. Moving the topic to Tape subforum. Thanks.
Gostev
Veeam Software
 
Posts: 21396
Liked: 2350 times
Joined: Sun Jan 01, 2006 1:01 am
Location: Baar, Switzerland

Re: Tape backups failing due to SQL issue

Veeam Logoby lightsout » Mon Sep 08, 2014 9:52 pm

That'll be 00632709 - just submitted as well.
lightsout
Expert
 
Posts: 185
Liked: 47 times
Joined: Thu Apr 10, 2014 4:13 pm

Re: Tape backups failing due to SQL issue

Veeam Logoby v.Eremin » Tue Sep 09, 2014 8:52 am

When do you typically get this issue? In the begging or in the midst of a tape job? There used to be similar issues related to tape changing operation, but they should have been fixed in patch#3. Thanks.
v.Eremin
Veeam Software
 
Posts: 13290
Liked: 973 times
Joined: Fri Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin

Re: Tape backups failing due to SQL issue

Veeam Logoby Dima P. » Tue Sep 09, 2014 11:37 am

lightsout,

If it is possible I would recommend you to recreate the existing tape job from scratch, and, again if it’s possible re-create the media pools as well. You may get this error because of the tapes incorrectly migrated from one media pool to another which cased SQL issues, even it was fixed long ago old tapes created during previous versions of VBR sill may have such behavior.
Dima P.
Veeam Software
 
Posts: 6257
Liked: 440 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Tape backups failing due to SQL issue

Veeam Logoby lightsout » Tue Sep 09, 2014 12:48 pm

According to support, it is a known issue.

I've got one media set that has a bunch of identical sequence numbers and that is causing the issue. So I'm going to erase those tapes, and that should fix it. Should also be fixed in the "next version", which I guess means v8.
lightsout
Expert
 
Posts: 185
Liked: 47 times
Joined: Thu Apr 10, 2014 4:13 pm

Re: Tape backups failing due to SQL issue

Veeam Logoby Dima P. » Tue Sep 09, 2014 2:19 pm

Great! Thank you for the heads up!
Dima P.
Veeam Software
 
Posts: 6257
Liked: 440 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov


Return to Tape



Who is online

Users browsing this forum: No registered users and 10 guests