TapeJob failed - Shared memory connection was closed.

Everything about backing up to tape

TapeJob failed - Shared memory connection was closed.

Veeam Logoby jdehn » Wed Jan 20, 2016 1:58 pm

Hi there!

I am nearly despairing right now.
Tried Veeam B&R some months ago and was happy with it - all worked quite good.
4 weeks ago I tried to get productive with Veeam, installed the needed servers and attached our productive Tape Drive to that server.
Some tests were good until we got some mistakes by copying the backups to tape.

The error message I am getting right now is:

Code: Select all
BackupSrvFileToTape failed Tape fatal error. Die Anforderung konnte wegen eines E/A-Gerätefehlers nicht ausgeführt werden Tape write error Exception from server: Shared memory connection was closed. Tape fatal error.

Details:
    - using Veeam v9
    - backup-server is running on Windows 7 Professional 64 Bit (VM @ Hyper-V)
    - server for repository and tape is running on Windows 10 Pro 64 Bit directly on a Intel Modular Server Blade
    - tape drive is attached via SAS to the Modular Server and then passed through to the repository- and tape-server
    - tape drive is IBM TS2260 / 3580 HH-6 with newest firmware
    - tapes are LTO6

I am using the newest driver (non-exclusive) I am getting from IBM.
I updated the tape drive to the newest firmware.
ITDT (IBM Tape Diagnostic Tool) does not give me any error.
I already uninstalled the antivirus-software (ESET Endpoint Antivirus 5).

Have anyone ever seen this error before? I don't get very much information by googling..

Thanks in advance for your help!

Best regards, Julian Dehn

Support ID is 01419840.
jdehn
Novice
 
Posts: 6
Liked: 2 times
Joined: Thu Jan 14, 2016 9:01 am
Location: Nördlingen, Germany
Full Name: Julian Dehn

Re: TapeJob failed - Shared memory connection was closed.

Veeam Logoby Dima P. » Wed Jan 20, 2016 2:30 pm

Hello Julian,

Kindly, attach the requested logs to the case. I’ve asked QA and Dev’s to check but it seems that no logs were uploaded. Thanks in advance.
Dima P.
Veeam Software
 
Posts: 6242
Liked: 440 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: TapeJob failed - Shared memory connection was closed.

Veeam Logoby jdehn » Wed Jan 20, 2016 3:04 pm

Hi Dmitry,

thanks for your quick response!
I already uploaded the requested logs and screenshots to the FTP-Server for my casenumber.
I got the credentials from Ms. Pilat who is actual working on my case - did I do anything wrong?

Thanks again and best regards, Julian

edit: Sorry! My mistake! I just uploaded the files Ms. Pilat requested before to the ftp-server. Now I added the log-files for this job to the case.
Right now the job seems to run through - I set the blocksize to the lowest option.. Maybe thats it..
Sorry again!
jdehn
Novice
 
Posts: 6
Liked: 2 times
Joined: Thu Jan 14, 2016 9:01 am
Location: Nördlingen, Germany
Full Name: Julian Dehn

Re: TapeJob failed - Shared memory connection was closed.

Veeam Logoby Dima P. » Wed Jan 20, 2016 5:41 pm

Thanks you. At first sight, it looks like a hardware failure due "The driver detected a controller error on \Device\RaidPort0” event entry but lets await for the investigation results from the support side.
Dima P.
Veeam Software
 
Posts: 6242
Liked: 440 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: TapeJob failed - Shared memory connection was closed.

Veeam Logoby jdehn » Thu Jan 21, 2016 9:42 am

Hi Dmitry,

where do you see this error message?
I can't find this in the logs.

By the way: It doesn't matter which blocksize I am using - the error is still the same by different blocksizes.

Thank you and best regards, Julian
jdehn
Novice
 
Posts: 6
Liked: 2 times
Joined: Thu Jan 14, 2016 9:01 am
Location: Nördlingen, Germany
Full Name: Julian Dehn

Re: TapeJob failed - Shared memory connection was closed.

Veeam Logoby Dima P. » Fri Jan 22, 2016 3:16 pm

I was told that it is in the debug logs you shared and may refer to SAS controller issues.
Dima P.
Veeam Software
 
Posts: 6242
Liked: 440 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: TapeJob failed - Shared memory connection was closed.

Veeam Logoby jdehn » Tue Jan 26, 2016 1:47 pm 2 people like this post

Thanks for your help Dima!

Now we got the issue - for anyone who has the some problem than me:
It is because of the Intel Modular Server. There is any error by passing through the SAS-connection to the blade.
Support says, this error occurs at some customers systems but you cant really do anything to get it working.

I installed another (old) server with Windows 10 and added as Tapeserver to Veeam.
Copying the backup jobs to tape is working now.

edit: I think I can not close this thread - can anyone do that for me? Thanks!
jdehn
Novice
 
Posts: 6
Liked: 2 times
Joined: Thu Jan 14, 2016 9:01 am
Location: Nördlingen, Germany
Full Name: Julian Dehn

Re: TapeJob failed - Shared memory connection was closed.

Veeam Logoby Dima P. » Tue Jan 26, 2016 2:06 pm 1 person likes this post

Glad your issue is resolved and additional kudos for sharing the resolution with the community – it helps a lot!
Dima P.
Veeam Software
 
Posts: 6242
Liked: 440 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov


Return to Tape



Who is online

Users browsing this forum: No registered users and 2 guests