Unable to backup to Tape - After 9.5 upgrade

Everything about backing up to tape

Unable to backup to Tape - After 9.5 upgrade

Veeam Logoby adb98 » Wed Dec 07, 2016 7:52 pm

Support ticket # 01997052

Need some help on this one. Support is going kinda slow and I am hoping someone has seen this before and can give me some wisdom.

Before I start let me give the environment layout. 1 VBR server and 2 physical proxies. The 2 physical proxies are on a closed 10gb network with our DD 4200 and have direct attached storage for all the datastores. We then have a physical tape proxy in a different room that does not have access to this closed network. It has to use one of the two physical proxies to pull data

All was working great in Version 9. Now when I try to do a job to tape I get the following:

Code: Select all
12/6/2016 3:49:03 PM :: Full backup: BackupSrvFileToTape failed
rpc connection failure. Err: 5028
Failed to connect to storage. Storage: 192.168.248.1, User: boostuser

rpc connection failure. Err: 5028 


Now this IP is the closed network IP for the DD and boostuser is the user for the DD. Not sure but it seems like it is now trying to make a direct connection which it won't be able to. It has to go thru one of the two physical proxies to pull data. Tapes load fine and are ready to rock. It fails trying to connect to get the data.

I have restarted all proxies and the VBR server, rescanned all repositories and proxies to the same issue. Any help would be great.
adb98
Influencer
 
Posts: 18
Liked: 1 time
Joined: Thu Jul 21, 2016 5:03 pm
Full Name: Aaron B

Re: Unable to backup to Tape - After 9.5 upgrade

Veeam Logoby Dima P. » Thu Dec 08, 2016 1:54 pm

Hi Aaron,

Is that a file to tape or backup to tape job?
Dima P.
Veeam Software
 
Posts: 6517
Liked: 454 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Unable to backup to Tape - After 9.5 upgrade

Veeam Logoby adb98 » Thu Dec 08, 2016 2:50 pm

backup to tape job
adb98
Influencer
 
Posts: 18
Liked: 1 time
Joined: Thu Jul 21, 2016 5:03 pm
Full Name: Aaron B

Re: Unable to backup to Tape - After 9.5 upgrade

Veeam Logoby adb98 » Thu Dec 08, 2016 4:43 pm

Hope this is not a bug in the code because this has to be working as we have HIPPA regulations we have to follow. This is what I found in the logs.


Code: Select all
[CTapeChainBackupUnit] [Full:vm:Name of VM] failed
[06.12.2016 13:19:10] <20> Error    BackupSrvFileToTape failed (Veeam.Backup.Common.CAgentException)
[06.12.2016 13:19:10] <20> Error       at Veeam.Backup.AgentProvider.CBackupClient.BackupSrvFileToTape(String srvFilePath, String tapePathLink, Int32 errHandlingType)
[06.12.2016 13:19:10] <20> Error       at Veeam.Tape.Core.CTapeBackupVmFileObject.RunBackupOnAgent(EAgentErrorHandlingType errHandling, ITapeAgentsSession agentsSession, IXmlLogger logger)
[06.12.2016 13:19:10] <20> Error       at Veeam.Tape.Core.CTapeBackupVmFileObject.Backup(Boolean substituteHost, IXmlLogger logger)
[06.12.2016 13:19:10] <20> Error       at Veeam.Tape.Core.Jobs.Tasks.CTapeStorageBackupPerformer.Perform(CTapeVmBackupOibBuilder oibBuilder)
[06.12.2016 13:19:10] <20> Error       at Veeam.Tape.Core.Jobs.Tasks.CTapeVbkBackupPerformer.Perform(ITapeSourceStorageLockKeeper lockKeeper)
[06.12.2016 13:19:10] <20> Error       at Veeam.Tape.Core.ResourceOwners.CTapeChainBackupUnitPerformer.BackupVbk(ITapeBackupResource leasedResources)
[06.12.2016 13:19:10] <20> Error       at Veeam.Tape.Core.ResourceOwners.CTapeChainBackupUnitPerformer.PerformVbkBackup(ITapeBackupResource leasedResources)
[06.12.2016 13:19:10] <20> Error       at Veeam.Tape.Core.ResourceOwners.CTapeChainBackupUnitPerformer.PerformChainBackup(Object resources)
[06.12.2016 13:19:10] <20> Error    rpc connection failure. Err: 5028 (Veeam.Backup.Common.CCppComponentException)
[06.12.2016 13:19:10] <20> Error    Failed to connect to storage. Storage: 192.168.248.1, User: boostuser (Veeam.Backup.Common.CCppComponentException)
adb98
Influencer
 
Posts: 18
Liked: 1 time
Joined: Thu Jul 21, 2016 5:03 pm
Full Name: Aaron B

Re: Unable to backup to Tape - After 9.5 upgrade

Veeam Logoby Dima P. » Thu Dec 08, 2016 8:34 pm

adb98,

Unfortunately, can’t say much based on this errors. Let’s wait for the support investigation results.
Dima P.
Veeam Software
 
Posts: 6517
Liked: 454 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Unable to backup to Tape - After 9.5 upgrade

Veeam Logoby adb98 » Mon Dec 12, 2016 5:05 pm 1 person likes this post

Just a quick update. This has been escalated to Lv2 and I they are currently reviewing this.
adb98
Influencer
 
Posts: 18
Liked: 1 time
Joined: Thu Jul 21, 2016 5:03 pm
Full Name: Aaron B

Re: Unable to backup to Tape - After 9.5 upgrade (Temp Solut

Veeam Logoby adb98 » Tue Dec 13, 2016 1:55 pm

****Temp Solution Given *****

This has been resolved to a sense. Lv2 support requested that I specify a gateway server that the tape proxy could get to on the Data Domain Repository instead of having it set to automatic. I changed it and this resolved the issue.

Lv2 support is still looking into this but apparently the Automatic Gateway selection for the Data Domain is either broken in this version or it is broken on the tape side. All my repositories are set to automatic and this was working on 9.0. I now have to change them to a specfic server when I want to back a VM up that is on that repository. Not to good.

I will give more updates as I get them
adb98
Influencer
 
Posts: 18
Liked: 1 time
Joined: Thu Jul 21, 2016 5:03 pm
Full Name: Aaron B

Re: Unable to backup to Tape - After 9.5 upgrade

Veeam Logoby Dima P. » Wed Dec 14, 2016 9:10 am

Thanks for updating the thread. Can imagine a conflict while using automatic selection: data domain tries to use it’s own gateway and tape job it’s own server. I’ll check with the team regarding your issue.
Dima P.
Veeam Software
 
Posts: 6517
Liked: 454 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov


Return to Tape



Who is online

Users browsing this forum: No registered users and 8 guests