Free agent install problem

Backup agent for Linux servers and workstations on-premises or in the public cloud

Free agent install problem

Veeam Logoby stinkydiver » Wed May 03, 2017 4:12 am

Hi

I've got a CentOS server version 7.3.1611. Trying to run the agent rpm package installation I am getting this error:

rpmReadSignature failed: region tralier: BAD, tag 1872 type 2047 offset 20480 count 4096

I've checked the package MD5 and it is ok.

Running a --nosiganture switch doesn't make a difference.

Any ideas?

Thanks
stinkydiver
Novice
 
Posts: 4
Liked: never
Joined: Wed May 03, 2017 4:08 am
Full Name: Aaron Haugh

Re: Free agent install problem

Veeam Logoby vmniels » Wed May 03, 2017 1:51 pm

Could you download it again and try again? About which rpm package are you talking exactly?
VCP-DCV
Veeam Certified Engineer
http://foonet.be
vmniels
Veeam Software
 
Posts: 1504
Liked: 325 times
Joined: Mon Jul 15, 2013 11:09 am
Full Name: Niels Engelen

Re: Free agent install problem

Veeam Logoby PTide » Wed May 03, 2017 2:26 pm

Hi,

Is that a veeam-release rpm package obtained from veeam.com that you're trying to install? If so then could you please provide its full name (e.g. veeam-release-el7-1.0-1.x86_64.rpm)

Thank you
PTide
Veeam Software
 
Posts: 3019
Liked: 245 times
Joined: Tue May 19, 2015 1:46 pm

Re: Free agent install problem

Veeam Logoby stinkydiver » Thu May 04, 2017 2:25 am

Hey there

I downloaded the CentOS 7 x64 package twice as well as the x86 package from the veeam.com download page. They both were a whopping 8kb! MD5 matched however...

I managed to resolve the issue buy creating a custom veeam repository installing it via yum.

Thanks anyway
stinkydiver
Novice
 
Posts: 4
Liked: never
Joined: Wed May 03, 2017 4:08 am
Full Name: Aaron Haugh

Re: Free agent install problem

Veeam Logoby stinkydiver » Thu May 04, 2017 4:00 am

FYI the file I got from veeam.com that didn't work was veeam-release-el7-1.0-1.x86_64.rpm
stinkydiver
Novice
 
Posts: 4
Liked: never
Joined: Wed May 03, 2017 4:08 am
Full Name: Aaron Haugh

Re: Free agent install problem

Veeam Logoby PTide » Fri May 05, 2017 8:42 am

Glad that you've nailed it. I just would like to clarify something, please correct me if I'm wrong:

- you had downloaded veeam-release-el7-1.0-1.x86_64.rpm from veeam.com and attempted to install it with rpm -ivh veeam-release-el7-1.0-1.x86_64.rpm which gave the above-mentioned rpmReadSignature error. The MD5 was fine though.

- after that you installed the package via yum localinstall veeam-release-el7-1.0-1.x86_64.rpm and that resolved the issue.

Is everything correct?

Thank you
PTide
Veeam Software
 
Posts: 3019
Liked: 245 times
Joined: Tue May 19, 2015 1:46 pm

Re: Free agent install problem

Veeam Logoby stinkydiver » Sun May 07, 2017 8:49 pm

Hi PTide

This is correct: you had downloaded veeam-release-el7-1.0-1.x86_64.rpm from veeam.com and attempted to install it with rpm -ivh veeam-release-el7-1.0-1.x86_64.rpm which gave the above-mentioned rpmReadSignature error. The MD5 was fine though.

I then created the custom veeam repository using the settings found in the [GA] Veeam Agent for Linux thread.

I then ran yum install veeam which downloaded and installed the agent for me.

Thanks
stinkydiver
Novice
 
Posts: 4
Liked: never
Joined: Wed May 03, 2017 4:08 am
Full Name: Aaron Haugh


Return to Veeam Agent for Linux



Who is online

Users browsing this forum: No registered users and 7 guests