Error: Shared memory connection was closed

Backup agent for Microsoft Windows servers and workstations (formerly Veeam Endpoint Backup FREE)

Re: Error: Shared memory connection was closed

Veeam Logoby MasterII » Fri Nov 18, 2016 9:55 am

I wound like to report similar problem with "Shared memory connection was closed". I do not know if any real technician will read this post, but even I have had to fix it myself, I think, there is something wrong. I can replicate issue every time. But my issue is not due to failed USB drive as resolved above.

Lets see my status (and notice):
- there is and USB drive Y: permanently connected (unfortunately no sata free)
- there is a share on this drive \\localhost\VEEAM only acessible by user "backuper" and "service" for fullrights. Administrators and others users can access this share only as read, applied for share permission and NTFS rights
(i cannot allow kryptoviruses to reach backups and encrypt them, and because VEBFree cannot save into unmapped letter nor protect the storage place, I am creating this workaround how to manage secured storage)
- there is a huge portion of backups data, repeatedly tried more then 650GB (when less, this issue does not appear - where is the real data amount limit I do not know exactly. But with 80GB there is no issue.)
- Backup is started, and backuping until end (many hours, but no problem untils end, read later)
- at the end "Shared memory connection was closed" and reason "network share is no longer available". (how should be \\localhost\veeam unavailable I cannot believe)

WHEN the same backup is saved into Y:\VEEM (without using share \\localhost\veeam), it is sucessfull, it take very similar time as into share and at the end there is no error.

I really wonder, why is is failing with storage in share \\localhost\veeam

- It is not permission issue (if only smaller amount of data is backuped, all is working fine)
- USB is not disconected automaticaly, i can browse it even in the same time VEBFree reports error
- on other machine where is no USB disk, but normal SATA this problem does not exists (possible workaround)

So finaly there is only point of my feedback and recommendation for VEEAM programmers and testers:
- there is something wrong with USB/network shared storage
- there will be nice, if there will be protection againts kryptoviruses implemented - in the way you manage now storage location permanently connected it is useless. Every user which install VEBFree is unprotected because of possible encryption of file backups. May be allow backup into unmapped partition (less secure, clever malware will get access there), better you completely run everything under different user and also only with this user full access permission to the storage. Everyone else must only read (in case od restore).

Sorry for long post, I will not do it again, I have really no time for this. But the VEEAM ENDPOINT BACKUP FREE is a wonderfull product, which deserves feedbacks.
I woud like to provide feedback, but it is as much complicated as it should be without guarantee somebody competent will read it. Unfreandly posting when red notice about case ID is scaring users, there is no official support for VEBFree, how to get this ID. I have none of two decribed support (paid) plans in the link. Even if VEBFree is a free product, there should be more comportable way to tell you ideas, improvements, issues. Not only endless sink of user community forums.

Keep good work!
MasterII
Novice
 
Posts: 3
Liked: never
Joined: Fri Nov 18, 2016 8:54 am

Re: Error: Shared memory connection was closed

Veeam Logoby MasterII » Sun Nov 20, 2016 12:36 am

Just small update.
Unfortunately I get same error on another machine with fixed SATA disk. There is no doubt that there is a bug for writing to network share 813GB and more. So my issue is not USB device related.
Exception from server: network share is no longer available (translated from czech).

Code: Select all
20.11.2016 1:24:48 :: Error: Shared memory connection was closed. Failed to upload disk. Agent failed to process method {DataTransfer.SyncDisk}. Exception from server: Zadaný síťový název není již dále k dispozici. Error code: 64 Failed to flush file buffers. File: [\\localhost\VEEAM\Backup Job MINIFRAME1\Backup Job MINIFRAME12016-11-20T011214.vbk]. Failed to download disk.
MasterII
Novice
 
Posts: 3
Liked: never
Joined: Fri Nov 18, 2016 8:54 am

Re: Error: Shared memory connection was closed

Veeam Logoby Dima P. » Wed Nov 23, 2016 8:32 am

Hi MasterII,

Welcome to the community and thanks for the detailed explanation of your issue!

We do provide a free support for Veeam Endpoint Backup, so feel free to open a support case via Veeam Endpoint Backup’s Control Panel > Support tap > Technical support (you have to confirm your email address while submitting the case). That said, the described behavior does not look like expected. We do support a shared folder as a destination, even if that’s a shared USB devices connected to a local machine)

Kindly, open a case and share the case ID, so we could check the application logs. Thanks in advance!
Dima P.
Veeam Software
 
Posts: 6739
Liked: 482 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Error: Shared memory connection was closed

Veeam Logoby roger.pfaff » Mon Oct 16, 2017 3:59 pm 1 person likes this post

To solve this, just Format the external USB device in NTFS instead of FAT32!
So the large file limit of FAT32 dont longer causes this problem.

Hope this helps you

greetings from germany….
roger.pfaff
Lurker
 
Posts: 1
Liked: 1 time
Joined: Mon Oct 16, 2017 3:55 pm
Full Name: Roger Pfaff

Previous

Return to Veeam Agent for Windows



Who is online

Users browsing this forum: No registered users and 1 guest