Error updating to version 1.1.2.119

Backup agent for Microsoft Windows servers and workstations (formerly Veeam Endpoint Backup FREE)

Error updating to version 1.1.2.119

Veeam Logoby TechImpossible » Mon Nov 23, 2015 11:57 pm 2 people like this post

Hi Community,

I wanted to share the problems I encountered when trying to update my VEB from Version 1.0.0.1954 to the current Version 1.1.2.119

When trying to install the installation failed when trying to update the MS SQL Server 2012 LocalDB.

Code: Select all
[23.11.2015 12:41:05][INFO] Checking presence of Microsoft SQL Server 2012 Local DB...
[23.11.2015 12:41:05][INFO] Requested 'InstanceAPIPath' registry key at the 'SOFTWARE\Microsoft\Microsoft SQL Server Local DB\Installed Versions\11.0\' path is found, Checking version.
[23.11.2015 12:41:05][INFO] Required version: 11.2.5058.0; Found version: 11.0.2100.60
[23.11.2015 12:41:05][INFO] Microsoft SQL Server 2012 Local DB upgrade is required.
[23.11.2015 12:41:05][INFO] Installing 'SQL Server 2012 Express LocalDB' redistributable...
[23.11.2015 12:41:05][INFO] Package path: C:\Users\me\AppData\Local\Temp\RarSFX0\EndPoint\Redistr\x64\SqlLocalDB.msi
[23.11.2015 12:41:05][ERROR] System.ComponentModel.Win32Exception (0x80004005): Fatal error during Installation
   at Veeam.Setup.MsiLibrary.VmMsiCommon.CheckError(VmMsiDatabase db, UInt32 result)
   at Veeam.Setup.MsiLibrary.VmMsiCommon.InstallProduct(String product, String commandLine, Boolean& bReboot)
   at Veeam.Setup.Endpoint.Core.MsiPackageInstaller.InstallWithProgressHandling(IProgressReporter progressReporter, String msiPackage, String commandLine, String logFile)
   at Veeam.Setup.Endpoint.Core.Redists.SqlLocalDbRedist.Install(IProgressReporter progressReporter)
   at Veeam.Setup.Endpoint.Core.RedistManager.InstallWithProgressHandling(IProgressReporter progressReporter)
   at Veeam.Setup.Endpoint.Core.InstallerEngine.Install(IProgressReporter progressReporter)
[23.11.2015 12:41:05][ERROR] Installation failed.
[23.11.2015 12:41:05][INFO] InstallerEngine session completed. Result = Failed


I read that some had similar problems and solved them by rebooting the system prior to install. That did not help in my case.
Uninstalling and repair of the "SQL Server LocalDB" was also not possible from Windows.

What solved the problem for me was a solution I found here on the forum for a different issue with SqlLocalDB. After downloading PsTools I was able to delete the VeeamEndPoint Database (CASE A in the linked thread)

After a reboot the Installation went through without any issues. The only backdraw was that on the initial backup VEB was not able to recognize the existing backup and did a new full backup in a new Directory, instead of just the increment.
TechImpossible
Lurker
 
Posts: 1
Liked: 2 times
Joined: Mon Nov 23, 2015 11:26 pm

Re: Error updating to version 1.1.2.119

Veeam Logoby PTide » Tue Nov 24, 2015 7:52 am

Hi,

Thanks for sharing! Actually, that looks like a bug. Have you considered opening a ticket with our support team so they could conduct a deeper investigation of your case and fix the problem? If you decide to contact support kindly post your case ID here.

Thank you!
PTide
Veeam Software
 
Posts: 3019
Liked: 246 times
Joined: Tue May 19, 2015 1:46 pm


Return to Veeam Agent for Windows



Who is online

Users browsing this forum: Yahoo [Bot] and 4 guests