Standalone backup agent for Microsoft Windows servers and workstations (formerly Veeam Endpoint Backup FREE)
Post Reply
MarkusLoyen
Novice
Posts: 4
Liked: never
Joined: Nov 28, 2019 12:30 pm
Full Name: Markus Loyen
Contact:

Illegal character in path open backup for restore

Post by MarkusLoyen » Nov 28, 2019 12:35 pm

SupportCase ID: 03886558

After the latest updates from Windows I am not longer capable of opening backups stored on a CIFS share.
the Agent quits by telling: Illegal character in path (Illegales Zeichen im Pfad).

Backups still work, and are restoreable when being saved to a usb drive etc.

Copying from CIFS to USB fails too, but revovery via Virtual Machine with ISO Recovery Image and an USB drive works like charm.

So this seems to be kind of problem of the agent and the operating system (e.g. one of the runtime dll) anyone experienced this too and give some assistance?
Or is this a bug?

Dima P.
Product Manager
Posts: 10870
Liked: 897 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Illegal character in path open backup for restore

Post by Dima P. » Nov 28, 2019 7:25 pm

Hello Markus,

Mind me asking how you open a backup in your CIFS location (via restore wizard or by double clicking the backup file)? Thanks!

MarkusLoyen
Novice
Posts: 4
Liked: never
Joined: Nov 28, 2019 12:30 pm
Full Name: Markus Loyen
Contact:

Re: Illegal character in path open backup for restore

Post by MarkusLoyen » Nov 28, 2019 8:45 pm

Double Clicking vbm, vbk... not working.... :-(

Funny to see that the Restore Wizard seems work :-)

MarkusLoyen
Novice
Posts: 4
Liked: never
Joined: Nov 28, 2019 12:30 pm
Full Name: Markus Loyen
Contact:

Re: Illegal character in path open backup for restore

Post by MarkusLoyen » Dec 14, 2019 5:50 pm

Hi Guys,

After having investigated myself, this is a problem of the latest Windows 10 and most likely also the latest Veeam Backup Agent. (Not willing to dig a lot deeper at the moment)

I can reproduce the problem/ the behavior at all times and also on a different PC outside my environment (my neighbor):

First start a command shell with elevated rights (admin) and you will notice: where are my CIFS-Shares?.All gone.. Feels a little bit like: not my PC....
Then mount the exact shares with

e.g. net use /persistent:yes y: \\server\share

Then double-click one of your *.vbm or *.vbk etc. files from the normal explorer.exe on that share (still mounted under you "normal user"). Veeam Restore will start (with elevated) rights. Windows will ask you again for the credentials of the share und all works like charm.

From now on Credentials are requested every time after Veeam Restore is started by double-clicking

So now it is on you (Support@ Veeam) to determine if this is a bug in Veeam or in Windows... Please let me know...

MarkusLoyen
Novice
Posts: 4
Liked: never
Joined: Nov 28, 2019 12:30 pm
Full Name: Markus Loyen
Contact:

Re: Illegal character in path open backup for restore

Post by MarkusLoyen » Dec 14, 2019 5:51 pm

One addition: Doing it from the GUI providing the credentials works everytime....

Dima P.
Product Manager
Posts: 10870
Liked: 897 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Illegal character in path open backup for restore

Post by Dima P. » Dec 15, 2019 4:25 pm

Hello Markus,

Can confirm that an improvement request has been noted based on the investigation results. The issue is related to the path not being resolved correctly when you do a double-click on the backup file at the remote location (i.e. file share). For now, indeed, the best workaround for a backup stored on a file share would be to start a restore via Veeam Agent Control Panel > main menu > backup job name > desired type of restore. Thanks!

Post Reply

Who is online

Users browsing this forum: No registered users and 10 guests