Standalone backup agent for Microsoft Windows servers and workstations (formerly Veeam Endpoint Backup FREE)
Post Reply
aich365
Service Provider
Posts: 269
Liked: 20 times
Joined: Aug 10, 2016 11:10 am
Full Name: Clive Harris
Contact:

System Requirements .NET Framework

Post by aich365 »

From published system requirements
In VAW 3.0 - Microsoft .NET Framework 4.6 - https://helpcenter.veeam.com/archive/ag ... efore.html
In VAW 4.0 - Microsoft .NET Framework 4.7.2 - https://helpcenter.veeam.com/archive/ag ... efore.html
In VAW 5.0 - Microsoft .NET Framework 4.5.2 - https://helpcenter.veeam.com/docs/agent ... tml?ver=50

If we already have version 4.7.2 will VAW 5.0 work OK ?

Thanks

Natalia Lupacheva
Veeam Software
Posts: 597
Liked: 139 times
Joined: Apr 27, 2020 12:46 pm
Full Name: Natalia Lupacheva
Contact:

Re: System Requirements .NET Framework

Post by Natalia Lupacheva »

Hi Clive,

Yes, Veeam Agent for Windows is compatible with .NET 4.7.2 also. It supports 4.5.2 and higher versions.
The requirement was downgraded to provide compatibility with 4.5.2.

Thanks!

aich365
Service Provider
Posts: 269
Liked: 20 times
Joined: Aug 10, 2016 11:10 am
Full Name: Clive Harris
Contact:

Re: System Requirements .NET Framework

Post by aich365 »

OK thanks

masonit
Service Provider
Posts: 274
Liked: 17 times
Joined: Oct 09, 2012 2:30 pm
Full Name: Magnus
Contact:

Re: System Requirements .NET Framework

Post by masonit »

Hi!

Our agent backups is managed from a vbr server (10.0.1.4854) with protection groups. In preparation for upgrading to V11 we now need to upgrade some older agents (version 3.x). Big hassle with upgrading agents is the .net framework requirements. What are my options now? From what I understand I need to upgrade older agents to version 4 to be able to upgrade vbr to v11..? But vaw 4 and requirements of .net 4.7.2 will require some .net framework upgrades and restarts. Would be alot better to upgrade directly to vaw 5 with lower .net requirements. But I guess that is not an option with the vbr version we have?

Also, is it possible from vbr server to see what .net version that is installed on agents? I can't find it in vbr gui. But maybe it is collected in some logs in the vbr server?

\Magnus

Mildur
Veeam Legend
Posts: 674
Liked: 307 times
Joined: May 13, 2017 4:51 pm
Full Name: Fabian Kessler
Contact:

Re: System Requirements .NET Framework

Post by Mildur »

You should be able to upgrade from 3.x to 5.x on Veeam V11.
It's not possible to create a backup, but the upgrade process will work.

servers-workstations-f49/vbr11-supporte ... 72511.html

How many Agents do you have?

masonit
Service Provider
Posts: 274
Liked: 17 times
Joined: Oct 09, 2012 2:30 pm
Full Name: Magnus
Contact:

Re: System Requirements .NET Framework

Post by masonit »

We have 30 agents on version 3.x. But am I able to upgrade vbr to v11 when there is unsupported agents?

Mildur
Veeam Legend
Posts: 674
Liked: 307 times
Joined: May 13, 2017 4:51 pm
Full Name: Fabian Kessler
Contact:

Re: System Requirements .NET Framework

Post by Mildur »

Yes, you can upgrade to V11.
But backups will not work.

You need to Upgrade the agents to V 5.0 right away after the Upgrade to Veeam V11.

masonit
Service Provider
Posts: 274
Liked: 17 times
Joined: Oct 09, 2012 2:30 pm
Full Name: Magnus
Contact:

Re: System Requirements .NET Framework

Post by masonit »

ok, thanks!

What about my other question, is it possible to see .net version in an easy way?

Mildur
Veeam Legend
Posts: 674
Liked: 307 times
Joined: May 13, 2017 4:51 pm
Full Name: Fabian Kessler
Contact:

Re: System Requirements .NET Framework

Post by Mildur »

No Problem. Your Agents will need a reboot, if the CBT Driver is installed. I'm not sure, if it need one without the CBT driver. You have to schedule a maintenance window.

I don't know the answer about the .NET Framework.
You may be able to query the version with powershell:
https://www.powershelladmin.com/wiki/Li ... _computers

Dima P.
Product Manager
Posts: 12378
Liked: 1146 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: System Requirements .NET Framework

Post by Dima P. »

Hi folks,

There is no way to gather .Net version information via Veeam B&R, but, as Fabian mentioned, you can do that via scripts. Generally all latest OS should have 4.5.x and above: What version of the .NET Framework is included in what version of the OS?. For Windows 7SP1/2008R2 we've performed several tests in the labs and can confirm that build-in windows update functionality automagically patches .Net version up to 4.6.x

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests