Maintain control of your Microsoft Office 365 data
Post Reply
Jmiker919
Influencer
Posts: 11
Liked: never
Joined: Nov 10, 2016 2:14 pm
Full Name: Mike Rodgers
Contact:

Upgraded repository now mailbox processing fails

Post by Jmiker919 »

Got a few days' notice that the repository was out of date and needed to be upgraded (I don't check the system every day) so I upgraded it at 1:55pm yesterday. Went very fast, confirmation it completed. At 2:05pm an incremental retry started failing on the mailboxes.

The mailbox backups are failing with "Processing mailbox 'username' failed with error: The remote server returned an error: (401) Unauthorized." There are nine mailboxes and they all fail, but the Sharepoint sites do back up successfully.

Same logon account, as far as I can see nothing else has changed. Is there anything else I need to "upgrade"?

Thanks,
Mike

HannesK
Veeam Software
Posts: 7626
Liked: 1306 times
Joined: Sep 01, 2014 11:46 am
Location: Austria
Contact:

Re: Upgraded repository now mailbox processing fails

Post by HannesK »

Hello,
That sounds like a technical issue. Please provide a support case ID for this issue, as requested when you click New Topic.

Without case number, the topic will eventually be
deleted by moderators
.

Best regards,
Hannes

Mike Resseler
Product Manager
Posts: 6819
Liked: 901 times
Joined: Feb 08, 2013 3:08 pm
Full Name: Mike Resseler
Location: Belgium
Contact:

Re: Upgraded repository now mailbox processing fails

Post by Mike Resseler »

Hi Mike,

Hannes is correct, please create a support call. At what version number are you? Please check this KB: https://www.veeam.com/kb4124

Polina
Veeam Software
Posts: 1730
Liked: 351 times
Joined: Oct 21, 2011 11:22 am
Full Name: Polina Vasileva
Contact:

Re: Upgraded repository now mailbox processing fails

Post by Polina »

@Jmiker919

Check if the Azure AD application you use for backup is still assigned with the full_access_as_app permission. This permission has been recently moved to Office 365 Exchange Online API and, in some cases, it seems that it may be removed from the backup app and needs to be reassigned.

Jmiker919
Influencer
Posts: 11
Liked: never
Joined: Nov 10, 2016 2:14 pm
Full Name: Mike Rodgers
Contact:

Re: Upgraded repository now mailbox processing fails

Post by Jmiker919 »

I forgot to mention I'm running the latest Community Edition, doesn't that preclude me from opening a support case?

And, Polina, I'm thinking the upgrade must have wiped out the Azure ID, I have help pages open to re-add one. Thanks.

Mike Resseler
Product Manager
Posts: 6819
Liked: 901 times
Joined: Feb 08, 2013 3:08 pm
Full Name: Mike Resseler
Location: Belgium
Contact:

Re: Upgraded repository now mailbox processing fails

Post by Mike Resseler »

@Jmiker919

Having CE still gives you mail support, but without any SLA and on a best effort basis

Jmiker919
Influencer
Posts: 11
Liked: never
Joined: Nov 10, 2016 2:14 pm
Full Name: Mike Rodgers
Contact:

Re: Upgraded repository now mailbox processing fails

Post by Jmiker919 »

Good grief. I got it resolved, but I don't know what failed. I wound up having to manually add two API permissions (and I don't recall having to ever add any to begin with) and creating a new app password. When editing the organization profile it was failing when it was authenticating.

After adding Powershell and Exchange Online API permissions it would connect to Sharepoint and Powershell Online, but not Graph or EWS. After adding a new app password and giving it some time it finally went to working.

Thanks for working with me.

Mike Resseler
Product Manager
Posts: 6819
Liked: 901 times
Joined: Feb 08, 2013 3:08 pm
Full Name: Mike Resseler
Location: Belgium
Contact:

Re: Upgraded repository now mailbox processing fails

Post by Mike Resseler »

Mike,

Good to know it is solved!

Thanks for letting us know
Cheers
Another Mike

Post Reply

Who is online

Users browsing this forum: rpeterson and 5 guests