Comprehensive data protection for all workloads
Post Reply
pizang
Enthusiast
Posts: 61
Liked: never
Joined: Aug 02, 2009 7:33 pm
Contact:

64bit VCB proxy - read before use

Post by pizang »

Some time ago I have posted a problem with a job that shows error "Not enough space" (http://www.veeam.com/forums/viewtopic.php?f=2&t=1794). Veeam support answered that it is not a space problem but memory one. They also suggested not to run concurrent jobs. Backup job couldn't allocate memory necessary to do it's work. It was strange as I was using 64 bit system and 8GB of memory. I have corrected virtual memory settings and after 1 day I had exactly the same problem. I have connected to the server and to my surprise I have seen that whole memory is eaten by system cache (7,5 from 8 GB!). It was clear that something wrong happened as SQL Server occupied only 66MB of RAM as in normal condition it takes 10 times more.

I started to goggle. In 32 bit kernel memory space is limited so system cache is limited to about 1GB. In 64 bit system there is no such a limit. System cache can grow to enormous size when extensive IO happens - and this is a scenario I have noticed.

Please read http://blogs.msdn.com/ntdebugging/archi ... cache.aspx for further information.

I have installed Windows Dynamic Cache Service and change its settings to match my system (max cache memory = 4GB). Since then my backups works well even that I have concurrent jobs. You can download this program here http://www.microsoft.com/downloads/deta ... laylang=en

Vitaliy S.
Product Manager
Posts: 24355
Liked: 1897 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: 64bit VCB proxy - read before use

Post by Vitaliy S. »

Hello Miroslaw,

Thank you very much for posting the resolution for the issue.

Post Reply

Who is online

Users browsing this forum: allanh, Bing [Bot], foggy, oleg.feoktistov, OstDyr and 75 guests