automount disabled and WinServer 2008 SP1 intall problem

Availability for the Always-On Enterprise

automount disabled and WinServer 2008 SP1 intall problem

Veeam Logoby ctchang » Sat Feb 26, 2011 4:16 am

http://windows.microsoft.com/en-US/wind ... 0x800F0A12

1.Click the Start button , and in the search box, type command prompt.

2.In the list of results, right-click Command Prompt, and then click Run as administrator. If you're prompted for an administrator password or confirmation, type the password or provide confirmation.

3.Type mountvol /E and press Enter.

4.Restart your computer, and then try installing SP1 again.


1.Click the Start button , and in the search box, type command prompt.

2.In the list of results, right-click Command Prompt, and then click Run as administrator. If you're prompted for an administrator password or confirmation, type the password or provide confirmation.

3.Type mountvol /E and press Enter.

4.Restart your computer, and then try installing SP1 again.


and also http://blogs.technet.com/b/joscon/archi ... f0a12.aspx


My question is I don't want to corrupt my VMDK partition by enabling the automount, but I also want to successfully install W2K8 SP1.

The only way I can think of is to disconnect all the iSCSI connection to my EQL SAN, then enable automount (btw, do I need to DISABLE it again later), then reboot, then install SP1, then DISABLE automount, then re-connect the iSCSI VMDK volume.

Any hint on this?
ctchang
Expert
 
Posts: 115
Liked: 1 time
Joined: Wed Sep 15, 2010 3:12 pm

Re: automount disabled and WinServer 2008 SP1 intall problem

Veeam Logoby ctchang » Sat Feb 26, 2011 4:17 am

Another question is with automount disabled, will I still able to use USB harddisk?
What step do I need to do in order to see the attached USB harddisk?
Thanks.
ctchang
Expert
 
Posts: 115
Liked: 1 time
Joined: Wed Sep 15, 2010 3:12 pm

Re: automount disabled and WinServer 2008 SP1 intall problem

Veeam Logoby Gostev » Sat Feb 26, 2011 11:12 am

Yes, outlined above might be a good approach for upgrading to SP1. Disabling automount does not prevent you using any volumes. If you plug-in new USB stick, you will simply need to mount it manually via Disk Management snap-in. Thanks.
Gostev
Veeam Software
 
Posts: 21047
Liked: 2267 times
Joined: Sun Jan 01, 2006 1:01 am
Full Name: Anton Gostev

Re: automount disabled and WinServer 2008 SP1 intall problem

Veeam Logoby ctchang » Sat Feb 26, 2011 12:25 pm

I understand mountvol /E is to enable automount again.
So after I've upgraded SP1, I need to DISABLE automount again right?
and the command is mountvol /N ?
ctchang
Expert
 
Posts: 115
Liked: 1 time
Joined: Wed Sep 15, 2010 3:12 pm

Re: automount disabled and WinServer 2008 SP1 intall problem

Veeam Logoby ctchang » Sat Feb 26, 2011 12:29 pm

Microsoft Windows [Version 5.2.3790]
(C) Copyright 1985-2003 Microsoft Corp.

C:\Documents and Settings\Administrator>automount
'automount' is not recognized as an internal or external command,
operable program or batch file.

C:\Documents and Settings\Administrator>diskpart

Microsoft DiskPart version 5.2.3790.3959
Copyright (C) 1999-2001 Microsoft Corporation.
On computer: GATEWAY

DISKPART> automount

Automatic mounting of new volumes enabled.

DISKPART> automount disable

Automatic mounting of new volumes disabled.

DISKPART>


I found I DO NOT need to restart my server to disable/enable automount, is it necessary to restart the server everytime I change the automount setting?

Thx,
ctchang
Expert
 
Posts: 115
Liked: 1 time
Joined: Wed Sep 15, 2010 3:12 pm

Re: automount disabled and WinServer 2008 SP1 intall problem

Veeam Logoby ctchang » Sat Feb 26, 2011 2:21 pm

Answering my own question and hope this helps others. You do have to reboot multiple times, I've tried the short cut by not reboot the server after typing automount enable and encountered sp1 installation failed after reboot.

I've encountered a problem when installing Windows Server 2008 R2 SP1 today and found the reason and solution pretty easy. It was due to Veeam B&R v5.0 automatically Disabled automount for SAN mode and W2K8 R2 SP1 requires automount to be enabled.

Solution:

1. Disconnect all active iSCSI connections and REMOVE the Target Portal from iSCSI favourite tab.

2. From command prompt, issue the followings:
> diskpart
> automount enable

3. Reboot the server then go ahead and upgrade your W2K8 R2 with SP1, it will take about 50 minutes to complete, yes, it did take that long even on latest powerful server.

4. Then issue the following AFTER reboot:
> diskpart
> automount disable

5. Reboot the last time and then re-establish all previous iSCSI connections as usual.


So there is no short cut.
ctchang
Expert
 
Posts: 115
Liked: 1 time
Joined: Wed Sep 15, 2010 3:12 pm

Re: automount disabled and WinServer 2008 SP1 intall problem

Veeam Logoby payneful » Mon Feb 28, 2011 8:40 pm

Windows 2008 R2 Service Pack 1 only needs temporay access to the system partition which is prevented with automount disabled.
I installed the service pack as follows: (Drive J can be any free drive letter not used).

1. At command promtp: Type "mountvol /? "(This will display help and will also list volumes). Identify system partition (will not have drive letter) ie: \\?\Volume{9be074ce-d55f-11df-83d7-806e6f6e6963}
2. Mount a temporary drive letter to the system partion "mountvol j:/ \\?\Volume{9be074ce-d55f-11df-83d7-806e6f6e6963}" (Enter your own system partition guid).
3. Run SP 1 update and restart.
4. Dismount temporary drive "mountvol j: /d".
Done.
payneful
Novice
 
Posts: 3
Liked: 1 time
Joined: Mon Feb 28, 2011 8:25 pm
Full Name: R Payne


Return to Veeam Backup & Replication



Who is online

Users browsing this forum: No registered users and 23 guests