Comprehensive data protection for all workloads
Post Reply
Maddin21
Influencer
Posts: 11
Liked: never
Joined: Jan 19, 2022 8:27 am
Full Name: Martin
Contact:

Components Upgrade - Veeam trying to install wrong components

Post by Maddin21 »

Hi all,

yesterday I applied the patch to our Veeam BR 11a. After this, the components on the proxy, Hyper-V server, Windows Server, Linux hardened repo etc. needed to be updated. We have two Linux repos and both are setup similar. difference is that one is an older hardware server with a lot of disks and the other is a thin-client with attached NAS for storage. The Linux repos have only Installer, Transport, Tape Proxy (not used) and Veeam CDP (not used) as components. This components have been updated but for the first Linux repo Veeam somehow want to update components that are not there.

It says update required for Hyper-V Integration, Veeam Backup VSS Integration and Veeam VSS Hardware Snapshot Provider. All of the three are installed on another managed server.

So I went for an upgrade from v11 to v12 but still the same issue. Veeam wants to upgrade the Linix repo with components that are not there and of course this will end with an error like "Failed to upgrade host components. Error 'Invalid component type FileSystemVssIntegration'". There is no such integration on a Linux system!

Backups and everything is still working but every time the console is opened it says one host (two repositories) are out-of-date.
Mildur
Product Manager
Posts: 8876
Liked: 2341 times
Joined: May 13, 2017 4:51 pm
Full Name: Fabian K.
Location: Switzerland
Contact:

Re: Components Upgrade - Veeam trying to install wrong components

Post by Mildur »

Hello,
That sounds like a technical issue. Please provide a support case ID for this issue, as requested when you click New Topic.
Without case number, the topic will eventually be deleted by moderators.

We cannot analyze such issues over the forum without having access to your environment.

Best regards,
Fabian

PS: support can only help if you upload logs
https://www.veeam.com/kb1832
Product Management Analyst @ Veeam Software
Maddin21
Influencer
Posts: 11
Liked: never
Joined: Jan 19, 2022 8:27 am
Full Name: Martin
Contact:

Re: Components Upgrade - Veeam trying to install wrong components

Post by Maddin21 »

Case #05930741. If there is need to have a remote session, it is possible.
LickABrick
Enthusiast
Posts: 60
Liked: 30 times
Joined: Dec 23, 2019 7:26 pm
Full Name: Lick A Brick
Contact:

Re: Components Upgrade - Veeam trying to install wrong components

Post by LickABrick »

Has this host been used before with a different role (i.e. not a linux repo)? I have seen before that some old entries are left in the Veeam database which makes Veeam want to update components that are not there.
LickABrick
Enthusiast
Posts: 60
Liked: 30 times
Joined: Dec 23, 2019 7:26 pm
Full Name: Lick A Brick
Contact:

Re: Components Upgrade - Veeam trying to install wrong components

Post by LickABrick »

Found the post which helped me at the time: vmware-vsphere-f24/linux-hardened-repo- ... 74304.html (see the second to last comment)
Mildur
Product Manager
Posts: 8876
Liked: 2341 times
Joined: May 13, 2017 4:51 pm
Full Name: Fabian K.
Location: Switzerland
Contact:

Re: Components Upgrade - Veeam trying to install wrong components

Post by Mildur »

@Maddin21
Thank you for the case number. Let‘s see what support finds out.

Best,
Fabian
Product Management Analyst @ Veeam Software
Maddin21
Influencer
Posts: 11
Liked: never
Joined: Jan 19, 2022 8:27 am
Full Name: Martin
Contact:

Re: Components Upgrade - Veeam trying to install wrong components

Post by Maddin21 »

@LickABrick
I´ve already read this post but did not tried the SQL query. Yes, the host have been once used as a Hyper-V server. We got new servers with VMware and migrated all VMs through Veeam. After all VM have been moved this way the old host have been removed from Veeam, degraded and rebuild with Linux as a hardened Repo. This have worked for over a year until the last 11a update and v12 upgrade. This is kinda ridiculous the old host ID in the DB was not removed the time the host have been deleted in Veeam.

I´ll update the case as there is no issue anymore. Thanks for pointing me to the post again ;-)
Mildur
Product Manager
Posts: 8876
Liked: 2341 times
Joined: May 13, 2017 4:51 pm
Full Name: Fabian K.
Location: Switzerland
Contact:

Re: Components Upgrade - Veeam trying to install wrong components

Post by Mildur »

Hi Martin

I'm glad, that your issue is solved.
But I wanted to mention, doing such queries on your own without guidance from our customer support is not supported.
If you face issues related to that query, our customer support may not be able to provide help and will ask you to start with a new configuration database.

Best,
Fabian
Product Management Analyst @ Veeam Software
Post Reply

Who is online

Users browsing this forum: mromriell, SebCharp, streetz and 111 guests