Comprehensive data protection for all workloads
Post Reply
pdxpaulee
Service Provider
Posts: 2
Liked: never
Joined: Feb 15, 2010 9:29 pm
Full Name: Paul Walker
Contact:

Connection actively Refused

Post by pdxpaulee »

Fresh install of 2003 x64 and the Enterprise manager. Every time I try to open up the manager i recieve this error after logging in:

SocketException
No connection could be made because the target machine actively refused it 127.0.0.1:9394

Firewall is off and the services seem to be running.
Any ideas?

thanks
Paul

Gostev
SVP, Product Management
Posts: 26679
Liked: 4268 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Connection actively Refused

Post by Gostev » 1 person likes this post

Paul, generally the "actively refused" errors come up when connection is attempted to wrong port number. But this is just a guess, having full Enteprise Manager logs our support engineers should be able to tell more.

pdxpaulee
Service Provider
Posts: 2
Liked: never
Joined: Feb 15, 2010 9:29 pm
Full Name: Paul Walker
Contact:

Re: Connection actively Refused

Post by pdxpaulee »

I took all the defaults during the install. Where can I find the logs and what should i do with them?

Gostev
SVP, Product Management
Posts: 26679
Liked: 4268 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Connection actively Refused

Post by Gostev »

Paul, please open a support call and our support staff will provide you with all instructions.

TrevorBell
Expert
Posts: 356
Liked: 13 times
Joined: Feb 13, 2009 10:13 am
Full Name: Trevor Bell
Location: Worcester UK
Contact:

Re: Connection actively Refused

Post by TrevorBell »

127.0.0.1 are you sure thats a valid ip adress ? normally that is reserved for ping backs

Gostev
SVP, Product Management
Posts: 26679
Liked: 4268 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Connection actively Refused

Post by Gostev »

Yes, this is valid. What we are seeing here is a connection attempt from the web front-end (ASP .NET) to the Enterprise Manager service.

albertwt
Expert
Posts: 669
Liked: 22 times
Joined: Nov 05, 2009 12:24 pm
Location: Sydney, NSW
Contact:

Re: Connection actively Refused

Post by albertwt »

Hi Trevor,

You're not alone mate, I’m also having problem with accessing the Enterprise manager website interface, has anyone resolved it yet ?

Code: Select all

Server stack trace: at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress) at System.Net.Sockets.Socket.Connect(EndPoint remoteEP) at System.Runtime.Remoting.Channels.RemoteConnection.CreateNewSocket(EndPoint ipEndPoint) at System.Runtime.Remoting.Channels.RemoteConnection.CreateNewSocket() at System.Runtime.Remoting.Channels.SocketCache.GetSocket(String machinePortAndSid, Boolean openNew) at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.SendRequestWithRetry(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream) at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.ProcessMessage(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream, ITransportHeaders& responseHeaders, Stream& responseStream) at System.Runtime.Remoting.Channels.BinaryClientFormatterSink.SyncProcessMessage(IMessage msg) Exception rethrown at [0]: at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type) at Veeam.Backup.Interaction.Reporting.IReportingService.OpenSession(CSessionReConnectInfo& sessionInfo) at UserContext.get_Session() at _Default.RootConfig() at ASP.default_aspx.__Rendercontent(HtmlTextWriter __w, Control parameterContainer) at System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) at ASP.masterpage_master.__Render__control1(HtmlTextWriter __w, Control parameterContainer) at System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) at System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) at System.Web.UI.Page.Render(HtmlTextWriter writer) at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
This is after clean install and I typed the DOMAIN\Administrator credentials in the beginning of this login.

Please let me know in accessing this page or if this product is compatible with Windows Server 2003 Std. x64 R2 SP2 and SQL Server 2008 Std. x64 SP1

Cheers,
AWT
--
/* Veeam software enthusiast user & supporter ! */

Vitaliy S.
Product Manager
Posts: 24243
Liked: 1859 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: Connection actively Refused

Post by Vitaliy S. »

Albert,

Yes, this is fully compatible with your setup. Have you had a chance to open a support ticket with us? We may require all the logs from the Enterprise Manager application to see what might be the reason for your issue. Please send us VeeamBES.log to support@veeam.com for investigation. You can find the log path listed on the Configuration|About page of the web UI, for me it is:

Code: Select all

C:\Documents and Settings\Administrator\Local Settings\Application Data\Veeam\Backup\VeeamBES.log
Thank you!

albertwt
Expert
Posts: 669
Liked: 22 times
Joined: Nov 05, 2009 12:24 pm
Location: Sydney, NSW
Contact:

Re: Connection actively Refused

Post by albertwt »

thanks Vitaly,

Yes I have but i forgot to include the log file.

I specified the wrong SQL username Localvcenter\SQLService during the installation and now the Backup process doesn’t work, can you please help me how to grant DOMAIN\SQLService user into the Veeambackup DB

Here it is the error message:
Cannot open database "VeeamBackup" requested by the login. The login failed.Login failed for user 'KENWORTH\SQLService'.

This might got something to do with my other problem which I cannot access the web interface of
https://kenworth:9443/ Error.aspx?id=bfeb79b7233a419cbd5318a9f8ff2e14#1267601424162
--
/* Veeam software enthusiast user & supporter ! */

albertwt
Expert
Posts: 669
Liked: 22 times
Joined: Nov 05, 2009 12:24 pm
Location: Sydney, NSW
Contact:

Re: Connection actively Refused

Post by albertwt »

Hi All,

I resolve this problem after the tech support send me email to replace the service user account.

go to services.msc and find Veeam Backup and FastSCP service, here you can easily specify the user account required.

Cheers.
--
/* Veeam software enthusiast user & supporter ! */

smudger
Novice
Posts: 9
Liked: 3 times
Joined: Nov 06, 2009 4:35 pm
Full Name: Neil Smith
Contact:

Re: Connection actively Refused

Post by smudger »

Hi,

While we haven't hit this problem directly, it appears the Veeam UI can only be successfully started and used by the Windows Service account which has either installed the product, or is running the Veeam Backup & Replication service. Is this by design?

I'd like to have other Windows users permissioned to at least startup the application. Currently starting the Veeam UI for any other user than the account used to run the services I get "Failed to connect to server sqlservername. Login failed for user domainname\username"

So from this it looks like permissioning within SQL - what rights are needed for other application users to start and use the application?

Thanks in advance,

Neil

Gostev
SVP, Product Management
Posts: 26679
Liked: 4268 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Connection actively Refused

Post by Gostev »

Neil, you should grant some role to those other user accounts using the Users and Roles dialog in Veeam Backup UI.

gh0stwalker
Novice
Posts: 8
Liked: never
Joined: Apr 21, 2010 2:11 am
Full Name: Dan Snape
Contact:

Re: Connection actively Refused

Post by gh0stwalker »

We have run in to a similar situation to Neil (smudger). When i log in to the server as the same user that installed the application and runs the services, all works OK. When i login to the server as another account (exactly the same permissions- AD and SQL- as the veeam service account) we get the following error when trying to start Veeam Backup and replication.

Execute with results failed for Database 'VeeamBackup'
An exception occurred while executing a Transact-SQL statement or batch.
The server principal "DOMAIN\USER" is not able to access the database VeeamBackup under the current security context


Permissions have been given to the other accounts using the Users and Roles dialog in Veeam Backup UI, so that's not the problem

Our DBA's seem to think that the Veeam is trying to run some sort of query on the master SQL DB. Is that the case and how do we get around this issue

Dan

smudger
Novice
Posts: 9
Liked: 3 times
Joined: Nov 06, 2009 4:35 pm
Full Name: Neil Smith
Contact:

Re: Connection actively Refused

Post by smudger »

Dan,

Our DBA's ran some traces on the Veeam DBs and we estabalished despite users being permissioned in the Veeam UI access was being denied to the SQL DB for these users ie. The service account running the application has rights, hence being able to login and use the app yet being denied with other accounts.

Our solution has been to permission the SQL DB with an AD group which grants enough rights for the UI to function (Appropiate users then added to the aforementioned AD group) and all is now good.

I don't believe this configuration to be exotic or complicated, and there is no way in our environment we can expect Support staff to login and run backups/restores using a highly priv'd service account.

I'd lke to see Veeam document this part of the installation process, or have a best practise guide on how the application interacts with SQL (or similar). We've burnt some hours investigating the correct way to do this for our proxy hosts. As you mention, face value is to add users via the "Users & Roles" dialog but this does not seem to work.
Is this by design or a bug?

Thanks,

Neil

gh0stwalker
Novice
Posts: 8
Liked: never
Joined: Apr 21, 2010 2:11 am
Full Name: Dan Snape
Contact:

Re: Connection actively Refused

Post by gh0stwalker »

Thanks Neil,

Do you have details of the SQL permissions needed, and if it's only required on the VeeamBackup DB? I pretty sure we tested giving permissions to this DB to a user, but it still failed, and the DBA's indicated that there may have been some sort of query run against the master DB. I'll get them to do another test anyway.

I hope this is fixed up in a future release, or at least documented as we are in the same boat as you in that we don't want to use the veeam service account to login to the veeam server.

Thanks again
Dan

Gostev
SVP, Product Management
Posts: 26679
Liked: 4268 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Connection actively Refused

Post by Gostev »

No worries, I've already asked devs/QC early today to try to confirm this issue. Will update when I know more.

AlexLeadingEdge
Expert
Posts: 350
Liked: 43 times
Joined: Dec 14, 2015 9:42 pm
Contact:

Re: Connection actively Refused

Post by AlexLeadingEdge »

I just had this exact same problem! After upgrading from version 8 to version 9 I went to check that all the settings were correct and got the "connection actively refused" warning in red writing. Closing the Console and opening it again changed the port numbers automatically! The first time the port said 3935 and after opening it again it is now 3932. Seems to be working perfectly now.

I really was starting to panic that the install had failed! Not nice giving this poor SysAdmin a heart attack!!!

AlexLeadingEdge
Expert
Posts: 350
Liked: 43 times
Joined: Dec 14, 2015 9:42 pm
Contact:

Re: Connection actively Refused

Post by AlexLeadingEdge »

Sorry, those ports were 9395 and then 9392.

Post Reply

Who is online

Users browsing this forum: No registered users and 32 guests