Comprehensive data protection for all workloads
Post Reply
fgw
Enthusiast
Posts: 83
Liked: 2 times
Joined: Jun 11, 2009 8:39 pm
Full Name: Franz Glatzer
Contact:

error after upgrading to 4.1

Post by fgw » Dec 16, 2009 4:13 pm

just upgraded from 4.0 to 4.1

upgrade itself went smoothly
upgraded two servers. as one of them also has enterprise manager installed and it aksed me to reboot after upgrading enterprise manager i decided to simply reboot bopth of the servers.

after reboot, upon login a window pops up with the following msg:

VeeamAgent encountered a problem and needed to
close.

This error occured on ...

For more info click here


clicking here pops up another window with the following info ...

Error signature

szAppName : VeemAgent.exe szAppVer : 4.0.0.80
szModName : VeemAgent.exe szModVer : 4.0.0.80 offset : 001b981d

To view technical info ...


anybody seen this too?

Gostev
SVP, Product Management
Posts: 24939
Liked: 3622 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: error after upgrading to 4.1

Post by Gostev » Dec 16, 2009 11:25 pm

4.0.0.80 is build number of 4.0 release, so it does not look like the upgrade went well.

beyondnines
Lurker
Posts: 1
Liked: never
Joined: Dec 17, 2009 6:20 am
Full Name: Nobody

Re: error after upgrading to 4.1

Post by beyondnines » Dec 17, 2009 6:34 am

I also got an error after upgrading and am now left with a broken setup. Also, you guys removed version 4.0 (and every other version) from the website. It would be more convenient if you left older versions for download in case somebody needs them in situations like this.

antivir
Enthusiast
Posts: 63
Liked: never
Joined: Nov 04, 2009 2:39 pm
Full Name: Andrew
Contact:

Re: error after upgrading to 4.1

Post by antivir » Dec 17, 2009 6:38 am


Vitaliy S.
Product Manager
Posts: 23070
Liked: 1582 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: error after upgrading to 4.1

Post by Vitaliy S. » Dec 17, 2009 10:02 am

Hello Franz,

Can you tell us please whether you were successfull or nor in starting any jobs after that? Do you see this error confirming each time you login to the server?

Vitaliy S.
Product Manager
Posts: 23070
Liked: 1582 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: error after upgrading to 4.1

Post by Vitaliy S. » Dec 17, 2009 10:05 am

Glen,

What type of error did you get after an upgrade? Does it look like the same that Franz experienced? Or an upgrade hadn't finished successfully at all?
If yes, could you please send us the setup log from %TEMP% folder to support@veeam.com, so we could investigate your issue.

Gostev
SVP, Product Management
Posts: 24939
Liked: 3622 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: error after upgrading to 4.1

Post by Gostev » Dec 17, 2009 10:54 am

Pretty much the only possible reason why agent did not get updated is because some job started or was running during the upgrade (which is against the upgrade procedure listed in the Release Notes document). So its EXE file was locked and did not properly update.

In all cases, uninstalling and re-installing version 4.1 will help in all cases. And all configuration will be preserved as long as you point the setup to the same SQL instance.

fgw
Enthusiast
Posts: 83
Liked: 2 times
Joined: Jun 11, 2009 8:39 pm
Full Name: Franz Glatzer
Contact:

Re: error after upgrading to 4.1

Post by fgw » Dec 18, 2009 1:37 pm

gostev, vitaly,

i agree, version 4.0.0.80 is related to v4.0 and it makes sense when you ask if something was still running when i upgraded veeam backup and the corresponding file might have been locked thus not upgraded.

i have read the release notes and checked the jobs before i started the upgrade. there were no jobs running when i started the upgrade. also i have not yet scheduled any jobs. start them all still manually.

also there were no signs of any error during the upgrade itself. everything went smoothly.

could it be that the service was not sopped during the upgrade process and thus locking an image?

yes, i can successfully start jobs. there aro no signs of a problem!

the errormsg pooped up on the first login after the upgrade only! no errormsg on subsequent logins.

starting veam backup and clicking help -> about the version number shown is 4.1. so it looks like at least the gui part was upgraded sucessfully.

ps logged a service call also: Ticket#517759

could you pls specific the location of logfiles (temp?) in more detail: will supply whatever logs you are asking ...

Gostev
SVP, Product Management
Posts: 24939
Liked: 3622 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: error after upgrading to 4.1

Post by Gostev » Dec 18, 2009 1:41 pm

fgw wrote:the errormsg pooped up on the first login after the upgrade only! no errormsg on subsequent logins
Ah, in that case, I know what was the reason. Crash happened earlier - Windows simply notifies about crashes upon the next reboot. Our QC lead told me that this was another most likely reason after I first talked to him about your issue. But I did not post this because I thought the crash happens every time (which is "expected" if agent indeed did not get updated correctly to 4.1, while all other components were updated).

fgw
Enthusiast
Posts: 83
Liked: 2 times
Joined: Jun 11, 2009 8:39 pm
Full Name: Franz Glatzer
Contact:

Re: error after upgrading to 4.1

Post by fgw » Dec 18, 2009 2:03 pm

Gostev wrote:I know what was the reason. Crash happened earlier - Windows simply notifies about crashes upon the next reboot.
so this was just a notification from windows, telling me that veem backup 4.0 had crashed some time before (for what reason ever?), but was not related to the upgrade and not related to version 4.1.

i can sefely ignore it?

if so, could you pls contact the person working on my Ticket#517759 to clarify this and probably close the ticket ...

Gostev
SVP, Product Management
Posts: 24939
Liked: 3622 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: error after upgrading to 4.1

Post by Gostev » Dec 18, 2009 2:09 pm

Yes, that is correct - it crashed at some point, but the Veeam Backup server was never rebooted after that, so you only saw this message after reboot required by upgrade. You can ignore it. To be on the safe side, find veeamagent.exe file in the Veeam Backup installation folder, right-click it and verify its version in the Properties tab.

fgw
Enthusiast
Posts: 83
Liked: 2 times
Joined: Jun 11, 2009 8:39 pm
Full Name: Franz Glatzer
Contact:

Re: error after upgrading to 4.1

Post by fgw » Dec 18, 2009 2:27 pm

Gostev wrote:Yes, that is correct - it crashed at some point, but the Veeam Backup server was never rebooted after that, so you only saw this message after reboot required by upgrade. You can ignore it. To be on the safe side, find veeamagent.exe file in Veeam Backup installation folder, right-click it and verify its version in the Properties tab.
veeamagent.exe is of the correct version: 4.1.0.96

anyway, funny thing is that i got this on both servers i upgraded. so this crash must have happend on both servers.

but if the version on the images is correct, and i checked all exe's in the veeam folder to be version 4.1.0.96 AND veeam backup is working without problems as it is rigth now i tend to ignore this and move on ...

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 13 guests