Comprehensive data protection for all workloads
Post Reply
Spad
Influencer
Posts: 18
Liked: never
Joined: Nov 05, 2009 8:06 am
Full Name: Adam Beardwood
Contact:

Errors with Enterprise Manager

Post by Spad » Sep 10, 2010 9:28 am

Due to circumstances beyond our control we've had to rebuild the server hosting Enterprise Manager (4.1.2); we've done a reinstall, reattached it to the old database using the same server names and accounts and all appears well until you login at which point you get one of the following errors:

If you're connected locally, it's: SocketException: No connection could be made because the target machine actively refused it 127.0.0.1:9394

If you're connected remotely, it's: Exception Details: System.Security.Cryptography.CryptographicException: Padding is invalid and cannot be removed.

VeeamBES.log shows:

Code: Select all

Starting new log
Log has been started by 'PCT\_vmware' user (Non-interactive)
Logging level is 4 (AboveNormal)
OS: Microsoft Windows NT 6.1.7600.0
Module: C:\Program Files (x86)\Veeam\Enterprise Manager\Veeam.Backup.EnterpriseService.exe. File version: 4.1.2.125, Assembly version: 4.0.0.0
CPU: Intel(R) Xeon(R) CPU           E5450  @ 3.00GHz
Memory: 2.00 GB
Network Interface, Name: Production LAN, Description: vmxnet3 Ethernet Adapter, Interface Type: Ethernet, Operational Status: Up;
    Unicast IPAddresses: fe80::9fd:824e:512c:88d6%12; 192.168.2.93;
    Gateway IPAddresses: 192.168.2.1;
Network Interface, Name: Loopback Pseudo-Interface 1, Description: Software Loopback Interface 1, Interface Type: Loopback, Operational Status: Up;
    Unicast IPAddresses: ::1; 127.0.0.1;
Network Interface, Name: isatap.pct.xwolverhampton.nhs.uk, Description: Microsoft ISATAP Adapter, Interface Type: Tunnel, Operational Status: Down;
    Unicast IPAddresses: fe80::5efe:192.168.2.93%13;
Network Interface, Name: Local Area Connection* 9, Description: Microsoft Teredo Tunneling Adapter, Interface Type: Tunnel, Operational Status: Down;
    Unicast IPAddresses: fe80::100:7f:fffe%11;

[10.09.2010 10:14:28] <05> Info     Default lifetime metrics. Initial time: [5 min], renew on call time: [2 min], sponsorship timeout: [2 min]
[10.09.2010 10:14:28] <05> Info  Sql parameters: localhost; VEEAM; VeeamBackupReporting
[10.09.2010 10:14:28] <05> Info  Sql parameters: WVPSQL1A; ; VeeamBackupReporting
[10.09.2010 10:14:28] <05> Info     Database params: [Server: [WVPSQL1A], Instance name: [], Instance port: [-1], Initial catalog: [VeeamBackupReporting], User: [current], Enable multiple active resultsets: [True]], Web settings: [Enterprise server port: [9394], Collect session retention period: [7 day(s)], Periodically garbage collect: [False], Backup servers accessibility timeout: [3 min]], Settings: [SqlExec data import: [300 sec], Collect job activity interval: [33 sec], Ping backup server on add: [1 sec], Ping backup servers periodically: [4 sec], Activity graph negligible period factor: [144]]
[10.09.2010 10:14:28] <05> Info  Current DB version is 66
[10.09.2010 10:14:28] <05> Info  Trying to find update script in C:\Program Files (x86)\Veeam\Enterprise Manager\ReportingDBUpdate.sql
[10.09.2010 10:14:28] <05> Info  Update version is 66
[10.09.2010 10:14:29] <05> Error    System.Security.Cryptography.CryptographicException: Key not valid for use in specified state.
[10.09.2010 10:14:29] <05> Error       at System.Security.Cryptography.ProtectedData.Unprotect(Byte[] encryptedData, Byte[] optionalEntropy, DataProtectionScope scope)
[10.09.2010 10:14:29] <05> Error       at Veeam.Backup.Common.CryptoHelper.Unprotect(String encryptedString, String& str)
[10.09.2010 10:14:29] <05> Error       at Veeam.Backup.Reporting.DbLayer.CReplicationTopology.LoadReplicatedServers(CPersistentDbConnection configDbConnection, Dictionary`2 dbSyncPoints)
[10.09.2010 10:14:29] <05> Error       at Veeam.Backup.Reporting.DbLayer.CReplicationTopology..ctor(CPersistentDbConnection configDbConnection)
[10.09.2010 10:14:29] <05> Error       at Veeam.Backup.Reporting.DbLayer.CCollectorCfg..ctor(CPersistentDbConnection configDbConnection, CReportingDbSettings settings)
[10.09.2010 10:14:29] <05> Error       at Veeam.Backup.Reporting.DbLayer.CConfigPartition..ctor(CDbConnectionParams dbConnectionParams, CReportingDbSettings reportingDbSettings)
[10.09.2010 10:14:29] <05> Error       at Veeam.Backup.Reporting.DbLayer.CReportingDbAccesor.Start(CDbConnectionParams dbConnectionParams, CReportingDbSettings reportingDbSettings)
[10.09.2010 10:14:29] <05> Error       at Veeam.Backup.EnterpriseServices.CEnterpriseServer.InitReportingDb(CLocalRegistryConfig registryConfig)
[10.09.2010 10:14:29] <05> Error       at Veeam.Backup.EnterpriseServices.CEnterpriseServer.Init()
[10.09.2010 10:14:29] <05> Error       at Veeam.Backup.EnterpriseServices.CEnterpriseServer.DoWorkflow()
[10.09.2010 10:14:29] <05> Info     Uninitialize enterprise server
[10.09.2010 10:14:29] <05> Info     Unregistering database accesor

Vitaliy S.
Product Manager
Posts: 23844
Liked: 1746 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: Errors with Enterprise Manager

Post by Vitaliy S. » Sep 10, 2010 10:20 am

Hello Adam,

You should remove Veeam backup server credentials from the Enterprise Manager's database. In order to achieve that, please execute the script below against your VeeamBackupReporting database:

Code: Select all

delete [dbo].[Repl.Topology.BackupServerCreds]
On executing this script via SQL Management Studio, please re-enter all credentials in the Enterprise Manager' console and you should be good to go. If you need any assistance with the script, don't hesitate to refer to our technical team.

Thank you!

Spad
Influencer
Posts: 18
Liked: never
Joined: Nov 05, 2009 8:06 am
Full Name: Adam Beardwood
Contact:

Re: Errors with Enterprise Manager

Post by Spad » Sep 10, 2010 10:29 am

That's sorted it.

Thanks.

cffit
Expert
Posts: 338
Liked: 34 times
Joined: Jan 20, 2012 2:36 pm
Full Name: Christensen Farms
Contact:

Re: Errors with Enterprise Manager

Post by cffit » Oct 21, 2013 5:45 pm 2 people like this post

This also worked for me after I moved Enterprise Manager to a new server and the service wouldn't start. In event viewer it was complaining about credentials each time I tried to start the service. I deleted the table mentioned here and then had to go in and delete/readd all the user/group accounts. I'm not sure if the later part was necessary, but direct support said to do it.

Gostev
SVP, Product Management
Posts: 26088
Liked: 4057 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Errors with Enterprise Manager

Post by Gostev » Oct 21, 2013 7:12 pm

Great, thanks for taking time to post this.

Post Reply

Who is online

Users browsing this forum: No registered users and 58 guests