Comprehensive data protection for all workloads
Post Reply
gopher_49
Enthusiast
Posts: 39
Liked: never
Joined: Jun 26, 2010 2:27 pm
Full Name: chris h
Contact:

Exchange U-AIR timeout issues

Post by gopher_49 »

I'm using the Exchange U-Air application and getting timeout errors. If I try the wizard a few times eventually it works... I use the all items options and filter via a folder name. It takes about 5-6 tries before the timeout error goes away... Does anyone know where to tweak out the timeout settings for the U-Air application?

Alexey D.

Re: Exchange U-AIR timeout issues

Post by Alexey D. »

Hello Chris,

Could you please provide the exact error string and describe at which step it showed up?
Also, what is the version of Exchange you are using?

Gostev
SVP, Product Management
Posts: 26679
Liked: 4268 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Exchange U-AIR timeout issues

Post by Gostev »

I am guessing Exchange 2003, because other versions are not supported with current beta ;)

Yes, looks like you are running it too early, before Exchange is ready to serve the requests... I have seen similar issue once. You may want to increase application initialization timeout for Exchange VM in the application group settings, this way Exchange will be able to take more time before it is reported as ready.

By the way, how many time those 5-6 timeouts take in reality, before it starts working? We may want to tweak the defaults for Exchange in the next update.

gopher_49
Enthusiast
Posts: 39
Liked: never
Joined: Jun 26, 2010 2:27 pm
Full Name: chris h
Contact:

Re: Exchange U-AIR timeout issues

Post by gopher_49 »

Sorry for the delay in my response.. I'll have to setup a lab Monday morning (too busy today) and give you better details. I have my roles tweaked (I edited the .xml file) to give it 3500 seconds of boot time and 1800 seconds of application time. I think you're correct in regards to the timeout for once it starts working it keeps on working, however, if I scan for all emails and do not enable a filter of any sort it seems that it times out no matter how long I let the VM stay booted... That seems like a timeout setting in your application waiting for my VM for I it was fully booted and still timed out when scanning through all emails of a specified user. I also receive timeout errors extracting emails...

I'll increase my application timeout to 2400 and then document everything in better detail.. I might be able to do this today..

Gostev
SVP, Product Management
Posts: 26679
Liked: 4268 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Exchange U-AIR timeout issues

Post by Gostev »

Actually, these timeouts do not affect the wizard itself. Inside the wizard, there are different timeouts. I will make sure these are increased before the release.

It is quite strange that you need 3500+1800, I would say typical Exchange should be fully ready under 10 min (600 sec), unless your backup storage is really slow...

Thanks for your feedback and help!

gopher_49
Enthusiast
Posts: 39
Liked: never
Joined: Jun 26, 2010 2:27 pm
Full Name: chris h
Contact:

Re: Exchange U-AIR timeout issues

Post by gopher_49 »

Once my lab was ready I logged into the server via the console and verified all servies where running and infostore DB mounted...

10:53 - Timed out when scanning through all folders. No filters enabled

10:58 started to scan Inbox - timed out on this too - too maybe one min to timeout thought - it needs to try way longer than that in my environment.

11:00 started to scan a smaller folder - in the past this one eventually worked - I just had to try a few times - failed also - 1 min later

11:06 - started to scan all folders and no filters again - timed out 1 min later

11:09 - started to scan only deleted ones with no filter and still timed out

Eventually at 11:15 I was able to access any email with or without a filter. I have to try 5-6 times and then it works perfectly fine... It doesn't matter if I wait 20 mins after the lab is ready or if I wait 1 hr after the lab is ready. I still have to try 5-6 times at mininum before it works... When it works I can search any aspect of the mailbox perfectly fine... It seems that the timeout needs to be adjusted withing the Exchange U-AIR application...

And yes... My backups are slow.. I have a Linux based NAS/iSCSI appliance.. So... It's not a true HBA device.. It only gets decent performance when a lot of clients are requesting resources... Anyway... If the U-Air timeouts are increased I'll be all good.. I think..

gopher_49
Enthusiast
Posts: 39
Liked: never
Joined: Jun 26, 2010 2:27 pm
Full Name: chris h
Contact:

Re: Exchange U-AIR timeout issues

Post by gopher_49 »

I changed my application timeout to 600 secs.. My labs load quicker now but I still have the same symptoms... I get a ton of time out errors when searching for items.. Eventually after trying a lot it works... Once it's able to find items from then on I can always find items... I get the same symptoms even if my lab is sitting idle for 20 mins or 2 hours... I would send the logs if U-Air was supported....

Gostev
SVP, Product Management
Posts: 26679
Liked: 4268 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Exchange U-AIR timeout issues

Post by Gostev »

Sure, 600 sec is fine even for our own 400GB and 300 plus mailbox Exchange 2003 (actually, it boots up from backup in under 5 mins). The issue here is solely with internal timeouts of Exchange wizard, and that is going to be easy fix obviously. I did not ask for logs because the issue seems clear (at least dev did not ask for the logs). If I still here we need logs, I will let you know. Thanks!

gopher_49
Enthusiast
Posts: 39
Liked: never
Joined: Jun 26, 2010 2:27 pm
Full Name: chris h
Contact:

Re: Exchange U-AIR timeout issues

Post by gopher_49 »

ok cool.. I'll wait for the update... I'm VERY anxious.

Thanks

gopher_49
Enthusiast
Posts: 39
Liked: never
Joined: Jun 26, 2010 2:27 pm
Full Name: chris h
Contact:

Re: Exchange U-AIR timeout issues

Post by gopher_49 »

When do you think the update will be out?

Gostev
SVP, Product Management
Posts: 26679
Liked: 4268 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Exchange U-AIR timeout issues

Post by Gostev »

Together with 5.0.1 by the end of November... or sooner, if you are ready to try untested code (just need to wait for this specific issue to be fixed).

gopher_49
Enthusiast
Posts: 39
Liked: never
Joined: Jun 26, 2010 2:27 pm
Full Name: chris h
Contact:

Re: Exchange U-AIR timeout issues

Post by gopher_49 »

I'm ready to try untested code if it has the new U-Air timeout settings...

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 32 guests