Comprehensive data protection for all workloads
Post Reply
bpickell
Novice
Posts: 4
Liked: never
Joined: Dec 27, 2010 5:59 pm
Full Name: Brian Pickell
Contact:

File Copy Job issues

Post by bpickell » Feb 10, 2011 3:09 pm

We are using Veam Backup & Replication version 5.0.1.198 and we are trying to setup a File Copy Job; however it keeps failing.

The situation is as follows:

We have two separate DMZ networks in our infrastructure. And inside those DMZ networks there is a NAS device. We are backing up the VM's inside those DMZ networks to the NAS devices. What we are trying to accomplish is use Veeam File Copy to copy the backups off of the NAS device to a file share on another NAS device on our Domain so that the backups can go off site to tape.

On the server that Veeam is installed on I mapped network drives to the NAS devices that are inside the DMZ's I supplied the network drives with the administrator credentials for those shares. The problem that I am seeing is when I set up file copy to connect to the mapped drives, it isn't using the mapped drives to connect to the shares. It is using the UNC path of the shares to connect. By doing this the job fails due to authentication errors.

I need to find a way to get this working. I have been using Robocopy up to this point, but it just is not reliable enough for me.

Any help would be appreciated.

Thanks,

bpickell
Novice
Posts: 4
Liked: never
Joined: Dec 27, 2010 5:59 pm
Full Name: Brian Pickell
Contact:

Re: File Copy Job issues

Post by bpickell » Feb 10, 2011 4:02 pm

I tried saving the credentials in windows password vault. I can now navigate through windows explorer to the UNC path shares without any authentication problems. However Veeam File copy is still failing when I try to run it.. So now I'm completely confused.

Vitaliy S.
Product Manager
Posts: 22759
Liked: 1519 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: File Copy Job issues

Post by Vitaliy S. » Feb 10, 2011 6:08 pm

Brian,

Let me shed some light on your issue.

The point is that we use Veeam Backup Service account to access destination storage. The reason why UNC path is being used for the job is the following - mapped drives are per-user (stored in HKCU), so Veeam Backup service account cannot see that drive, you can only see it while being logged on interactively.

I guess a workaround would to grant Veeam Backup Service account with access to your NAS device. In addition, please have a look at this topic, should help: Backup to NAS box with security OR securing backups

Thank you!

bpickell
Novice
Posts: 4
Liked: never
Joined: Dec 27, 2010 5:59 pm
Full Name: Brian Pickell
Contact:

Re: File Copy Job issues

Post by bpickell » Feb 11, 2011 8:44 pm

Well the linux thing seems to be an ok temporary band-aid for now; since it does seem to work. However it is painfully slow. We are averaging about 600 kb/s using this method.

It would be nice if you could somehow allow separate authentication to the share in the setup of the job like a lot of other backup software allows. That would just make my life a whole lot easier.

Edit: One other thing I noticed using this method. If the directory we are trying to copy has more than two nested directories.. It doesn't copy anything but the top two directories. That is a huge problem in my case.

Vitaliy S.
Product Manager
Posts: 22759
Liked: 1519 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: File Copy Job issues

Post by Vitaliy S. » Feb 13, 2011 5:41 pm

Brian,

Could you tell me what is the CPU load on your Linux box while the copy job takes place?
bpickell wrote:It would be nice if you could somehow allow separate authentication to the share in the setup of the job like a lot of other backup software allows. That would just make my life a whole lot easier.
Thank you for the feedback, we'll see what we can do here.

dapidap
Novice
Posts: 4
Liked: never
Joined: Aug 01, 2012 3:35 am
Full Name: Dapearl SJ
Contact:

Re: File Copy Job issues

Post by dapidap » Jan 02, 2013 6:06 am

Hi,

I know this forum has not been posted with replies in a while, but I am experiencing same issue but with Veeam Backup & Replication 6.0 on windows Server 2008 Hyper-V . I hope you have find any workarounds with it.

My File Copy job just don't do anything, It is always on "0% completed at 0 KB/s" state for like hours. I am trying to copy a folder of 300GB to a VHD attached to VEEAM VM Server which I have no trouble backing up some VMs to it with the same credential, but on a File Copy job, it's just not working.

I have on the "Item to copy" as source - "D:\MainFoldername\SubFoldername" with Host "192.xxx.x.x"
I have a Destination path as "\\servername\D$\DestinationFolder"

When I run the job, it didn't even copied a file.

I hope someone could give some workaround, I am using the File Copy wizard.

Gostev
SVP, Product Management
Posts: 24427
Liked: 3405 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: File Copy Job issues

Post by Gostev » Jan 02, 2013 10:18 am

Hi, please open a support case and let them investigate the debug logs to find out what the issue is. Thanks!

Vitaliy S.
Product Manager
Posts: 22759
Liked: 1519 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: File Copy Job issues

Post by Vitaliy S. » Jan 02, 2013 10:28 am

Hi Dapearl,

I guess you have a slightly different issue, as your copy job doesn't fail, but keep running with 0 progress.
dapidap wrote: I am trying to copy a folder of 300GB to a VHD attached to VEEAM VM Server which I have no trouble backing up some VMs to it with the same credential, but on a File Copy job, it's just not working.

I have a Destination path as "\\servername\D$\DestinationFolder"
Since you have the VHD file attached to the backup server, why not to point to this drive directly without specifying this path "\\servername\D$\"?

Thanks!

dapidap
Novice
Posts: 4
Liked: never
Joined: Aug 01, 2012 3:35 am
Full Name: Dapearl SJ
Contact:

Re: File Copy Job issues

Post by dapidap » Jan 04, 2013 3:49 am

Hi Vitaly,

I tried it using below on File copy job wizard:

Source: A folder (375GB) from another sever (not on hyper-v) "\\192.xxx.x.x\D$\FolderName" - this a groupdata folder shared by users where they backup their important files.

Destination: A vhd (added as repository) slaved to a VM on Hyper-V where Veeam Backup is running. I can browse it from the wizard and point directly to it.

However still it doesn't execute, status would state 0 progress, on the real-time stat only the time duration is running.

Vitaliy S.
Product Manager
Posts: 22759
Liked: 1519 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: File Copy Job issues

Post by Vitaliy S. » Jan 04, 2013 10:34 am

In this case it would be better to take a look a the job log file, so please open a support ticket with our technical team. Thanks!

cvlr
Service Provider
Posts: 41
Liked: 5 times
Joined: Dec 14, 2010 1:04 pm
Full Name: Christophe Van Lierde
Contact:

[MERGED] File Copy Job does not detect HP RDX drive

Post by cvlr » Apr 08, 2013 1:20 pm

Our backups are done to disk and afterwards copied to an RDX drive. At least that was the initial plan.

The Veeam File Copy Job fails with error "Could not find a part of the path 'E:\'."

E:\ drive is our RDX drive.
In the job log I found out that the E:\ drive is not detected (not enumerated during local host drive info).
The E:\ drive is available if I logon as the veeam service account on the backup server.

Using Windows 2012 and Veeam 6.5 with patch 1
Veeam Certified Engineer v9 / Veeam Gold Pro Partner

cvlr
Service Provider
Posts: 41
Liked: 5 times
Joined: Dec 14, 2010 1:04 pm
Full Name: Christophe Van Lierde
Contact:

Re: File Copy Job does not detect HP RDX drive

Post by cvlr » Apr 08, 2013 1:31 pm

update : tried using unc path to \\localhost\e$ but it ends with same error. Share permissions are ok.
Veeam Certified Engineer v9 / Veeam Gold Pro Partner

Vitaliy S.
Product Manager
Posts: 22759
Liked: 1519 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: File Copy Job does not detect HP RDX drive

Post by Vitaliy S. » Apr 08, 2013 4:38 pm

Mapped drives are only visible when you log in to your server interactively, that is why it fails in the initial case. Can you please try to use UNC path without "$" sign?

cvlr
Service Provider
Posts: 41
Liked: 5 times
Joined: Dec 14, 2010 1:04 pm
Full Name: Christophe Van Lierde
Contact:

Re: File Copy Job issues

Post by cvlr » Apr 09, 2013 7:23 am

E:\ drive is not a mapped drive. Tried UNC path without $ sign but that does not work either. I can however use the drive as Backup Repository.
Veeam Certified Engineer v9 / Veeam Gold Pro Partner

veremin
Product Manager
Posts: 16666
Liked: 1390 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: File Copy Job issues

Post by veremin » Apr 09, 2013 9:09 am

Hi, Christophe. This error might be also caused by the fact that account running Veeam Backup service does not have permissions to read/write to the target path set in the job.

Anyway, the fastest way to address the issue is to open a ticket with support team, since it’s way too complicated to investigate technical problem remotely through forum correspondence.
Our backups are done to disk and afterwards copied to an RDX drive. At least that was the initial plan.
Additionally, as a potential workaround you can write a simple PS script which would be responsible for taking corresponding backup-files to RDX drive and which would be specified as post-job activity or scheduled to run via Windows Scheduler.

Hope this helps.
Thanks.

cvlr
Service Provider
Posts: 41
Liked: 5 times
Joined: Dec 14, 2010 1:04 pm
Full Name: Christophe Van Lierde
Contact:

Re: File Copy Job issues

Post by cvlr » Apr 09, 2013 1:13 pm 3 people like this post

I finally got it working by disabling failure auditing on removable storage in Windows 2012 :

auditpol /set /subcategory:"Removable Storage" /failure:disable
Veeam Certified Engineer v9 / Veeam Gold Pro Partner

Post Reply

Who is online

Users browsing this forum: Bing [Bot], M.Lewis and 37 guests