Comprehensive data protection for all workloads
Post Reply
tsightler
VP, Product Management
Posts: 5675
Liked: 2486 times
Joined: Jun 05, 2009 12:57 pm
Full Name: Tom Sightler
Contact:

FLR Wizard Slow to Startup

Post by tsightler »

OK, I'm having an annoying issue that I discovered recently. When attempting to use the FLR Wizard (the appliance) clicking the icon to start the wizard takes almost 5 minutes for the application to load. During this time one CPU on my box is running at 100%, and memory counts for the FLR process go from ~20MB to ~350MB, then back to just under 100MB, then up to almost 500MB at which time the wizard finally starts and seems to work OK. This is with Veeam 4.1.1 on 64bit Windows 2003. Has anyone else seen anything like this?

I had noticed the delay before, but prior to last week we had rarely had reason to use the FLR wizard as most of our file level restores were for Windows systems. Because of a technology failure in our datacenter last week we've spent a lot more time performing restores to recover systems and we needed to use the tool multiple times in the same day and it became annoying.

Should I open a support case for this?

Gostev
SVP, Product Management
Posts: 26679
Liked: 4268 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: FLR Wizard Slow to Startup

Post by Gostev »

Tom, this is the time when .NET Framework components initialize, so my first idea is that this is .NET issue specific to this computer... however, this would probably affect "main" application as well - which I assume you are not seeing. I will check with devs on their thoughts tomorrow morning.

Quick check would be to try and install Veeam to any other computer, and see if it has the same issue.

This is not a known issue (and not expected) so definitely feel free to create a support case.

tsightler
VP, Product Management
Posts: 5675
Liked: 2486 times
Joined: Jun 05, 2009 12:57 pm
Full Name: Tom Sightler
Contact:

Re: FLR Wizard Slow to Startup

Post by tsightler »

Definitely doesn't seem to affect the main application. That opens in about 30 seconds the first time, and generally faster after that. The FLR wizard is very slow every time.

When we first started using Veeam on a 64-bit platform we did have a similar issue with the main application when we started the backup wizard and it enumerated our vCenter. It would get very slow, use an entire CPU, use a lot of memory, and take a very long time to provide the list of machine, but otherwise, it seemed fine. This issue seemed to go away with a later revision, and we could only reproduce it on 64-bit, not 32-bit (a 32-bit host took only a few seconds for the same operation).

I'm wondering if some fix was implemented in the main application around enumerating vCenter, and this fix was not applied to the FLR Wizard application. I'm trying on another 64-bit system now. It's a clean install of Windows 2003 Standard x64 edition so we'll see how it behaves.

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 31 guests