Linux agent problems & solutions

Availability for the Always-On Enterprise

Linux agent problems & solutions

Veeam Logoby Darkknight » Mon Feb 13, 2017 4:44 am 1 person likes this post

Ran into many issues today with getting the Linux agent working on a remote VPS. Having solved the issues to the degree that I was able to complete at least one backup, I thought I'd post the problems and solutions here. I've actually referenced my own answers a couple of times in the past using a google search for a problem I solved a years before and forgot about, but posted the solutions for, so this is partly for me too.

Error message:
Failed to create volume snapshot


This error was initially caused because veeamsnap did not install correctly. VPS provider uses a shared kernel and does not allow the installation of modules. Solution was to install distro supplied kernel. That didn't fix the problem entirely however, because I immediately encountered another error trying to install the module (which could be found in the make job.log):

include/linux/page-flags-layout.h:5:30: fatal error: generated/bounds.h: No such file or directory


This secondary issue created due to some incompatibility in kernel 4.8.x (most recent for my distro) where the module would not install into that kernel. Solution was to add back-port repo's and install a newer 4.9 kernel. I once again had to remove the veeam packages and start again but this time, it built successfully.

Now that Veeam agent is successfully installed, I configured to connect to my B&R server behind my local firewall. However, the jobs still failed saying it was unable to connect to the server. I quickly discovered that B&R requires lot of ports open & forwarded to function correctly. The solution was to look up the ports required: https://helpcenter.veeam.com/docs/backu ... tml?ver=95 in my case this was in the ranges of 10002 & 2500.

That got my further, but I hit one last issue that was perplexing. It looks like there is a bug in the Linux agent that causes the backup data on the remote end to use B&R servers internal LAN IP instead of the WAN IP. The error message looks like:

Failed to connect to the port [x.x.x.x:2500]
where the x.x.x.x is the local LAN ip of your B&R server; tcpdump showed me the way.

The solution was to use IP tables & NAT on the remote server to redirect traffic sent to the LAN ip to the WAN ip of your B&R server. Instructions: http://superuser.com/questions/681705/u ... ip-address

This isn't a particularly elegant solution, but it did allow the backup to complete successfully. After so many hours banging my head against the wall to solve it, I'll take this as a victory. Hope this can help someone else.
Darkknight
Lurker
 
Posts: 1
Liked: 1 time
Joined: Mon Feb 13, 2017 4:08 am

Return to Veeam Backup & Replication



Who is online

Users browsing this forum: Bing [Bot], DGrinev, Google Feedfetcher, law999, lbiw and 39 guests