Comprehensive data protection for all workloads
Post Reply
itldn
Influencer
Posts: 24
Liked: never
Joined: Mar 29, 2011 9:54 am
Contact:

noautomount and system state

Post by itldn »

When we install Veeam backup and replication 5. it disables the noautomount on the server. This has caused a problem when a System State is backed up of the server that holds Veeam. Basically to backup the system state you need to make sure that the noautomount key is enabled which is the default setting by microsoft, However veeam disables this to make sure that the LUNs are not overwritten.

is there any way that i can backup the system state of the veeam server, keeping in mind i dont want to overwrite my LUNS also my SAN does not have read only access function?

Thanks,

Gostev
SVP, Product Management
Posts: 26679
Liked: 4268 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: noautomount and system state

Post by Gostev »

Just wanted to stress the importance of this. No matter what, do make sure that you keep your automount off at all times. If you need to enable it, physically disconnect SAN from your server first. Otherwise, Windows may re-signature your VMFS volumes. Thanks.

itldn
Influencer
Posts: 24
Liked: never
Joined: Mar 29, 2011 9:54 am
Contact:

Re: noautomount and system state

Post by itldn »

Gostev,

This contradict what was just uploaded to this question which it seems to be deleted. I also talked to Veeam support and they seems to agree with the deleted reply which is as long as it is a physical server then automount is not important.

In you comment you don't seems to give a solution to the question (how do we backup System State), it is not practical to just flick the regkey every time i want to backup the system state.
Is this a bug in Veeam?
Please i need solution!!

Gostev
SVP, Product Management
Posts: 26679
Liked: 4268 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: noautomount and system state

Post by Gostev »

Physical server connected directly into SAN fabric is exactly where having automount disabled is critically important. Deleted reply from Alexey was incorrect. I have not seen Veeam support reply you are referring too, but from what you said above, I assume it was incorrect either.

No, this is not a bug with Veeam, but normal default Windows behavior when new volume appears, and this has been a known VMware backup gotcha since early days, before Veeam even existed. See here for example:
http://www.yellow-bricks.com/2008/02/11 ... -what-now/

I cannot give you a solution because I do not know, but may be other fellow community members will be able to suggest something. Simply "flicking" the reg key without physically disconnected the server from SAN fabric is definitely not a solution though, because this means that at certain points in time your server will have automount enabled while connected into SAN fabric, and this is just calling for VMFS corruption. This is exactly why our product's setup disables automount automatically.

Thanks.

itldn
Influencer
Posts: 24
Liked: never
Joined: Mar 29, 2011 9:54 am
Contact:

Re: noautomount and system state

Post by itldn »

Hi Gostev,

Thanks for the information, i hope now Veeam support can use this information when they encounter this problem.

MarcelB
Influencer
Posts: 10
Liked: never
Joined: Feb 04, 2010 10:32 am
Full Name: Marcel van den Berg
Contact:

Re: noautomount and system state

Post by MarcelB »

The same problem with automount disabled applies to installing Service Pack 1. For succesful install of SP1 automount must be enabled. Instead of disconnecting the Veeam server form the SAN fabric, the steps described below might help.
It is described in my blogposting as well and taken from a posting on this forum (Thanks for the author)
http://up2v.wordpress.com/2011/02/26/er ... on-server/
Procedure to install SP1: (Drive J can be any free drive letter not used).

1. At command promtp: Type “mountvol /? “(This will display help and will also list volumes). Identify system partition (will not have drive letter) ie: \\?\Volume{9be074ce-d55f-11df-83d7-806e6f6e6963}
2. Mount a temporary drive letter to the system partion “mountvol j:/ \\?\Volume{9be074ce-d55f-11df-83d7-806e6f6e6963}” (Enter your own system partition guid).
3. Run SP 1 update and restart.
4. Dismount temporary drive “mountvol j: /d”.

Post Reply

Who is online

Users browsing this forum: No registered users and 29 guests