Comprehensive data protection for all workloads
Post Reply
tgillispie
Technology Partner
Posts: 17
Liked: 5 times
Joined: Nov 16, 2010 10:52 pm
Full Name: Tom Gillipsie
Contact:

Problem integrating SureBackup + AppGroup w/ VM router

Post by tgillispie »

I have an app group with 4 VMs - domain controller, exchange server, sql server and a simple Linux vyatta router that creates an subnet for that app group. The vyatta router simply routes between the corporate subnet on one interface and this app group's "dedicated" subnet on the other interface which is created via a standard VMware switch. Other details:
app group's "dedicated" subnet is via a simple VMware virtual switch
vyatta router's VM has one network connection to the corporate network via the typical "VM Network", and a 2nd to the app group's "dedicated" subnet

When I do a SureBackup, the vyatta's router's VM is brought up in the SureBackup's isolated lab network (as expected), but it gets only a single network connection to the SureBackup's isolated lab network (which is expected - it takes the place of the corporate network - the "VM Network") - but that's not sufficient. Its almost like the SureBackup's isolated lab network needs an additional standard switch created (automatically?) for the VMs to use.

The "mapping" is something like:
Production SureBackup
VM Network (corp) Virtual Lab Network with its proxy to the VM Network
App's dedicated subnet Standard switch for the App's dedicated subnet while in the Virtual Lab

SureBackup is creating the first mapping, but not the 2nd, so the VMs don't have the same network environment inside the Virtual Lab as they expect/need.

How can I get SureBackup to do this, or do I need to script it, or ........?

Thanks.

Gostev
SVP, Product Management
Posts: 26693
Liked: 4273 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Problem integrating SureBackup + AppGroup w/ VM router

Post by Gostev »

Hi Tom, our virtual lab is not designed to support configurations with additional VM routers. Thank you.

tsightler
VP, Product Management
Posts: 5678
Liked: 2490 times
Joined: Jun 05, 2009 12:57 pm
Full Name: Tom Sightler
Contact:

Re: Problem integrating SureBackup + AppGroup w/ VM router

Post by tsightler »

We actually have a very similar setup for some of our VM's. Because the proxy appliance expects to be directly connected to VM's you can't really create a routed subnet on the Surebackup isolated network. However, you can still use the Surebackup functions for these VM's by simply leaving the vyatta router out of the Virtual Lab and configuring the proxy appliance with the network settings from the "dedicated network" side of the vyetta router.

Basically, in simpler terms, just configure the proxy appliance as a replacement for the vyetta router.

tgillispie
Technology Partner
Posts: 17
Liked: 5 times
Joined: Nov 16, 2010 10:52 pm
Full Name: Tom Gillipsie
Contact:

Re: Problem integrating SureBackup + AppGroup w/ VM router

Post by tgillispie »

Thanks tsightler! I had the same thought driving home the day I made the post. I've done this and I'm very close to a succsessful SureBackup.
Thanks again.

Post Reply

Who is online

Users browsing this forum: Baidu [Spider], falkob and 70 guests