Problem with pre-freeze and post-thaw scripts (Linux)

Availability for the Always-On Enterprise

Problem with pre-freeze and post-thaw scripts (Linux)

Veeam Logoby dennsp » Mon Jul 31, 2017 1:23 pm

Hello! I have a problem with running scripts.

ESXi 6.5, B&R9.5U2
I have 4 virtual hosts with Linux servers. All of them are on CentOS 6 and 7.
I need to execute pre-freeze and post-thaw scripts on the each of this servers.
In a backup task all of the scripts are specified the same way:
http://www.evernote.com/shard/s693/sh/3 ... 5fac511289
I can successfully run scripts locally on all servers.

The problem is that scripts work only on 2 servers, when on the other 2 servers they do not work. Scripts are being ignored, while the task itself is working.
Scripts working:
http://www.evernote.com/shard/s693/sh/7 ... 94b9da9796
Scripts not working:
http://www.evernote.com/shard/s693/sh/1 ... f21dd91f87

In the first case Veeam correctly detects the OS inside of created backup copies. In the second case, when scripts were ignored, Veeam doesn't detect the OS.
Scripts succeeded:
http://www.evernote.com/shard/s693/sh/7 ... 679d71077b
Scripts not succeeded:
http://www.evernote.com/shard/s693/sh/1 ... 69987c82f6

In the log-file of the task where scripts were ignored there is a record: "Couldn't detect guest type".
http://www.evernote.com/shard/s693/sh/4 ... ceb1128d75
If scripts succeeded there is no records like that:
http://www.evernote.com/shard/s693/sh/d ... 68289109cc

I think that the problem probably is in VMware Tools. The thing is that one of the servers with the problem had no such problems at first, scripts successfully worked. I compared 2 of the servers and reinstalled VMware Tools on the server where scripts were working, after that scripts stopped working on that server.

As for now scripts are not working on 2 servers. I tried to reinstall VMware Tools from gz by VMware and use Open VM Tools from the repository. Before the install I cleared a server from any VMware files. VMware Tools are working with ESXi. ESXi can manage VMs, the status is "VMware Tools installed".

VMware Tools on the 2 servers where scripts are working were installed with the different methods: from gz and from repository.
Scripts are working well on both of this servers.

I have deleted a task and created new one. I reinstalled B&R with fresh OS. I made a new virtual machine with an old HDD. Nothing helped. So the problem is inside VM.

Please help me to find a problem and a solution.
dennsp
Lurker
 
Posts: 1
Liked: never
Joined: Mon Jul 31, 2017 12:21 pm

Re: Problem with pre-freeze and post-thaw scripts (Linux)

Veeam Logoby PTide » Mon Jul 31, 2017 2:01 pm

Hi,

Have you tried VMware native quiescence? Did it work?

Thank you
PTide
Veeam Software
 
Posts: 3019
Liked: 246 times
Joined: Tue May 19, 2015 1:46 pm


Return to Veeam Backup & Replication



Who is online

Users browsing this forum: Bing [Bot] and 14 guests