Comprehensive data protection for all workloads
Post Reply
insel
Lurker
Posts: 1
Liked: never
Joined: Jul 02, 2014 9:38 am
Full Name: Sebastian Inacker
Contact:

Set FQDN for outgoing e-mail

Post by insel » Jul 02, 2014 10:04 am

Hello.

How can i set a fully qualified domain name ("backup.example.com" instead of "backup") for outgoing e-mail notifications? I have not found an option for doing this.

I tried to set a FQDN on the windows machine, but mail is still send out without FQDN. Because of that our mail server complains: "5.5.2 <VeeamBackup>: Helo command rejected: need fully-qualified hostname".

I use Veeam 7.0.0.690 on Windows 8.

Thanks for any hint,
Sebastian

Vitaliy S.
Product Manager
Posts: 22777
Liked: 1526 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: Set FQDN for outgoing e-mail

Post by Vitaliy S. » Jul 02, 2014 10:29 am

Sebastian,

Not sure there is a way to change that, as Veeam backup server might not be joined to the domain, thus only hostname is used. Let me check if Veeam ONE can send backup email notification in the way you need or not.

Thanks!

MichalJ
Lurker
Posts: 1
Liked: never
Joined: May 09, 2016 7:25 am
Full Name: Michal J.
Contact:

[Feature request] Seting FQDN hostname in notifications

Post by MichalJ » May 09, 2016 7:49 am

Hello!

I have a problem sending e-mail notifications from Veeam Backup & Replication. Our mail server is sending this kind of error:

Code: Select all

Helo command rejected: need fully-qualified hostname (System.Net.Mail.SmtpException) 
As you can see, our mail server requires FQDN hostname. In Windows I can only set simple hostname without dots (like "Veeam") and then add a domain name (like "company.com"). Entire PC name is correct ("Veeam.company.com") and would meet mail server requirements, but Veeam is only sending a simple Windows hostname "Veeam" in e-mail notification. I would like to request a feature to customize hostname sent by Veeam software and force sending FQDN hostname.

Thanks!

Shestakov
Veeam Software
Posts: 6836
Liked: 697 times
Joined: May 21, 2014 11:03 am
Full Name: Nikita Shestakov
Location: Prague
Contact:

Re: Set FQDN for outgoing e-mail

Post by Shestakov » May 09, 2016 9:06 am

Hello Michal and welcome to the forums.
Thanks for the feedback!

dahdco
Novice
Posts: 3
Liked: never
Joined: Oct 07, 2011 2:31 pm
Full Name: Doug Heckman
Contact:

Re: Set FQDN for outgoing e-mail

Post by dahdco » Sep 14, 2016 2:20 pm

We essential have the same issue. We don't outright require the HELO to have FQDN but if it doesn't it's treated as suspect and if pretty much any email gets sent through the host is blacklisted automatically. It would be great to be able to have the option to force it to use FQDN.

Post Reply

Who is online

Users browsing this forum: No registered users and 13 guests