Sudoers has invalid syntax

Availability for the Always-On Enterprise

Sudoers has invalid syntax

Veeam Logoby Scream » Tue Oct 24, 2017 8:45 pm

Hi,

I added a server recently to my backup job, which uses local user auth and also does LDAP authentication to our domain controller.
When I do credentials test for the guest file system indexing I get the following error message: "Error: ERROR: /etc/sudoers has invalid syntax", in the backup job setting I have the "Elevate specified account to root" and "Add account to the sudoers file automatically" options turned on. When I do visudo -c on that linux box, it doesn't highlight any issue with the syntax.

Is there anyone out there, who had the same message before? What was your solution?

Thank you!
Scream
Novice
 
Posts: 3
Liked: never
Joined: Tue Mar 14, 2017 5:40 pm

Re: Sudoers has invalid syntax

Veeam Logoby PTide » Thu Oct 26, 2017 1:04 pm

Hi,

With "Add account to the sudoers file automatically" option VBR attempts to modify sudoers file automatically. It seems that for some reason something had gone wrong during the modification so the changes were not committed, that's why visudo check does not highlight any issues. You can try to add the user into sudoers file manually and try again. Anyway you should contact our support team for a deeper investigation as the observed behaviour is unexpected. Once you contact them please post your case ID. Btw, what is your distro?

Thank you
PTide
Veeam Software
 
Posts: 3311
Liked: 275 times
Joined: Tue May 19, 2015 1:46 pm


Return to Veeam Backup & Replication



Who is online

Users browsing this forum: Google [Bot], Google Feedfetcher and 1 guest