SureReplica testing in a virtual lab when Re-IP is configure

Availability for the Always-On Enterprise

SureReplica testing in a virtual lab when Re-IP is configure

Veeam Logoby garymansell » Fri Dec 16, 2016 11:38 am

Hi,

I have a replication job configured for a couple of VM's with a source IP and network of 172.30.10.x that are replicated to a remote site along with a Re-IP rule being configured as part of the replication to change their networking to 172.21.10.x

I have setup an application group from the two replica VM's

I have setup a virtual lab configured for the host that they are on at the replica site, the Appliance IP was set to 172.21.100.1 (ie the IP of the router of the replica as it would be after it is Re-IP'd for the remote network)

When I run the sure backup job, it fails with the error:

Code: Select all
16/12/2016 10:47:38 Error stc-plmtst-01 - Powering on
16/12/2016 10:47:38 Error: No destination network for IP address 172.30.10.94


This seems to suggest to me that the replica VM's are coming up in the virtual lab with their original PROD source IP's which does not match the networking config of the virtual lab Appliance IP and hence they can't be contacted and the job fails.

If I then re-configure the Virtual Lab Appliance IP to be that of the original PROD source network - ie 172.30.10.x, the sure backup job seems to get a bit further but still fails (there is a ping error):

Code: Select all
Details
16/12/2016 11:18:44 Error stc-plmtst-01 - Running ping test(s)
16/12/2016 11:20:44 Error: Application group failed to start
16/12/2016 11:20:49 Error: Application group failed to start


It seems to me that my first configuration of the virtual lab should be correct - ie using the IP of the network as it would be at the remote site after re-ip'ing - but I can find no info to confirm this and neither configuration works for me.

Can anyone point me in the direction of what I am doing wrong here?

Thanks

Gary
garymansell
Enthusiast
 
Posts: 26
Liked: never
Joined: Mon Sep 03, 2012 1:31 pm

Re: SureReplica testing in a virtual lab when Re-IP is confi

Veeam Logoby garymansell » Mon Dec 19, 2016 8:47 am

OK - this turns out to be because I am trying to bring up the virtual lab at the replica site rather than the master site where the veeam server is located.

Veeam seem pretty keen to suggest that you can use just the one server to do both backup and replication, but when backups need to be done locally due to their size, the only option is to "push" the replication to the remote site and then things like SureReplica can't work without some jiggery pokery with adding a load of network routes.

It seems to me that this is something that could be done with the remote Veeam proxies - surely they could be involved in the SureReplica job to allow this all to work seamlessly?
garymansell
Enthusiast
 
Posts: 26
Liked: never
Joined: Mon Sep 03, 2012 1:31 pm


Return to Veeam Backup & Replication



Who is online

Users browsing this forum: Bing [Bot], Yahoo [Bot] and 20 guests