Comprehensive data protection for all workloads
Post Reply
Peejay62
Expert
Posts: 192
Liked: 29 times
Joined: Aug 06, 2013 10:40 am
Full Name: Peter Jansen
Contact:

Time out Enterprise Manager interface

Post by Peejay62 » Dec 05, 2013 2:43 pm

When opened the Enterprise Manager interface after some idle time the session disconnects and the login prompt reappears. Is this behaviour as expected? I have been looking for something like an idle session timeout setting but cannot find this. Is there an option to set this.
I want the session to never disconnect,or at least stay active for a very long time So you don't have to re-login all the time...

foggy
Veeam Software
Posts: 18453
Liked: 1589 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Time out Enterprise Manager interface

Post by foggy » Dec 05, 2013 2:56 pm 1 person likes this post

Yes, you can customize the auto-logoff timeout by changing the following value in the C:\Program Files\Veeam\Backup and Replication\Enterprise Manager\WebApp\web.config file:

Code: Select all

<add key="sessionTimeout" value="30"/>
(value is in minutes)

The parameter has been deprecated. Scroll down for an actual solution.

Peejay62
Expert
Posts: 192
Liked: 29 times
Joined: Aug 06, 2013 10:40 am
Full Name: Peter Jansen
Contact:

Re: Time out Enterprise Manager interface

Post by Peejay62 » Dec 05, 2013 3:17 pm 1 person likes this post

Ok, thanks for the quick reply, assuming these are minutes i will put 1440 in it.. ;-)

Gostev
SVP, Product Management
Posts: 25121
Liked: 3683 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Time out Enterprise Manager interface

Post by Gostev » Dec 05, 2013 8:08 pm

I still remember when in early days, some paid product review sponsored by a competitor (whose solution did not have a web portal) noted that our portal does not have auto-logoff feature, making it insecure and not enterprise-ready. When actually, we did have auto-logoff since the very first version of web portal. Apparently, 30 minutes can be too long of a wait for some ;)

arosas
Enthusiast
Posts: 38
Liked: 6 times
Joined: Jun 09, 2015 9:33 pm
Full Name: Tony Rosas
Contact:

Re: Time out Enterprise Manager interface

Post by arosas » Apr 06, 2017 9:12 pm

Sorry for reviving an old post, used veeam search and found this forum. :-)

Just wondering if this timeout value still can be used in the latest 9.5 version. Also after changing the value what service needs to be restarted for it to take effect?

Mike Resseler
Product Manager
Posts: 5834
Liked: 639 times
Joined: Feb 08, 2013 3:08 pm
Full Name: Mike Resseler
Location: Belgium
Contact:

Re: Time out Enterprise Manager interface

Post by Mike Resseler » Apr 07, 2017 5:23 am

Hi Tony,

No apologies for reviving an old post. I would rather say good job since you used search ;-)

Yes, this key has not changed so you can adapt it. I am not sure if you actually need to restart something but if you would restart the Veeam Enterprise Manager service that should do the trick

Mike

arosas
Enthusiast
Posts: 38
Liked: 6 times
Joined: Jun 09, 2015 9:33 pm
Full Name: Tony Rosas
Contact:

Re: Time out Enterprise Manager interface

Post by arosas » Apr 07, 2017 2:25 pm

Great, thanks for the response. :-)

dellock6
Veeam Software
Posts: 5790
Liked: 1657 times
Joined: Jul 26, 2009 3:39 pm
Full Name: Luca Dell'Oca
Location: Varese, Italy
Contact:

Re: Time out Enterprise Manager interface

Post by dellock6 » Apr 10, 2017 7:34 pm

Hi, you only need to logoff any session of enterprise manager, and after login the new timeout will be applied to the sessions.
Luca Dell'Oca
Principal EMEA Cloud Architect @ Veeam Software

@dellock6
https://www.virtualtothecore.com/
vExpert 2011 -> 2019
Veeam VMCE #1

Shieik
Novice
Posts: 8
Liked: 1 time
Joined: Nov 23, 2017 2:53 pm
Contact:

Re: Time out Enterprise Manager interface

Post by Shieik » Sep 06, 2018 2:19 pm

foggy wrote:Yes, you can customize the auto-logoff timeout by changing the following value in the C:\Program Files\Veeam\Backup and Replication\Enterprise Manager\WebApp\web.config file:

Code: Select all

<add key="sessionTimeout" value="30"/>
(value is in minutes)
For monitoring we need the Enterprise maganer always open. If i put 0 on the sessiontimout value, it will close?

foggy
Veeam Software
Posts: 18453
Liked: 1589 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Time out Enterprise Manager interface

Post by foggy » Sep 07, 2018 5:01 pm

Apparently you need another timeout that is set right on EM itself. Zero value will not work so just set it to some high number.

Shieik
Novice
Posts: 8
Liked: 1 time
Joined: Nov 23, 2017 2:53 pm
Contact:

Re: Time out Enterprise Manager interface

Post by Shieik » Oct 17, 2018 2:42 pm

Thanks foggy, i will try with 43200 minutes :D

ungerkkt
Novice
Posts: 5
Liked: 1 time
Joined: Sep 03, 2019 5:09 am
Contact:

[MERGED] Enterprise Manager deactivate auto logoff

Post by ungerkkt » Sep 03, 2019 11:14 am

Hello,

is it possible to deactivate the auto logoff of the Enterprise Manager website? I have tried to increase the parameter "sessionTimeout" of the web.config file, but it don't help.

Thank you for your help.

wishr
Veeam Software
Posts: 1327
Liked: 132 times
Joined: Aug 07, 2018 3:11 pm
Full Name: Fedor Maslov
Contact:

Re: Enterprise Manager deactivate auto logoff

Post by wishr » Sep 03, 2019 11:38 am

Hello,

Could you please specify the reason for this change? The increase of the logon session may be against security best practices.

Update: I've merged your topic with the related thread - please take a brief look.

Thanks

ungerkkt
Novice
Posts: 5
Liked: 1 time
Joined: Sep 03, 2019 5:09 am
Contact:

Re: Time out Enterprise Manager interface

Post by ungerkkt » Sep 04, 2019 4:53 am

I have read this thread already, but the parameter don't work for me. Why?

wishr
Veeam Software
Posts: 1327
Liked: 132 times
Joined: Aug 07, 2018 3:11 pm
Full Name: Fedor Maslov
Contact:

Re: Time out Enterprise Manager interface

Post by wishr » Sep 04, 2019 10:10 am

Hello,

Have you tried restarting the Enterprise Manager server or IIS itself? Which parameter you have changed (there are two above) and what is the value being set? Please provide a screenshot if possible.

Thanks

ungerkkt
Novice
Posts: 5
Liked: 1 time
Joined: Sep 03, 2019 5:09 am
Contact:

Re: Time out Enterprise Manager interface

Post by ungerkkt » Sep 04, 2019 11:39 am

This parameter was changed: <add key="sessionTimeout" value="8640" />
I have restarted the hole server end nothing happened. The timeout is shorter than the standard (30min).

wishr
Veeam Software
Posts: 1327
Liked: 132 times
Joined: Aug 07, 2018 3:11 pm
Full Name: Fedor Maslov
Contact:

Re: Time out Enterprise Manager interface

Post by wishr » Sep 04, 2019 1:57 pm

I'll perform a few tests and post the result here.

wishr
Veeam Software
Posts: 1327
Liked: 132 times
Joined: Aug 07, 2018 3:11 pm
Full Name: Fedor Maslov
Contact:

Re: Time out Enterprise Manager interface

Post by wishr » Sep 04, 2019 4:07 pm

foggy wrote:
Dec 05, 2013 2:56 pm
Yes, you can customize the auto-logoff timeout by changing the following value in the C:\Program Files\Veeam\Backup and Replication\Enterprise Manager\WebApp\web.config file:

Code: Select all

<add key="sessionTimeout" value="30"/>
(value is in minutes)
This configuration parameter has been replaced with a new registry key some time ago and no longer works. Instead, use the following registry key.

UserSessionTimeout
HKEY_LOCAL_MACHINE\SOFTWARE\Veeam\Veeam Backup Reporting\

The supplied value should be in DWORD (x32) format, decimal, in minutes. Please, restart Veeam Backup Enterprise Manager service after adding the value.

Note, that by default the length of the session is 10 minutes which is the golden mean according to security best practices.

Hope it helps,
Fedor

ungerkkt
Novice
Posts: 5
Liked: 1 time
Joined: Sep 03, 2019 5:09 am
Contact:

Re: Time out Enterprise Manager interface

Post by ungerkkt » Sep 05, 2019 8:32 am

What should be the name of the DWORD?

wishr
Veeam Software
Posts: 1327
Liked: 132 times
Joined: Aug 07, 2018 3:11 pm
Full Name: Fedor Maslov
Contact:

Re: Time out Enterprise Manager interface

Post by wishr » Sep 05, 2019 9:24 am

Hello,

It's "UserSessionTimeout". Here is an example with two minutes:

Image

Thanks

ungerkkt
Novice
Posts: 5
Liked: 1 time
Joined: Sep 03, 2019 5:09 am
Contact:

Re: Time out Enterprise Manager interface

Post by ungerkkt » Sep 05, 2019 9:47 am 1 person likes this post

Thank you for your help. Now it works.

FTBZ
Influencer
Posts: 22
Liked: 2 times
Joined: May 05, 2016 11:51 am
Contact:

Re: Time out Enterprise Manager interface

Post by FTBZ » Nov 18, 2019 1:35 pm

wishr wrote:
Sep 04, 2019 4:07 pm
Note, that by default the length of the session is 10 minutes which is the golden mean according to security best practices.
Thanks for the help.

Security best practices are good, but the problem is when you're downloading big files. When the session expires, the file download will stop. So it's perhaps a good idea to keep the downloading session running even if the user session has expired. Because for big files you need to set a long timeout.

wishr
Veeam Software
Posts: 1327
Liked: 132 times
Joined: Aug 07, 2018 3:11 pm
Full Name: Fedor Maslov
Contact:

Re: Time out Enterprise Manager interface

Post by wishr » Nov 18, 2019 4:08 pm

Hi FTBZ,

The download does not depend on the user login session. Are you experiencing the described behavior? If so, please open a support case so we can take a look at the log files for a better understanding.

Thanks

Post Reply

Who is online

Users browsing this forum: No registered users and 20 guests