VBR 9.0.0.1715 doesn't delete old backup copies

Availability for the Always-On Enterprise

VBR 9.0.0.1715 doesn't delete old backup copies

Veeam Logoby Eye-Q » Thu Dec 22, 2016 9:18 am

I have the following scenario at a customer:
- VBR 9.0.0.1715 on a Windows Server 2012 R2 Standard
- VMWare vSphere 6.0 Update 2 (one vCenter Server, one ESXi host)
- One backup job which backs up all VMs to a QNAP NAS (full backups are around 310 GB)
- The backup repository which points to the QNAP NAS is set to "Use per-VM backup files"
- One backup copy job which copies those backups to external 3TB HDDs which are connected to the QNAP NAS and get rotated daily
- The backup repository which points to the external HDDs is set to "This repository is backed by rotated hard drives"

Now we get to the issue I have: the backup copy job doesn't delete old backup copies, the external HDDs just fill up with full backup files and inevitably run out of space, even though the backup copy job is set to retain just two restore points. At the currently connected HDD there are 9 full backups and two incremental backups. At other customers which have exactly the same setup we don't have that issue.

Does anyone have a clue why deleting old restore points doesn't work in this case?
Eye-Q
Novice
 
Posts: 3
Liked: 1 time
Joined: Wed Dec 07, 2016 9:34 am
Full Name: Ingo Wandel

Re: VBR 9.0.0.1715 doesn't delete old backup copies

Veeam Logoby foggy » Thu Dec 22, 2016 10:29 am 1 person likes this post

Hi Ingo, what type of repository is used for the backup copy target - Windows or CIFS? In case of CIFS repository. the behavior looks expected and you need to use registry value to cleanup disks after swapping them.
foggy
Veeam Software
 
Posts: 15272
Liked: 1131 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson

Re: VBR 9.0.0.1715 doesn't delete old backup copies

Veeam Logoby Eye-Q » Thu Dec 22, 2016 10:42 am

Hi Alexander,

the type is indeed CIFS. I configured the registry value as mentioned in the second link, set it to 3 and restarted the Veeam Backup Service so the backup which is scheduled tonight should delete those old restore points. I'll keep you posted on the result.

Thanks so far.
Eye-Q
Novice
 
Posts: 3
Liked: 1 time
Joined: Wed Dec 07, 2016 9:34 am
Full Name: Ingo Wandel

Re: VBR 9.0.0.1715 doesn't delete old backup copies

Veeam Logoby foggy » Thu Dec 22, 2016 10:45 am

Feel free to contact our technical team if this still doesn't work as expected. They will take a closer look at your setup and are able review the logs, if needed.
foggy
Veeam Software
 
Posts: 15272
Liked: 1131 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson

Re: VBR 9.0.0.1715 doesn't delete old backup copies

Veeam Logoby Eye-Q » Fri Dec 23, 2016 9:23 am 1 person likes this post

The registry key setting helped, now there is just one backup copy restore point on the external HDD, as intended.

Thanks for the help, apparently I didn't read the documentation thoroughly enough.
Eye-Q
Novice
 
Posts: 3
Liked: 1 time
Joined: Wed Dec 07, 2016 9:34 am
Full Name: Ingo Wandel


Return to Veeam Backup & Replication



Who is online

Users browsing this forum: Google [Bot], Grebzy and 6 guests