Comprehensive data protection for all workloads
Post Reply
freddie.eichmann
Lurker
Posts: 1
Liked: never
Joined: Oct 10, 2017 11:41 am
Full Name: Freddie Eichmann
Contact:

Veeam Explorer for Sharepoint Time Out

Post by freddie.eichmann »

Hi everybody,

i want to restore some items with veeam explorer for SharePoint. Everything is running and i can open the explorer for SharePoint.
There are two databases
- content.mdf (with a big amount of data in GBs)
- content_2.mdf (with a minimal amount of data in MBs)

When i try to explore the content.mdf DB theres a error/message with the following text:
"Timeout expired. The timeout period elapsed Prior to completion of the Operation or the server is not responding. The wait Operation timed out".
The explore procedure of the content_2.mdf DB is working without any problems.

Is there any limitation of the SQL DB for SharePoint Explorer? (Size, Amount of Items, etc.)

DGrinev
Expert
Posts: 1943
Liked: 248 times
Joined: Dec 01, 2016 3:49 pm
Full Name: Dmitry Grinev
Location: St.Petersburg
Contact:

Re: Veeam Explorer for Sharepoint Time Out

Post by DGrinev »

Hi Freddie and welcome to the community!

The only thing I've found is MS Content DB recommended limit of 200GB as stated here: LINK
Please contact technical support and ask them to change the timeout parameter in the configuration file of Sharepoint explorer.
Also, share the case id here or your topic will be deleted according to the rules of the forum. Thanks!

PKaufmann
Enthusiast
Posts: 40
Liked: 5 times
Joined: Oct 05, 2016 8:00 am
Contact:

Re: Veeam Explorer for Sharepoint Time Out

Post by PKaufmann »

I am facing the same issue..
case is open #02469703

tried to extend the timeout in the config.xml to 60, and to 600, but no change :(

<Veeam>
<SharePointExplorer>
<SQL AutoEnableAttachNetworkFile="False" Server="XXXXXXX\STAGING" UseWindowsAuthentication="True" />
<SMTP UseSmtpSettings="False" />
<RESTORE RequestTimeout="600" />
</SharePointExplorer>
</Veeam>

PKaufmann
Enthusiast
Posts: 40
Liked: 5 times
Joined: Oct 05, 2016 8:00 am
Contact:

Re: Veeam Explorer for Sharepoint Time Out

Post by PKaufmann » 1 person likes this post

FYI, above parameters were wrong..

got the correct one from the support today, and the restore worked:

<Veeam>
<Core>
<Log Level="Extended" />
</Core>
<SharePointExplorer>
<Database CommandTimeout="900" />
</SharePointExplorer>
<SQLCore ConnectTimeout="900" CommandTimeout="900" />
</Veeam>

Mike Resseler
Product Manager
Posts: 6146
Liked: 718 times
Joined: Feb 08, 2013 3:08 pm
Full Name: Mike Resseler
Location: Belgium
Contact:

Re: Veeam Explorer for Sharepoint Time Out

Post by Mike Resseler » 1 person likes this post

Thanks for letting us know PKaufmann,

This will help others also! Much appreciated

Cheers
Mike

EvoTom
Enthusiast
Posts: 26
Liked: 1 time
Joined: Jul 11, 2012 10:18 am
Contact:

Re: Veeam Explorer for Sharepoint Time Out

Post by EvoTom »

Please could you let me know where the file is located to change the SharePointExplorer timeout value. I am running v9.5.

veremin
Product Manager
Posts: 17777
Liked: 1625 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: Veeam Explorer for Sharepoint Time Out

Post by veremin »

C:\ProgramData\Veeam\Backup\SharePointExplorer (if file doesn't exist there, feel free to create it). Thanks.

Simpleacc
Influencer
Posts: 12
Liked: never
Joined: Nov 13, 2017 10:02 am
Full Name: Javier
Contact:

Re: Veeam Explorer for Sharepoint Time Out

Post by Simpleacc »

Hello,

We have the same problem. The solution is create a file here C:\ProgramData\Veeam\Backup\SharePointExplorer\config.xml and paste this information?

<Veeam>
<Core>
<Log Level="Extended" />
</Core>
<SharePointExplorer>
<Database CommandTimeout="900" />
</SharePointExplorer>
<SQLCore ConnectTimeout="900" CommandTimeout="900" />
</Veeam>

Just this? Is not necessary enable something or activate a feature?

Best regards,

foggy
Veeam Software
Posts: 19285
Liked: 1741 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Veeam Explorer for Sharepoint Time Out

Post by foggy »

Hi Javier, yes, at least setting these timeouts helped people above. If doing the same doesn't address your issue, feel free to contact support for a closer look. Thanks!

Post Reply

Who is online

Users browsing this forum: pchin@sonicmfg.com, PetrM and 46 guests