Comprehensive data protection for all workloads
Post Reply
mplep
Service Provider
Posts: 62
Liked: never
Joined: Sep 16, 2009 7:50 pm
Contact:

You need to format the disk in drive G:

Post by mplep » Oct 12, 2010 4:40 pm

Hi,

I'm testing Veeam 4.1.2 in Virtual Appliance mode within an ESXi 4.0/4.1 environment with Veeam running upon a Server 2008 64bit VM. Veeam is sitting in our DR site (100MB leased line) and can address the live VM's datastore via iSCSI. After the initial seeding backup job completed yesterday I started a manual job today. After a couple of VM's had completed (very quickly I must add) a Windows prompt appeared saying "You need to format the disk in drive G: before you can use it", "Do you want to format it?" I obviously clicked "Cancel", but was concerned to see this appear. The job seemed to stop until I selected "Cancel". I can see that the VA mode mounts the VM disks as drive letters within Windows, so G was one of the VM disks being backed up. The job appeared to continued and that VM reported backup was a success. Any ideas on why this happened and how to avoid it happening again?

PS. I did have Windows Explorer open (but minimised) during my session.

Thanks

MPLEP

mplep
Service Provider
Posts: 62
Liked: never
Joined: Sep 16, 2009 7:50 pm
Contact:

Re: You need to format the disk in drive G:

Post by mplep » Oct 12, 2010 6:25 pm

Update: I returned to the session and had the same prompt onscreen but for the H: drive this time. Windows Explorer was not open this time however. I think the sessions do continue to run even with this message onscreen.

Vitaliy S.
Product Manager
Posts: 23088
Liked: 1588 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: You need to format the disk in drive G:

Post by Vitaliy S. » Oct 12, 2010 6:29 pm

Hello, try disabling autoplay functionality in the control panel of a Windows 2008 machine, should help. Thanks!

Gostev
SVP, Product Management
Posts: 24978
Liked: 3629 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: You need to format the disk in drive G:

Post by Gostev » Oct 13, 2010 1:45 pm

You want to disable automount on your Veeam Backup server.

mplep
Service Provider
Posts: 62
Liked: never
Joined: Sep 16, 2009 7:50 pm
Contact:

Re: You need to format the disk in drive G:

Post by mplep » Oct 13, 2010 3:18 pm

Thanks for the quick replies. I've disabled autoplay now.

ThinkGrid
Enthusiast
Posts: 55
Liked: 2 times
Joined: Jul 11, 2011 10:18 am
Contact:

[MERGED] You need to format the disk in drive before you can

Post by ThinkGrid » Jul 12, 2011 12:35 pm

Hi

I am receiving the above mentioned error come up a few times during the backups and it keeps crashing my Veeam application, sometimes freezing it and have to reboot the Server and kills all the running backups

Anyone seen it ?

Image

Thanks
Petrit

Gostev
SVP, Product Management
Posts: 24978
Liked: 3629 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: "You need to format the disk in drive before you can use

Post by Gostev » Jul 12, 2011 12:45 pm

Hi, do you have automount disabled on your Veeam Backup server?

ThinkGrid
Enthusiast
Posts: 55
Liked: 2 times
Joined: Jul 11, 2011 10:18 am
Contact:

Re: You need to format the disk in drive G:

Post by ThinkGrid » Jul 12, 2011 12:49 pm

Hi Gostev

Can you tell me where that Setting is please ?

Thanks

Gostev
SVP, Product Management
Posts: 24978
Liked: 3629 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: You need to format the disk in drive G:

Post by Gostev » Jul 12, 2011 1:06 pm 1 person likes this post

Please Google or search this forum for Windows automount. Thanks.

lars@norstat.no
Expert
Posts: 109
Liked: 14 times
Joined: Nov 01, 2011 1:44 pm
Full Name: Lars Skjønberg
Contact:

[MERGED] VBR 6.5 Proxy. Promt to format disk.

Post by lars@norstat.no » Oct 31, 2012 10:17 am

On two of my virtual proxies that handle replication sometimes windows will prompt me to format one of the disk's it has mounted or ask me to scan and fix a drive ....

It only prompts me on thoose two servers.

All four servers are made from the same template and are Windows 2008 R2 with automount disabled. All four servers have four SCSI controllers added with one 1gb "dummy" disk not mounted added to each controller so that vmware does not remove the controller.

The difference is that the two servers that are not prompting are 6 core and the two that do is 8 core ....

Vitaliy S.
Product Manager
Posts: 23088
Liked: 1588 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: You need to format the disk in drive G:

Post by Vitaliy S. » Oct 31, 2012 8:26 pm

Not sure that the number of cores matters, automount command should do the trick. Does this happen on all processed VMs or just on particular ones?

1971merlin
Influencer
Posts: 17
Liked: never
Joined: Jun 01, 2014 6:03 am
Full Name: Craig Hart
Contact:

Re: You need to format the disk in drive G:

Post by 1971merlin » Aug 22, 2016 6:52 am

For us, issuing the command DISKPART AUTOMOUNT SCRUB from the commandline of the VM fixed the issue.

My Theory is that VEEAM somehow reads the automount data (Registry?) and tries to mount all the fixed disk volumes in order to back them up. Disks such as iSCSI are considered local (i.e. not removable) therefore fail the mount (because they no longer exist), in turn this fails the VSS snapshot and also generates the erronous "format" dialog on the console.

I discovered this because every server I've had this issue on, has previously backed up using Windows server Backup, to an iSCSI volume - that was the common denominator that pointed to the issue for us.

Post Reply

Who is online

Users browsing this forum: Bing [Bot], JoseM and 59 guests