FIPS error new nworks install

Unleash the power of System Center for vSphere and Hyper-V | Veeam Task Manager for Hyper-V

FIPS error new nworks install

Veeam Logoby mjd9ball » Wed Mar 23, 2011 1:23 pm

Hello, I am sorry if there is an obvious answer to this question, i have been searching and will continue to do so. I have installed nworks 5.6 components all on a Win2k8 server, installs seemed to go OK, but when i try to bring up the UI I am greeted by the following error:

Server Error in '/' Application.
--------------------------------------------------------------------------------
Parser Error
Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.
Parser Error Message: This implementation is not part of the Windows Platform FIPS validated cryptographic algorithms.
Source Error:
Line 1: <%@ Application Language="C#" CodeBehind="Application.cs" Inherits="LS_UI.Application" %>
Source File: /global.asax Line: 1
--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.4206; ASP.NET Version:2.0.50727.4209

I have tried a workaround out there from Microsoft that adds some code the the default web.config file for the application but am still getting the error. I thought I had all of the prereqs fulfilled, have reinstalled all IIS components, rebooted, etc...

Thanks in advance for any assistance or direction you can provide
mjd9ball
Lurker
 
Posts: 1
Liked: never
Joined: Wed Mar 23, 2011 12:38 pm

Re: FIPS error new nworks install

Veeam Logoby flavor4real » Thu Apr 14, 2011 7:37 pm

Hello,
I've fixed mine 4 weeks ago but today once I've upgraded to the latest enterprise manager, I experience the same issue. I looked at the web.config and added the line but no result.

did u get urs fixed?
flavor4real
Expert
 
Posts: 205
Liked: 5 times
Joined: Mon Nov 22, 2010 7:57 pm
Full Name: DS

Re: FIPS error new nworks install

Veeam Logoby flavor4real » Thu Apr 14, 2011 7:42 pm

don;t worry,... I've been trying for 1-2 hrs and finally got it fixed. Thx
flavor4real
Expert
 
Posts: 205
Liked: 5 times
Joined: Mon Nov 22, 2010 7:57 pm
Full Name: DS

Re: FIPS error new nworks install

Veeam Logoby vBPav » Wed Apr 20, 2011 12:20 am

Hello,

If either of you are still experiencing this issue I would recommend opening up a case with Veeam Support.

Thanks!

-Brian
Brian Pavnick | Cireson| Solutions Architect

- Follow me on Twitter @ vbpav
- Reach me on e-mail @ brian.pavnick@cireson.com
vBPav
Expert
 
Posts: 181
Liked: 13 times
Joined: Wed Jan 13, 2010 6:08 pm
Full Name: Brian Pavnick

Re: FIPS error new nworks install

Veeam Logoby jsoled » Mon Apr 25, 2011 4:58 pm

We have a line in web.config that turns on debug mode but our developers have informed me that there isn't a reason to leave this on in production. If debug mode is on, it ignores the default algorithm specified in the web.config or elsewhere in IIS configuration and uses RijndaelManaged (an offshoot of AES) which is NOT FIPS compliant.

So the fix is...
edit that line to turn off debug mode.
make sure 3DES is the algorithm you are using.

if possible use .net 3.5 sp1 rather than 2.0
jsoled
Enthusiast
 
Posts: 48
Liked: never
Joined: Tue Jun 16, 2009 1:01 pm
Full Name: Jason Soled


Return to Veeam Management Pack for Microsoft System Center



Who is online

Users browsing this forum: No registered users and 4 guests