Upgrading/reinstalling nworks from old versions

Unleash the power of System Center for vSphere and Hyper-V | Veeam Task Manager for Hyper-V

Upgrading/reinstalling nworks from old versions

Veeam Logoby clocatel » Tue Mar 08, 2011 3:18 pm

Hello,

I have a customer with an old version of nWorks for SCOM (3.6?). He asked us for upgrading his 3.5 ESX servers to 4.1.
We decided to create another production infrastructure which should start with a vCenter 4.1 and 2 vSphere servers to test backup, provisionning, monitoring.

What is the impact of installing a 5.6 nworks server in this new infrastructure ?
- are 3.6 management packs are overridden, so 3.6 will stop to monitor VI 3.5 (only one SCOM environment)
- is it possible to have these 2 servers to monitor at the same time their own vmware infrastructure ?

is it true that installing 5.6 MP will override 3.6 MP and customization. So we will need to customize again 5.6 MP.

Regards,
Cedric.
clocatel
Novice
 
Posts: 3
Liked: never
Joined: Thu Feb 18, 2010 2:59 pm
Full Name: Cedric Locatelli

Re: Upgrading/reinstalling nworks from old versions

Veeam Logoby vBPav » Thu Mar 17, 2011 7:29 am

Hello Cedric,

nworks MP 5.6 is necessary (technically 5.5.2) in order to manage that vSphere 4.1 Inf. nworks MP 5.6 will also work fine with the VI 3.5 Inf. Looks like you will be doing an upgrade to nworks MP 5.6. For this nworks 5.6 Infrastructure, we recommend Windows Server 2008 R2 (but do not require this) to run as your collectors. In most cases, you will be looking at a parallel installation of nworks 5.6. The final "cut over" is when you Install the nworks MP 5.6 MP within the SCOM environment. To do this you will need to:

1.) Export override MP's
2.) Delete the 3.6 MP
3.) Import the 5.6 MP
4.) Import the override MP's

As for their override MP's, it should be able to import directly over 5.6. However, many discoveries, rules, and monitors have either been added, removed, or changed since nworks MP 3.6. An example of this is that most performance Monitors in 5.6 use multi-state thresholds. Where as in 3.6 these did not exist. What you will see are overrides trying to target a property called, "Threshold" while in MP 5.6 there are two called, "Threshold 1" and "Threshold 2". Since "Threshold" does not exist, this override will more than likely not function at all. I would recommend documenting the overrides, compare them with the default Monitor settings within MP 5.6, and then have a discussion with the customer. I would wager to bet that a good chunk of those overrides will not be necessary with all of the improvements that have been made over the time within the nworks MP for VMware.

Hope this helps!
Brian Pavnick | Cireson| Solutions Architect

- Follow me on Twitter @ vbpav
- Reach me on e-mail @ brian.pavnick@cireson.com
vBPav
Expert
 
Posts: 181
Liked: 13 times
Joined: Wed Jan 13, 2010 6:08 pm
Full Name: Brian Pavnick


Return to Veeam Management Pack for Microsoft System Center



Who is online

Users browsing this forum: No registered users and 2 guests