Monitoring and reporting for Veeam Backup & Replication, VMware vSphere and Microsoft Hyper-V
joespirit88
Enthusiast
Posts: 29
Liked: 3 times
Joined: Jul 04, 2017 12:53 pm
Full Name: Joe Spirit
Contact:

9.5 update 4 High resource usage on Backup servers

Post by joespirit88 » Jan 30, 2019 11:02 am

Hi,

I have upgraded my veeam one to the latest update but have noticed it seems to be causing my backup and replication servers to lock up constantly.

Looking at task manager it seems to be related to Veeam.backup.WMIserver which from what i understand is started by Veeam One.
This process is spiking to nearly the 30% cpu constantly which seems overly unnecessary for a wmi query, the server is a vm with 6 cpus and 24 GB ram so its not under resourced either.

Is anyone else seeing this behaviour after the update?

Shestakov
Veeam Software
Posts: 6310
Liked: 584 times
Joined: May 21, 2014 11:03 am
Full Name: Nikita Shestakov
Location: Prague
Contact:

Re: 9.5 update 4 High resource usage on Backup servers

Post by Shestakov » Jan 30, 2019 12:15 pm

Hi Joe,
You are the first one reporting it. Could you contact Veeam technical support to investigate the behavior?
Thanks!

joespirit88
Enthusiast
Posts: 29
Liked: 3 times
Joined: Jul 04, 2017 12:53 pm
Full Name: Joe Spirit
Contact:

Re: 9.5 update 4 High resource usage on Backup servers

Post by joespirit88 » Jan 30, 2019 12:29 pm

Sure I'll post back my case number and any findings

joespirit88
Enthusiast
Posts: 29
Liked: 3 times
Joined: Jul 04, 2017 12:53 pm
Full Name: Joe Spirit
Contact:

Re: 9.5 update 4 High resource usage on Backup servers

Post by joespirit88 » Jan 30, 2019 12:41 pm

case number 03389004

Shestakov
Veeam Software
Posts: 6310
Liked: 584 times
Joined: May 21, 2014 11:03 am
Full Name: Nikita Shestakov
Location: Prague
Contact:

Re: 9.5 update 4 High resource usage on Backup servers

Post by Shestakov » Jan 30, 2019 1:50 pm

Thank you for sharing the case number, Joe!
I'll keep track of your case as we expected better performance after upgrade.
Once assistance is needed, let me know.

nickcasa3
Novice
Posts: 4
Liked: never
Joined: Jul 22, 2016 3:01 pm
Full Name: nick casagrande
Contact:

[MERGED] Veeam One server is pounding Veeam B&R Server

Post by nickcasa3 » Jan 30, 2019 2:17 pm

I installed VeeamOne trial on a new vm, all is working well, however my B&R server is at 100% cpu and has been for about 12 hours, why would this be happening? I have a small environment, 4 hosts and about 40 vm's being backed up between 2 jobs. Nothing special honestly. I had to shut down veeam one for now to get the b&r server to come back down to a normal 10% cpu level.

nickcasa3
Novice
Posts: 4
Liked: never
Joined: Jul 22, 2016 3:01 pm
Full Name: nick casagrande
Contact:

Re: 9.5 update 4 High resource usage on Backup servers

Post by nickcasa3 » Jan 30, 2019 2:18 pm

I have this same issue and just posted a topic about it as well. VeeamOne is pounding my b&r server to the point where I had to shutdown veeam one.

Shestakov
Veeam Software
Posts: 6310
Liked: 584 times
Joined: May 21, 2014 11:03 am
Full Name: Nikita Shestakov
Location: Prague
Contact:

Re: 9.5 update 4 High resource usage on Backup servers

Post by Shestakov » Jan 30, 2019 2:22 pm

Hello Nick and welcome to the community!
Could you also provide a support case number?
Thanks!

nickcasa3
Novice
Posts: 4
Liked: never
Joined: Jul 22, 2016 3:01 pm
Full Name: nick casagrande
Contact:

Re: 9.5 update 4 High resource usage on Backup servers

Post by nickcasa3 » Jan 30, 2019 2:26 pm

I have not logged a case yet, I just came here to see if others were having the same issue and apparently they are. I am running 9.5u4 for veeam one and 9.5.0.1922 for b&r

Shestakov
Veeam Software
Posts: 6310
Liked: 584 times
Joined: May 21, 2014 11:03 am
Full Name: Nikita Shestakov
Location: Prague
Contact:

Re: 9.5 update 4 High resource usage on Backup servers

Post by Shestakov » Jan 30, 2019 2:28 pm 1 person likes this post

As was said the behavior is not expected, so it worth contacting the support team. Once we have a fix, support engineers will provide it to you.

joespirit88
Enthusiast
Posts: 29
Liked: 3 times
Joined: Jul 04, 2017 12:53 pm
Full Name: Joe Spirit
Contact:

Re: 9.5 update 4 High resource usage on Backup servers

Post by joespirit88 » Jan 31, 2019 2:07 pm

Had a webex this morning with an engineer, they have collected some logs and are speaking to the dev team

Shestakov
Veeam Software
Posts: 6310
Liked: 584 times
Joined: May 21, 2014 11:03 am
Full Name: Nikita Shestakov
Location: Prague
Contact:

Re: 9.5 update 4 High resource usage on Backup servers

Post by Shestakov » Jan 31, 2019 2:33 pm

Thanks for the update,
I've also talked to developers and it turned out that after upgrade to u4 Veeam ONE needs to recollect historical performance data from VBR and since the new collector is much powerful, it may cause CPU usage on VBR side for 15-25%.
How many CPUs do have assigned to VBR server?

joespirit88
Enthusiast
Posts: 29
Liked: 3 times
Joined: Jul 04, 2017 12:53 pm
Full Name: Joe Spirit
Contact:

Re: 9.5 update 4 High resource usage on Backup servers

Post by joespirit88 » Jan 31, 2019 3:00 pm

We have 6 vCPU's for the backup server, we were seeing the CPU spiking above 40% for the Veeam WMI Server exe.
If it is collecting historical data how long should we expect it to take, can we skip the historical data import?
It seems a bit overkill that the monitoring server can take out the backup server

Shestakov
Veeam Software
Posts: 6310
Liked: 584 times
Joined: May 21, 2014 11:03 am
Full Name: Nikita Shestakov
Location: Prague
Contact:

Re: 9.5 update 4 High resource usage on Backup servers

Post by Shestakov » Jan 31, 2019 3:05 pm

Duration depends on infrastructure size, but approximately will take 1-3 days, after that the load should be back to normal low values. It cannot be skipped in GUI, but you may ask support if it's an option.
Is the load distributed among all CPUs or it's 100% for one of the units?

joespirit88
Enthusiast
Posts: 29
Liked: 3 times
Joined: Jul 04, 2017 12:53 pm
Full Name: Joe Spirit
Contact:

Re: 9.5 update 4 High resource usage on Backup servers

Post by joespirit88 » Jan 31, 2019 3:48 pm

I have currently stopped the veeam one service, however I might re enable it over the weekend whilst I won't be accessing the console and see what the performance is like monday

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests