Monitoring and reporting for Veeam Backup & Replication, VMware vSphere and Microsoft Hyper-V
Vitaliy S.
Product Manager
Posts: 22131
Liked: 1382 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: Heartbeat is missing for VM

Post by Vitaliy S. » Apr 08, 2014 7:54 am

Yes, it was a great catch, that slipped my mind for some reason.

genetorres
Lurker
Posts: 2
Liked: never
Joined: May 08, 2014 8:38 pm
Full Name: Gene Torres
Contact:

Re: Heartbeat is missing for VM

Post by genetorres » May 08, 2014 8:42 pm

Hi guys, I found this via a search, and I'm looking at the "heartbeat" counter for a VM. Since you've been discussing it, and I never use this counter for anything, could someone tell me exactly what this counter means? I'm seeing numbers like this:

Max: 737686 Min: 1200 Average: 27610 and there are two huge spikes over a 1 hour period every 24 hours (when backups are running) and outside of that, this line in the graph is a flat line. I'm not looking to solve a problem, but simply understand what these numbers mean.

Thanks!

v.Eremin
Product Manager
Posts: 15976
Liked: 1284 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: Heartbeat is missing for VM

Post by v.Eremin » May 12, 2014 9:44 am

Hearbeat alarm shows up, if VM is either unavailable or overloaded for a certain period of time. Thanks.

Vitaliy S.
Product Manager
Posts: 22131
Liked: 1382 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: Heartbeat is missing for VM

Post by Vitaliy S. » May 13, 2014 5:22 am

This counter represents how many heart beats your VM had in a certain time period, these spikes are usually caused be VM reboots and other activities. In the best case the line should be flat indeed.

edvschriesheim
Influencer
Posts: 13
Liked: 1 time
Joined: Jan 21, 2015 8:46 am
Full Name: Schriesheim
Contact:

[MERGED] Heatbeat is missing - Citrix Linked-Clone-VM runs

Post by edvschriesheim » Jan 28, 2016 6:17 am

Hi Guys,

i have an nearly identical problem as this guy: http://forums.veeam.com/veeam-one-f28/h ... 21181.html

We have a couple of Citrix Linked Clone VMs. Some of the Clones produced the "Hearbeat is missing" Error.
Everything in the VMs runs fine and in the vSphere Chart the Heartbeat seems ok.
I reinstalled vSphere Tools in the Citrix Master and recreated the clones, but the error comes up again. I thin about 2-3 Times a day.

Veeam One reports the following
Error Heartbeat Missing 06:10:55
Resolved Heartbeat Missing 06:14:18

During this Time vSphere show's me a constant heartbeat of 30
Image

Any suggestion how we can resolve this issue?

Greetings
Tobias

Shestakov
Veeam Software
Posts: 6414
Liked: 611 times
Joined: May 21, 2014 11:03 am
Full Name: Nikita Shestakov
Location: Prague
Contact:

Re: Heartbeat is missing for VM

Post by Shestakov » Jan 28, 2016 2:11 pm

Hello Tobias,
That looks like a bug.
Do you observe other performance metrics during that time period(06:10:55-06:14:18)?
Btw, what product version you are at?
Thanks!

Vitaliy S.
Product Manager
Posts: 22131
Liked: 1382 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: Heartbeat is missing for VM

Post by Vitaliy S. » Jan 28, 2016 2:18 pm

Also what is the difference between VM clones that have this error and the ones that don't? Are they hosted on the same server, datastore etc?

edvschriesheim
Influencer
Posts: 13
Liked: 1 time
Joined: Jan 21, 2015 8:46 am
Full Name: Schriesheim
Contact:

Re: Heartbeat is missing for VM

Post by edvschriesheim » Feb 05, 2016 7:02 am

We're now on Veeam One 9, but the error occured on Veeam One 8, too.
The other metrics during that time period are fine. The VM itself also runs without any problems.

There's no differne betweeen the clones. There on the same Servers and the same datastore.

Shestakov
Veeam Software
Posts: 6414
Liked: 611 times
Joined: May 21, 2014 11:03 am
Full Name: Nikita Shestakov
Location: Prague
Contact:

Re: Heartbeat is missing for VM

Post by Shestakov » Feb 05, 2016 9:10 am

Considering that, I would suggest to contact Veeam support for the further investigation.
Once you have a support case # please post it here.
Thanks!

edvschriesheim
Influencer
Posts: 13
Liked: 1 time
Joined: Jan 21, 2015 8:46 am
Full Name: Schriesheim
Contact:

Re: Heartbeat is missing for VM

Post by edvschriesheim » Feb 05, 2016 9:22 am 1 person likes this post

Support Case is #01689940

edvschriesheim
Influencer
Posts: 13
Liked: 1 time
Joined: Jan 21, 2015 8:46 am
Full Name: Schriesheim
Contact:

Re: Heartbeat is missing for VM

Post by edvschriesheim » Feb 16, 2016 8:44 am

Case is closed. I got a Registry File with some changes in the Registry of the Veeam One Monitor Server. That solved the issue.

The Reg File increased the time interval during which Heartbeat is not monitored after system starts.

Shestakov
Veeam Software
Posts: 6414
Liked: 611 times
Joined: May 21, 2014 11:03 am
Full Name: Nikita Shestakov
Location: Prague
Contact:

Re: Heartbeat is missing for VM

Post by Shestakov » Feb 16, 2016 9:53 am

Interesting! Thanks for updating the topic.

edvschriesheim
Influencer
Posts: 13
Liked: 1 time
Joined: Jan 21, 2015 8:46 am
Full Name: Schriesheim
Contact:

Re: Heartbeat is missing for VM

Post by edvschriesheim » Feb 16, 2016 10:26 am

Is it allowed to post the registry file, so others can use the same solution?

Shestakov
Veeam Software
Posts: 6414
Liked: 611 times
Joined: May 21, 2014 11:03 am
Full Name: Nikita Shestakov
Location: Prague
Contact:

Re: Heartbeat is missing for VM

Post by Shestakov » Feb 16, 2016 10:30 am

It`s not necessary for you to do that. We will discuss the issue with support and devs and create a KB article if needed.
Thanks for your participation!

[UPD]
The bug is going to be fixed in the update 1, which is planned for the end of February.
Those who have the same problem, can get the registry via technical support.

Shestakov
Veeam Software
Posts: 6414
Liked: 611 times
Joined: May 21, 2014 11:03 am
Full Name: Nikita Shestakov
Location: Prague
Contact:

Re: Heartbeat is missing for VM

Post by Shestakov » Mar 24, 2016 2:22 pm

Glad to inform that v9 update 1 has been released and discussed issue is fixed there.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests