Monitoring and reporting for Veeam Backup & Replication, VMware vSphere and Microsoft Hyper-V
Post Reply
jtupeck
Enthusiast
Posts: 33
Liked: 6 times
Joined: Aug 27, 2013 3:44 pm
Full Name: Jason Tupeck
Contact:

Veeam ONE Reporter/Business View Data Collection Failure

Post by jtupeck » Sep 20, 2017 8:21 pm

Hi all,

I am getting the following error/warning in my logs for Veeam ONE Reporter collections: [error]: Failed to collect Inventory Service Tags data. Virtual infrastructure server communication error

We recently upgraded our vCenter to version 6.0.0.30200 Build Number 5326079. I am uncertain if this is the cause of our current issue with Veeam ONE data collections, but it oculd be the catalyst. Unfortunately there are no more updates available for vCenter at this time AND we have another vCenter Server Appliance on the same version which is working just fine. I am trying to pull the vCenter Tag information into my Veeam ONE Business View instance, so I can begin really using the software to its potential. Due to this one error, I currently have an incomplete data set and sadly the majority of the data is in the vCenter that is failing to import.

I called support (Case #02317733) and was told that this is a known issue, but the support engineer was helpful and took a look at the environment anyway, to see if there were any configuration suggestions he could offer. Apparently everything is set up appropriately, however he did have a suggestion that I use a service account on our domain vs. a vsphere.local account, citing that sometimes Veeam ONE data collections prefer a domain account and simply work better that way. I am now re running a data collection process and hope to have some good results, but so far the collection job seems to be hanging up on the "Creating file search tasks" operation, having now been running for nearly 30 minutes, while my other vCenters seem to run for bout 8-10 before reporting a successful line in the logs.

I wanted to put this out there to see if anyone had experienced the "[error]: Failed to collect Inventory Service Tags data" issue and what might have been the resolution. I do not want to wait until either VMware or Veeam releases a patch for this, if I don't need to and it seems kind of odd that one other environment on the same version of vCenter is working fine. Any thoughts anyone might have would be much appreciated in the meantime!

Thanks!

jtupeck
Enthusiast
Posts: 33
Liked: 6 times
Joined: Aug 27, 2013 3:44 pm
Full Name: Jason Tupeck
Contact:

Re: Veeam ONE Reporter/Business View Data Collection Failure

Post by jtupeck » Sep 20, 2017 8:23 pm

While I was typing this, the collection session completed with the same error. Connecting to the vCenter server with a different account did not provide any additional benefit.

Also, please note, I am not sure if this was working PRIOR to the vCenter upgrade that occurred a month or so ago, because we only recently began working to get Veeam ONE Business View working with VMware tags and taking advantage of the reporting features. Thanks again!

Shestakov
Veeam Software
Posts: 6030
Liked: 522 times
Joined: May 21, 2014 11:03 am
Full Name: Nikita Shestakov
Location: Prague
Contact:

Re: Veeam ONE Reporter/Business View Data Collection Failure

Post by Shestakov » Sep 25, 2017 9:52 am 1 person likes this post

Hello Jason,
there is only one alike topic I can remember it that seems to be VMware bug. I`ll ask support team if they have more information and post here if there is something to share.
Thanks!

jtupeck
Enthusiast
Posts: 33
Liked: 6 times
Joined: Aug 27, 2013 3:44 pm
Full Name: Jason Tupeck
Contact:

Re: Veeam ONE Reporter/Business View Data Collection Failure

Post by jtupeck » Sep 28, 2017 2:47 am 1 person likes this post

@Shestakov. Thank you. I was told by support that it was a known issues with vCenter 6.0 and that a fix would be coming for the next Update for Veeam ONE. When I mentioned that I had another vCenter on the SAME code revision that was being scanned normally without issues by the same Veeam ONE server instance, we decided not to close the case and wait, but rather to elevate to Tier 2 support. Someone logged in with me and did some wizardry that actually ended up fixing the issue!

This is resolved, but sadly it was nothing I did on my end to resolve it. Thank you Veeam Support!

Shestakov
Veeam Software
Posts: 6030
Liked: 522 times
Joined: May 21, 2014 11:03 am
Full Name: Nikita Shestakov
Location: Prague
Contact:

Re: Veeam ONE Reporter/Business View Data Collection Failure

Post by Shestakov » Sep 28, 2017 2:00 pm

Thanks for the update, Jason!
New update will be available in 4-6 weeks by the way, so stay tuned.

AbdulMohsin
Novice
Posts: 4
Liked: 1 time
Joined: Jan 25, 2018 10:13 am
Full Name: Abdul Mohsin
Contact:

Re: Veeam ONE Reporter/Business View Data Collection Failure

Post by AbdulMohsin » Jan 25, 2018 10:21 am 1 person likes this post

Create a registry key HKEY_LOCAL_MACHINE\SOFTWARE\Veeam\Reporter Enterprise\ForceTagsViaVCloudSuiteSDK = 1 (DWORD)
Reboot VEEAM ONE server, re-run the task manually. It will be a success!!

Abdul Mohsin.

Shestakov
Veeam Software
Posts: 6030
Liked: 522 times
Joined: May 21, 2014 11:03 am
Full Name: Nikita Shestakov
Location: Prague
Contact:

Re: Veeam ONE Reporter/Business View Data Collection Failure

Post by Shestakov » Jan 25, 2018 5:12 pm

Or upgrade to v9.5u3 which is already released :)

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests