Discussions specific to the VMware vSphere hypervisor
Post Reply
sosborne
Enthusiast
Posts: 53
Liked: 3 times
Joined: Jan 30, 2018 12:06 pm
Full Name: Simon Osborne
Contact:

Backup files not detected on a SOBR

Post by sosborne » Apr 23, 2019 1:43 pm

I am in the process of expanding storage and created a SOBR in order to do so.

However, some backup files placed on the SOBR were not detected after a rescan. As a bit of background these files were exported, removed from configuration, the files copied to the new drive, a new repository created, then a SOBR created, the vbms metadata tweaked and then a rescan performed. At this stage I would expect to see them pop up in Backup (Encrypted) but they didn't. I can import them separately. However, this is more work and I will have to re do a lot of what I have already done.

Is there something I am missing? I have only just started using SOBR's so it wouldn't surprise me. Any advise?

Note: there were backups on the other extent which have been recognised fine, with jobs and repositories being automatically repointed as expected (but I wasn't doing anything else with these).

foggy
Veeam Software
Posts: 18239
Liked: 1556 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Backup files not detected on a SOBR

Post by foggy » Apr 23, 2019 5:52 pm

vbms metadata tweaked
Hi Simon, this is what confuses me most of all - could you please elaborate on this step? What specifically did you do and why this was needed?

sosborne
Enthusiast
Posts: 53
Liked: 3 times
Joined: Jan 30, 2018 12:06 pm
Full Name: Simon Osborne
Contact:

Re: Backup files not detected on a SOBR

Post by sosborne » Apr 24, 2019 7:52 am

I tweaked the job name, dir name, folder name and meta file name so it could be a bit more organised at Console and file/folder level given that I was exporting a restore point for every VM in system and things were getting a little busy. Note I didn't alter the vbk name.

sosborne
Enthusiast
Posts: 53
Liked: 3 times
Joined: Jan 30, 2018 12:06 pm
Full Name: Simon Osborne
Contact:

Re: Backup files not detected on a SOBR

Post by sosborne » Apr 24, 2019 8:02 am

Also I have done a similar export, and metadata tweak without issue before on another regular repository (so it had been tested). These files given their size needed to go on the new SOBR repository.

sosborne
Enthusiast
Posts: 53
Liked: 3 times
Joined: Jan 30, 2018 12:06 pm
Full Name: Simon Osborne
Contact:

Re: Backup files not detected on a SOBR

Post by sosborne » Apr 24, 2019 2:45 pm 1 person likes this post

I managed to resolve it in a round about way. I removed the extent from the SOBR as it didn't have any backups on it currently in the config. And then I rescanned the repository, the backups were picked up as encrypted, I put in the password for encryption for each, and then added the repository as an extent to the SOBR.

So the result was achieved even if I didn't wrap my head round why it should specifically be a problem. I suspect there may be something in the rest of the metadata in the vbm's. But given they were copied from a different repository anyway I don't know. But at least I can move forward now. And I shouldn't need to mess around with exports anytime soon it was just to overcome an issue.

Post Reply

Who is online

Users browsing this forum: No registered users and 12 guests