Discussions specific to the VMware vSphere hypervisor
Post Reply
george@itb
Novice
Posts: 7
Liked: never
Joined: Apr 16, 2019 9:39 pm
Full Name: George Lavrov
Contact:

Backup Job “failed” false positive status when integrating with Storage Snapshots

Post by george@itb » Apr 16, 2019 10:11 pm

Hi Folks,
Spoke with tech support on this but was redirected here for answers. The specific issue is around backup job status as “failed” when one or number of VMs are failing to create a snapshot. However, our backup jobs integrated with a Storage Platform’s Snapshot (Netapp) and Snapmirror to the DR. Our Backup jobs configured to target Netapp volumes presented to Vcenter, and not selected VMs, as in more common scenarios. And those Netapp integrated Volume snapshot jobs will complete regardless of VM being snapshot or not prior that process, so the status of the job should be “warning” NOT “failed”. Problem is those job “failure” statuses that occurs randomly on different VMs and different days affecting overall reporting on the quality of backups and triggering false positives in the job monitoring system. Also, It's not that simple to keep explaining to the different managers that VMs are available for restores, regardless of those “failure” statuses, and even demonstrating so. For those organizations that have to go through external audits, this can be a big challenge demonstrating clean backup history. There has to be a way to properly identify the job status while accounting for additional factors, such as an external storage integration.
Thanks.

Gostev
SVP, Product Management
Posts: 24803
Liked: 3563 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Backup Job “failed” false positive status when integrating with Storage Snapshots

Post by Gostev » Apr 16, 2019 11:30 pm

Hello, it is a bit strange support sent you here, as incorrect job status would be a bug that they should escalate into R&D for fixing per our standard process. If you let me know the support case ID, I will make sure your case follows the correct workflow. Thanks!

george@itb
Novice
Posts: 7
Liked: never
Joined: Apr 16, 2019 9:39 pm
Full Name: George Lavrov
Contact:

Re: Backup Job “failed” false positive status when integrating with Storage Snapshots

Post by george@itb » Apr 17, 2019 12:41 am

I discussed couple of issues with the support, this was one of them and basically I got "this is how it is" answer and a suggestion to post here. I doubt it was even recorded into the original ticket, which itself got split (reasonably) into different tickets 03517214 and 03517176. But I still like to understand how this issue can be resolved now or in the near future. Thx.

foggy
Veeam Software
Posts: 18278
Liked: 1564 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Backup Job “failed” false positive status when integrating with Storage Snapshots

Post by foggy » Apr 18, 2019 6:27 pm

Hi George, neither of these cases mentions the above behavior, however, without being able to see what actually happens we are not able to address it (or confirm it is by design). It is impossible to judge based on the information in this thread solely. I'd appreciate if you could open a dedicated case for this issue and provide logs covering the described behavior for our investigation. Thanks!

Post Reply

Who is online

Users browsing this forum: No registered users and 9 guests