Can VEEAM backup job delete or corrupt a VM?

VMware specific discussions

Can VEEAM backup job delete or corrupt a VM?

Veeam Logoby mysticalice » Sat Sep 05, 2015 7:48 pm

Set up a backup job in veeam to back up four servers (two windows, two Linux). "Velocity" and "Time IPS" are Linux. The backup job ran and 3 of the VMs worked but the 4th didn't (see below picture).
The second time I ran it it failed too.

What's very concerning is before running the backup job, the VM was running just fine. After running it (and it failed), the VM was off with an error that said "snapshot consolidation needed". There were no snapshots, and the VM wouldn't start up. In the end I handed to restore from a backup. The vmx, vmdk, and other files existed on the datastore, but it wouldn't power on.

Wasn't aware that veeam would be able to damage a virtual machine, linux or otherwise. Looks like a snapshot was taken and then it wasn't able to be deleted? Very worried. The problem is over, but I'm still concerned about creating a new backup job to back up this new TIME IPS server.

Any ideas?
See picture below
Also, still have access to any logs if anyone wants to see them. Again - this is not something that's critical enough to get veeam or VMware involved, but just interested to see what anyone has to suggest.

Image
mysticalice
Influencer
 
Posts: 20
Liked: 2 times
Joined: Wed Aug 03, 2011 5:44 pm
Full Name: mysticalice

Re: Can VEEAM backup job delete or corrupt a VM?

Veeam Logoby hiraoglu » Mon Sep 07, 2015 12:45 am

Hi,

I had the same issue, after a vCenter Snapshot. Try to migrate the VM to another host in the cluster or remove it from vCenter inventory and then add back again.
hiraoglu
Lurker
 
Posts: 2
Liked: never
Joined: Sun Feb 16, 2014 2:47 pm

Re: Can VEEAM backup job delete or corrupt a VM?

Veeam Logoby foggy » Mon Sep 07, 2015 10:31 am

There're most likely some environmental reasons for this behavior, please review a couple of existing threads with similar issues:

V8 backups causing VMs to crash and restart?
An error occured while taking snapshot
foggy
Veeam Software
 
Posts: 14752
Liked: 1083 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson


Return to VMware vSphere



Who is online

Users browsing this forum: No registered users and 20 guests