Discussions specific to the VMware vSphere hypervisor
Post Reply
mbeckey
Influencer
Posts: 16
Liked: 2 times
Joined: Sep 26, 2012 1:31 am
Full Name: Mark Beckey
Contact:

Error. The object or item referred to could not be found

Post by mbeckey » Oct 16, 2012 12:11 pm

We are in the process of configuring Veeam to replicate some of our guests from our production site to our DR data center. Both Vcenter servers are added to the Veeam console and when creating the job Veeam sees both environments without any issues. When the job runs it fails and returns the error "Error. The object or item referred to could not be found" on the target host at the DR site. We are using Veeam 6.1 and the VMware environments are completely separate from each other we are running VSphere 4.1 with ESX hosts at our production site and VSphere 5.01 with ESXi hosts at the DR site.

When the job runs it is able to take the snap shot at the production site and it is also able to create the replica at the DR site. Any thoughts on what would be causing the Error?

habibalby
Expert
Posts: 379
Liked: 24 times
Joined: Jul 18, 2011 9:30 am
Full Name: Hussain Al Sayed
Location: Bahrain
Contact:

Re: Error. The object or item referred to could not be found

Post by habibalby » Oct 16, 2012 12:20 pm

Hi, did you select the VM that you replicate from the vCenter that added to the Veeam Console, or you have selected the VM from a host that added to Veeam Console? If you have selected the VM from a ESX host that added to Veeam Console, most properly the VM got migrated to another host and the configured job cannot see the VM on previous host.. Edit the Job and select the VM directly from the vCenter Inventory rather than from the individual host and your problem should go away.

Thanks,
Hussain

mbeckey
Influencer
Posts: 16
Liked: 2 times
Joined: Sep 26, 2012 1:31 am
Full Name: Mark Beckey
Contact:

Re: Error. The object or item referred to could not be found

Post by mbeckey » Oct 16, 2012 1:13 pm

I selected it from the Vcenter entry. Just to make sure I created a new job and made sure to select it from the Vcenter entry the job failed again with the same error. I saw on some searches that it may be a permissions issue so I made sure the network account that I am using to run the job had administrator access on both Vcenter environments and it also has admin access on all of the guests.

Should the account that is running the backup job also have root access on the hosts? Just a thought.

foggy
Veeam Software
Posts: 18673
Liked: 1631 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Error. The object or item referred to could not be found

Post by foggy » Oct 16, 2012 2:36 pm

mbeckey wrote:Should the account that is running the backup job also have root access on the hosts? Just a thought.
Please refer to this topic for the list of the required permissions.

Vitaliy S.
Product Manager
Posts: 23423
Liked: 1665 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: Error. The object or item referred to could not be found

Post by Vitaliy S. » Oct 16, 2012 4:23 pm

No, it shouldn't assuming you've added vCenter Server from the remote site to the backup console.

Can you please tell me if you're able to run a backup job (just for the test purposes) on the second site?

mbeckey
Influencer
Posts: 16
Liked: 2 times
Joined: Sep 26, 2012 1:31 am
Full Name: Mark Beckey
Contact:

Re: Error. The object or item referred to could not be found

Post by mbeckey » Oct 16, 2012 5:26 pm

Thanks for Everyone's replies..

Vitaliy - I was able to run a replica of a guest within the same VM cluster at the second site with no issues. One piece of information that I left out of earlier posts is that we are using Cisco Nexus 1000 V's as our Distributed Virtual Switch at each of our sites. I am not sure if there is any known issues using Veeam 6.1 and the 1000V's.

mbeckey
Influencer
Posts: 16
Liked: 2 times
Joined: Sep 26, 2012 1:31 am
Full Name: Mark Beckey
Contact:

Re: Error. The object or item referred to could not be found

Post by mbeckey » Oct 16, 2012 5:52 pm

I just deleted the VMXNET3 Nic on our test guest and added a E1000 which grabed a DHCP address from our production site. I removed and added the guest to the current backup job and re-ran the job and it completed out to our DR site. So I am guessing there is something going on with the Nexus. Is there any known issues of using Veeam 6.1 and the Nexus 1000v?

Vitaliy S.
Product Manager
Posts: 23423
Liked: 1665 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: Error. The object or item referred to could not be found

Post by Vitaliy S. » Oct 16, 2012 8:51 pm

Hi Mark,

Yes, there was a couple of issues with Nexus 1000v, but all of them have been successfully resolved in Veeam B&R version 5.0.2

Could you please open a support case with our technical team for further investigation? And please post your ticket number, so I could forward this info to our QC team.

Thanks!

mbeckey
Influencer
Posts: 16
Liked: 2 times
Joined: Sep 26, 2012 1:31 am
Full Name: Mark Beckey
Contact:

Re: Error. The object or item referred to could not be found

Post by mbeckey » Oct 16, 2012 11:56 pm

Vitaliy,

Thanks for the reply the case number is request number: 00134839. I am interested to see what support says it is.

Vitaliy S.
Product Manager
Posts: 23423
Liked: 1665 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: Error. The object or item referred to could not be found

Post by Vitaliy S. » Oct 17, 2012 8:39 am

BTW - have you done any network mapping (second checkbox) in the replication job settings?

mbeckey
Influencer
Posts: 16
Liked: 2 times
Joined: Sep 26, 2012 1:31 am
Full Name: Mark Beckey
Contact:

Re: Error. The object or item referred to could not be found

Post by mbeckey » Oct 17, 2012 12:50 pm

Vitaliy - No there was no network mapping configuration done when the job was created I just recreated the job and selected what I think are the correct selections "VM Network". The job ends with the same results Error. The object or item referred to could not be found" . One other thing I did notice is that on the settings for the nic for the replica it has a Summary of "Invalid Backing" in the VM properties.

Vitaliy S.
Product Manager
Posts: 23423
Liked: 1665 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: Error. The object or item referred to could not be found

Post by Vitaliy S. » Oct 17, 2012 1:43 pm

Ok, let's see what our support can say based on your logs.

mbeckey
Influencer
Posts: 16
Liked: 2 times
Joined: Sep 26, 2012 1:31 am
Full Name: Mark Beckey
Contact:

Re: Error. The object or item referred to could not be found

Post by mbeckey » Oct 22, 2012 12:55 pm 1 person likes this post

Thanks for everyone's input on this topic. We were able to figure out that I was not selecting the correct options in the Network Remapping options, I was selecting the Nexus ESXi host and not the VM host.

Vitaliy S.
Product Manager
Posts: 23423
Liked: 1665 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: Error. The object or item referred to could not be found

Post by Vitaliy S. » Oct 22, 2012 1:03 pm

Good to hear that you've managed to figure it out. Thanks for the update.

m.novelli
Veeam ProPartner
Posts: 358
Liked: 42 times
Joined: Dec 29, 2009 12:48 pm
Full Name: Marco Novelli
Location: Asti - Italy
Contact:

Re: Error. The object or item referred to could not be found

Post by m.novelli » May 28, 2013 8:02 am

Today I had a similar issue: replicating between two vCenter 5.1 U1 gave me the error "The object or item referred to could not be found"

Both source and destination vCenter had a distributed vSwitch with the same name, but after some troubleshooting I've found that having the same name is not enough for DVS and I had to select "network remapping" feature in Veeam replica

Feature request: the error returned by Veeam in this case should be smarter e give some more clue to the sysadmin :)

Cheers

Marco

foggy
Veeam Software
Posts: 18673
Liked: 1631 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Error. The object or item referred to could not be found

Post by foggy » May 28, 2013 10:44 am

Thanks for the feedback, I'll pass the info to R&D.

Post Reply

Who is online

Users browsing this forum: Sheppen and 33 guests