Discussions specific to the VMware vSphere hypervisor
Post Reply
YounesF
Novice
Posts: 4
Liked: never
Joined: Sep 06, 2018 8:58 am
Full Name: Younes Fadil
Contact:

File restore from NetApp snapshot fails (case ID 03175995)

Post by YounesF » Sep 10, 2018 9:56 am

case ID 03175995

Hi All,

I am wondering if anyone out there has faced the problem that I am having.
We have few NFS DataStores presented from NetApp to our ESXi hosts. All our ESXi hosts have 2 dedicated interfaces (vmkernel) for NFS traffic, that have IP addresses from a specific network subnet. this subnet is allowed on the default NFS export policy on the netapp. The ESXi hosts also have a separate management interface, and the FQDN of these ESXis will resolve to the IP of the management interface in the DNS. The management network subnet, is not allowed in the NFS export policy.

The problem I have now is, after adding the NetApp to the Veeam configuration and tried to browse/restore from the Netapp snapshots I am not able to, as Veeam is not able to mount the snapshot clone through NFS to any of our ESXi hosts. The error I receive is as follows:

9/6/2018 12:09:03 PM Error Adding NFS datastore /VeeamAUX_VOLUME_A_Restore/ to host esx123.abc.de Error: Failed to mount NFS volume (xxx.xxx.xxx.xxx:/VeeamAUX_VOLUME_A_Restore/). xxx.xxx.xxx.xxx: Fault "PlatformConfigFaultFault", detail "NFS mount xxx.xxx.xxx.xxx:/VeeamAUX_VOL_APP_LINUX_Restore/ failed: The mount request was denied by the NFS server. Check that the export exists and that the client is permitted to mount it."
An error occurred during host configuration.


It seems as if veeam is trying to mount the NFS volume to the esxi (if it's only doing a reverse lookup on the FQDN) using the management IP address - which is of course not allowed in the export. But I cannot be too sure because I couldn't find anything in the log that shows which IP address is veeam using to allow the mount.
now my question is:

1) I tried to find detailed documentation of what exactly happens when this mount operation is triggered, but I couldn't find any. Does anyone know how does Veeam mount the NFS volumes to the esxi and using which IP address/interface?
2) Is there a way we can tell Veeam which interface to use on the ESXi when doing NFS restores?

Any help would be greatly welcome.

Younes

foggy
Veeam Software
Posts: 17918
Liked: 1506 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: File restore from NetApp snapshot fails (case ID 0317599

Post by foggy » Sep 10, 2018 5:55 pm

Hi Younes, the first thing that comes to mind is NFS permissions. Our engineers will be able to check if everything is configured properly, so please continue working with support.

As to your questions, I recommend reviewing this document for better understanding of how backup from storage snapshots works with NetApp/NFS.

ND40oz
Influencer
Posts: 10
Liked: never
Joined: Nov 17, 2010 12:52 am
Full Name: ND40oz
Contact:

Re: File restore from NetApp snapshot fails (case ID 0317599

Post by ND40oz » Sep 11, 2018 4:12 pm

So I just tested this to see how it's handled. Normally in our setup, the Veeam Server or Proxy server has an IP on the subnet used for the NFS exports and backs up using NetApp storage snapshots. I tested an instant restore and it appears as though it picked an interface that have nfs enabled and used it, rather then using the ones that are subnet specific. It then added permissions to the export policy for the ESXi host's management IPs to the export policy and mounted it using the management interface. That's not quite how I'd want it to work, especially if management interfaces didn't have routes to the NetApps. You'd generally want it using the same IPs that are already in use for storage on both the NetApp and host.

Post Reply

Who is online

Users browsing this forum: backupquestions, Google [Bot] and 8 guests