Discussions specific to the VMware vSphere hypervisor
Post Reply
Posts: 2
Liked: never
Joined: May 15, 2018 11:21 am
Full Name: Williiam Allfree

GroupWise 7 Fails after Backup

Post by WilliamA »

My client has a GroupWise 7 Server running on NetWare 6.5. He is unable to back this up, because after backing the server up, as soon as it has rebooted the MTA gives a message "Post Office now closed".

From the logs, it seems that the TCPIP Link, between the Post Office and the MTA gets lost and it fails to connect to Port 7101. The Post Office, Domain and all the components are running on the same Guest on the same Virtual VMWare 5.5 server. There is only ONE Post Office.

I've done a few experiments and no matter how its done, after backup, the MTA and Post Office connection is lost. I've tried in the lab. I installed a new copy of GroupWise 7 on a new Netware 6.5 server. I can back it up and restore it, no problem.

I backed up just the MAIL: volume with the Domain and PO, no problem. If I restore it even to a brand new server, I can see all the mail, so the restore is perfect, BUT immediately it boots up, it loses the connection and I get the message "Post Office now closed".

I'm sure I'm not the first person to get this problem. How can my client avoid it so that he can backup his mail server, and just as important (to me anyhow), Is how to fix the problem if it has already occurred?. There is still a lot of Netware servers and a lot of GroupWise 7 and 8 servers, before Novell surrendered to Microsoft!

Karl Kunze
Posts: 9
Liked: never
Joined: May 02, 2018 10:03 am
Full Name: Karl Kunze

Re: GroupWise 7 Fails after Backup

Post by Karl Kunze »

We - as Veeam-B&R8-user - never had problems with GW 6.0 and GW 8.0 on NW 6.0 and NW 6.5 on ESXI 4.1 before and ESX 6.0 now being backed up and being restored, including replication with failover to replica. Do you have VMware-Tools installed?

Why do you reboot the server or MTA after backup?



Posts: 2
Liked: never
Joined: May 15, 2018 11:21 am
Full Name: Williiam Allfree

Re: GroupWise 7 Fails after Backup

Post by WilliamA »

Well, my client uses GroupWise 7 running on NetWare 6.5 SP8 as a virtual machine on VSphere 5.5. They'll have to pry Netware and GroupWise 7 out of his cold, dead, fingers!

I have managed to replicate the issue in the lab several times. They used to backup the MAIL: volume every night and run a purgevolume every weekend. No problems at all with backing up, but as soon as they restored either the complete VM OR the MAIL: volume, it immediately dropped the link and gave the error.

On top of that, they discovered that a couple of users are using Web Access on their iPads and after a restore, they could no longer log in and they got garbage on the screen. It was for this reason that they stopped backing up the mail server and relied instead on dbCopy.

I wasn't actually called in for this problem, it was for stuck obituaries, but this one also came up, even after everything was cleaned up and working.

I'm pleased to say that I solved both problems and if anyone else gets this issue, here is the solution.

When you restore the backup the GroupWise System or the mail Volume, GroupWise 7 loses the connection between the POA and the MTA. You get the message "Post Office now Closed" on the MTA.

The log file shows the following error:
Unable to open connection 0x8925. Address = <server_IP>. Port = 7101.

The fix for this is as follows : -
  • At the server console, bring up the POA console.
    Press F10 to view the options.
    Edit Startup File (at the bottom)
    Scroll down (pgdn) to the very end of the configuration file (SYS:System\<PostOffice>.POA) and add the following lines:
    /MTPINIPADDR-<server IP address>
    /MTPOUTIPADDR-<server IP address>
    Restart both the POA and the MTA. You may get messages on the MTA about a requested restart and this restart being ignored - in this case manually restart the MTA by pressing F6.
Note: if this happens after a migration do not forget to rebuild the Post Office.

You may also need to re-install WebAccess. Just run the install and accept all the previous settings.

It isn't as though it's a common occurrence to have to restore from Backup, and putting the few extra lines into the POA doesn't affect normal operations. So IF a restore is necessary the problem doesn't happen.

It's a bit of a pain to have to re-install the WebAccess, but I couldn't find any other way to fix this, but my client is now happy to backup the MAIL:volume every night again!.

Veeam Software
Posts: 1920
Liked: 270 times
Joined: Nov 17, 2015 2:38 am
Full Name: Joe Marton
Location: Chicago, IL

Re: GroupWise 7 Fails after Backup

Post by jmmarton »

I know it's been many months since this thread was posted but I just now noticed it. I find it odd that there would be issues and I'm curious if you'd experience the same thing by manually taking VMware snapshots of the NetWare VM. I'd also encourage your client to upgrade to newer versions of GroupWise and migrate to either SLES or OES or Windows. Then you could leverage pre-freeze/post-thaw scripts to handle backing up the PO more gracefully. Plus I'm sure the Micro Focus guys could tell your client about all the new features since GW7 which is extremely old.

BTW, here's a Cool Solutions article I wrote on protecting GroupWise with Veeam. Note that it's only applicable to newer versions of GW as it doesn't take into account running GW on NW. I had GW on SLES/OES in mind when I wrote the article, but the concept should work if it was on Windows as well.

https://www.novell.com/communities/cool ... cro-focus/


Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 18 guests