hotadd failing

VMware specific discussions

hotadd failing

Veeam Logoby sasam » Fri May 15, 2015 10:28 am

Hi

I've got at my client small environment and have decided on virtual Backup server as veeam-backup. I've also installed additional proxy server because of the issue I'm facing.
It was all running smoothly and using hotadd.
After some major crash of the vmware infrastructure, I've reinstalled Veeam software and everything, but jobs keep failing to nbd instead of hotadd.
I've tested and everything is in compliance with requirements prior to hotadd being selected.
In logs I get following error that leads me in one direction:

Mounting VM vim.VirtualMachine:vm-762 using transport hotadd failed : Could not open disk for disk signature retrieval.

I've found on https://www.vmware.com/support/develope ... notes.html following part of the post that says as follows:

Windows proxy HotAdd can cause differing disk signatures.
When backup is done on a Windows proxy with HotAdd transport, Windows may rewrite the disk signature if it finds two identical signatures, resulting in the first sector of the backup not matching the original. To avoid this issue for backups, read the first sector of the disk using NBD transport, then read the remaining sectors using HotAdd transport. To avoid this issue for restores, write the entire disk using HotAdd transport, close the disk and its connection handle, open a new disk connection handle, and rewrite the first disk sector using NBD transport.


Question is:

HOw do I actualy do that?
I've tried changing mode on backup server to nbd, and let it run once, but again, when I change to automatic, it always fails to nbd.
I've tried with Linux boxes being backed up and with windows as clients.
I've tried freshly installed and from template created VMs as clients.
tried changing SAN mode on diskpart on veeam backup server, but again it does the same thing.

How can I read the first secor of the disk using nbd transport, then read the remaining sectors using hotadd transport? Is this Veeam software related, or my infrastructure related, or client related.

Veeam version is 7.0.0.690. I've tried with patch 4 also.
Veeam backup server is windows 2012, and I've tried with 2008 R2, with same results

Thanks

Sasa
sasam
Lurker
 
Posts: 1
Liked: never
Joined: Fri May 15, 2015 9:46 am
Full Name: Sasa Markovic

Re: hotadd failing

Veeam Logoby foggy » Fri May 15, 2015 11:15 am

Sasa, please contact our technical support to review your configuration.
foggy
Veeam Software
 
Posts: 14742
Liked: 1080 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson


Return to VMware vSphere



Who is online

Users browsing this forum: Interconnect-WvT and 13 guests