Discussions specific to the VMware vSphere hypervisor
Post Reply
jja
Enthusiast
Posts: 45
Liked: 8 times
Joined: Nov 13, 2013 6:40 am
Full Name: Jannis Jacobsen
Contact:

Terrible performance + 1 vm never manage to be backed up

Post by jja » Dec 03, 2013 6:24 am

Hi!

I'm thinking of opening a support case, as we have serious performance issues.
We have 1 physical 12 core server with 96Gb ram as our veeam server.
It's direct connected to all the iscsi esxi datastores via 10GBe.
a known bottleneck is the Equallogic san it saves the backups to, this is only 1Gbit, but it should manage 80-100MB/s easy, as the veeam server is the only server connected.

We are on v7 R2. As it is now, I have to coax the jobs to finish successfully. some of the jobs may require up to 2-3 retries before every vm is backed up.
We also have 1 vm that haven't had a full backup since 25th november, log for this server is below.

02.12.2013 01:41:02 :: Using backup proxy VMware Backup Proxy for disk Hard disk 2 [san]
02.12.2013 01:41:10 :: Hard disk 2 (400,0 GB)
02.12.2013 01:56:11 :: Using backup proxy VMware Backup Proxy for disk Hard disk 3 [san]

02.12.2013 01:56:18 :: Hard disk 3 (1024,0 GB)
*** Notice the time spent on this single drive - about 9 hours (and it failed on about 48%, so the speeds are horrible). ***

02.12.2013 10:57:42 :: Removing VM snapshot
02.12.2013 10:59:15 :: Error: Client error: The system cannot find the file specified. Failed to read data from the file <location file>
Failed to perform data backup. An existing connection was forcibly closed by the remote host
02.12.2013 10:59:15 :: Busy: Source 20% > Proxy 9% > Network 9% > Target 98%
02.12.2013 10:59:15 :: Primary bottleneck: Target
02.12.2013 10:59:15 :: Network traffic verification detected no corrupted blocks
02.12.2013 10:59:15 :: Processing finished with errors at 02.12.2013 10:59:15

Any pointers/hints to where I should look. The EQL is an obvious place to start, but it also complains about waiting for backup infrastructure resources all the time.
I'm also guessing a support case would be a smart thing to open.

-J

foggy
Veeam Software
Posts: 18037
Liked: 1533 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Terrible performance + 1 vm never manage to be backed up

Post by foggy » Dec 03, 2013 9:38 am

jja wrote: 02.12.2013 10:59:15 :: Busy: Source 20% > Proxy 9% > Network 9% > Target 98%
02.12.2013 10:59:15 :: Primary bottleneck: Target
Jannis, have you tried to back up to some other storage? Your repository does indeed seem to be a real bottleneck here. What backup mode do you use (forward or reversed incremental)?

jja
Enthusiast
Posts: 45
Liked: 8 times
Joined: Nov 13, 2013 6:40 am
Full Name: Jannis Jacobsen
Contact:

Re: Terrible performance + 1 vm never manage to be backed up

Post by jja » Dec 03, 2013 10:03 am

I'm configuring the new storage server now, and will create a new job with a few vm's to do a testrun.
We use Reversed incremental.

-J

foggy
Veeam Software
Posts: 18037
Liked: 1533 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Terrible performance + 1 vm never manage to be backed up

Post by foggy » Dec 03, 2013 10:08 am

Reversed incremental mode puts much more heavier load on the target storage, which results in longer backup times in your case.

Post Reply

Who is online

Users browsing this forum: No registered users and 12 guests