[NetApp] Unable to find any LUN or NFS export

VMware specific discussions

[NetApp] Unable to find any LUN or NFS export

Veeam Logoby davidrnexon » Fri Nov 20, 2015 3:48 am

Hi,

We have ran into an issue after upgrading a Netapp system to Data Ontap 8.2.3P6, where any new snapvault relationships we have setup since the upgrade, fails to update via VBR 8 Update 3

Manual update of Snapvaults work, rescanning the Storage works and we can see all vm's within the snapshots, local snapshots on the source volumes are working correctly.

Within the backup log we see the following:

[NetApp] Unable to find any LUN or NFS export for SnapProtection relationsip: ........

This is what we should be seeing in the log:

[NetApp]Following LUNs and NFS exports included in Snap Protection relationships.......

All existing snapvault relationships are working correctly with VBR and updating correctly

NFS exports within the Netapp allow for access to the NFS mount points

We currently have a Veeam ticket open: #01127962

We also have a ticket logged with Netapp, however manual snapvault updates and snapvault policy schedules are working correctly.
davidrnexon
Service Provider
 
Posts: 20
Liked: 3 times
Joined: Mon May 25, 2015 6:15 am
Full Name: David Rodriguez

Re: [NetApp] Unable to find any LUN or NFS export

Veeam Logoby foggy » Fri Nov 20, 2015 2:32 pm

David, please continue investigating with Veeam technical support, since deep log analysis is required here. Thanks.
foggy
Veeam Software
 
Posts: 14712
Liked: 1075 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson

Re: [NetApp] Unable to find any LUN or NFS export

Veeam Logoby davidrnexon » Sun Nov 22, 2015 10:41 pm

Will do foggy

Last Friday we found something very weird in the logs, which could potentially be a bug. VBR tries to search for the volume within the list of snapmirrors, however it adds a / into the volume name. Here is an example of the log:

Code: Select all
[20.11.2015 15:04:26] <01> Info     [NetApp] Find Snap Protection relationships relevant for following LUNs or NFSs:
[20.11.2015 15:04:26] <01> Info             Path: '[b]/vol/customer_os/_data[/b]' <---- Here VBR is searching for the volumes name customer_os_data, however has added a / inbetween os and _data

When searching through the list of snapmirrors, it does not match on the actual relationship for this volume:

Code: Select all
[20.11.2015 15:04:28] <01> Info     [b][NetApp] Unable to find any LUN or NFS export for SnapProtection relationsip[/b]: 'SouceLocation: 'Vserver:customer_os_data', SourceVolume: 'customer_os_data', SourceVserver: 'Infrastructure_Vserver', SourceCluster: 'CLUSTER1',  DestinationLocation: 'VserverDR:customer_os_data_sv', DestinationVolume: 'customer_os_data_sv', DestinationVServer: 'VserverDR', DestinationCluster: 'CLUSTER2'RelationshipType: 'Vault''

Once VBR goes through the entire snapvault list, it then let's us know that no snapshot transfers are in place

Code: Select all
[20.11.2015 15:04:28] <01> Info     [SanSnapshotTransfer] Discovered relevant snapshot transfers fro host: '8dd8081f-9811-4584-9e53-5e524e5c2ce6' length '0'
[20.11.2015 15:04:28] <01> Info     [SanSnapshotTransfer] Sync operation for launching snapshot transfers completed.
[20.11.2015 15:04:28] <01> Info     [SanSnapshotTransfer]===========================================================================================
[20.11.2015 15:04:28] <01> Info     [SanSnapshotTransfer] [b]There aren't any launched Snapshot tranfers.[/b]

Comparing these logs to a backup job that is working correctly, the volume path does not contain any / inbetween the volume name
davidrnexon
Service Provider
 
Posts: 20
Liked: 3 times
Joined: Mon May 25, 2015 6:15 am
Full Name: David Rodriguez

Re: [NetApp] Unable to find any LUN or NFS export

Veeam Logoby davidrnexon » Mon Nov 23, 2015 9:41 am 2 people like this post

This issue has now been resolved thanks to support. We needed to patch 2 of the Netapp DLL's:

Veeam.Backup.SanPlugin.NetApp.dll
Veeam.Backup.SanPlugin.NetAppLib.dll

I believe the Bug ID is 52968

FYI this is to patch VBR Update 3
davidrnexon
Service Provider
 
Posts: 20
Liked: 3 times
Joined: Mon May 25, 2015 6:15 am
Full Name: David Rodriguez


Return to VMware vSphere



Who is online

Users browsing this forum: hendrikm and 48 guests