Discussions specific to the VMware vSphere hypervisor
Post Reply
Frosty
Expert
Posts: 175
Liked: 39 times
Joined: Dec 22, 2009 9:00 pm
Full Name: Stephen Frost
Contact:

vSphere v6.7 U3 and SureBackup

Post by Frosty » Oct 13, 2019 10:18 pm 1 person likes this post

Just posting this in case it helps someone else.
I upgraded a host this morning to vSphere v6.7 U3 which seemed to work fine.
We had an error in one of our SureBackup jobs that ran the previous weekend, so I followed my usual procedure to re-run the job, just in case it was a transient error (e.g. something timed out).
Now somewhere in that process, the SureBackup job failed again. The error this time was "No host is compatible with the virtual machine".
After some investigation I found that all my SureBackup virtual lab VMs were not linked to any host within vCenter any longer. They existed in the list of VMs on the left-hand-side of the screen within vCenter (within a SureBackup resource group folder) but when looking at ESXi hosts and their VM tab, didn't show up. Weird?!
I dragged each SureBackup virtual lab VM to the recently-upgraded ESXi host (i.e. like you would when dragging a VM for a vMotion task) and they re-registered themselves with the host.
Then I re-ran the SureBackup job again and it worked just fine.
I suspect, but cannot prove, that this happened because of the timing of my host upgrade and when I first tried to re-run the SureBackup job. I think that maybe, when I fired up the SureBackup job for the first re-run, that the host was still in Maintenance Mode. Can't prove it though.

UPDATE: after that 'fix' I was able to re-run the failed SureBackup job again and it worked fine. I'm reasonably convinced that this was triggered by running SureBackup when the host which had the SureBackup virtual lab VMs was in maintenance mode. Suspect that it tried to register them with other hosts and that this didn't work properly.

Post Reply

Who is online

Users browsing this forum: No registered users and 30 guests