Discussions specific to the VMware vSphere hypervisor
Post Reply
WinstonWolf
Expert
Posts: 203
Liked: 5 times
Joined: Jan 06, 2011 8:33 am
Contact:

Waring : "Removing VM Snapshot" on three from seven VMs

Post by WinstonWolf » Jul 26, 2014 5:29 am

Hello ,
Since four days we have an strange behavior while the Backup Job .
We backup 7 VMs , three on one ESX and the other four on the other ESX. The VMs are on an Storage.

In the Backup Log the three VMs on ESX1 brings the Warning "Removing VM Snapshot" and the Snapshots of this VMs are still . Not deleted.
The four VMs on the other ESX Host have no Problems .

I restarted the ESX Host , i create an new Job but with no effect .

What can i do ?

Thanks for Help .

Michael

Shestakov
Veeam Software
Posts: 7136
Liked: 733 times
Joined: May 21, 2014 11:03 am
Full Name: Nikita Shestakov
Location: Prague
Contact:

Re: Waring : "Removing VM Snapshot" on three from seven VMs

Post by Shestakov » Jul 27, 2014 4:06 am

Hello Winston,

As far as I understood your jobs run successfully, but snapshots remain after job completes. Do you have a vCenter Server that manages these hosts? How did you add these hosts to the Veeam backup console? Do you have any errors in the ESXi host events tab?

BTW, what version of Veeam B&R server are you at and do you have a support case opened on this issue?

Thank you!

foggy
Veeam Software
Posts: 18552
Liked: 1606 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Waring : "Removing VM Snapshot" on three from seven VMs

Post by foggy » Jul 27, 2014 9:17 pm

Are those snapshots removed during the subsequent job run? I also wonder whether you can reproduce this behavior without Veeam B&R presence - by creating snapshot of the affected VM manually, waiting for the time backup job typically takes, and trying to commit it.

Here is another existing topic discussing similar issues: Veeam temp snapshots not removed.

WinstonWolf
Expert
Posts: 203
Liked: 5 times
Joined: Jan 06, 2011 8:33 am
Contact:

Re: Waring : "Removing VM Snapshot" on three from seven VMs

Post by WinstonWolf » Jul 28, 2014 5:02 am

Hello onesmore ,

My Backup & Replication Version ist the 7.0.0.839.
I have an Vcenter 5.0 that Manages the ESX Hosts. I add the Vcenter to the Veeam Backup Console.
In the Backup Job i choose the VMs on every ESX Host and add it to the Job.

WinstonWolf
Expert
Posts: 203
Liked: 5 times
Joined: Jan 06, 2011 8:33 am
Contact:

Re: Waring : "Removing VM Snapshot" on three from seven VMs

Post by WinstonWolf » Jul 28, 2014 6:10 am

The next steps i try to do are :

- Completely remove the Vcenter Server from the Backup Infrastructure in Veeam Backup and reconnected .
- Disconnect and reconnect the ESX1 Host from the Vcenter Server

Do you think this is a good Idea ?

Shestakov
Veeam Software
Posts: 7136
Liked: 733 times
Joined: May 21, 2014 11:03 am
Full Name: Nikita Shestakov
Location: Prague
Contact:

Re: Waring : "Removing VM Snapshot" on three from seven VMs

Post by Shestakov » Jul 28, 2014 11:57 am

Winston,

Some of your colleagues had the same problem which could arise because they added VCenter as Windows Center. Solution is described here. Make sure you didn`t make same misconfiguration.
WinstonWolf wrote: - Completely remove the Vcenter Server from the Backup Infrastructure in Veeam Backup and reconnected .
- Disconnect and reconnect the ESX1 Host from the Vcenter Server
Do you think this is a good Idea ?
I would not recommend to do it right now since you need to re-add VMs to your jobs in this case becasue VM moref ID will be changed and jobs track VMs by this ID. Also your jobs will run full backup for these VMs after this operation. Prior to that I would consider taking foggy`s post into consideration.

Snapshots that have left since the previous run should be deleted during the next job run. It can be useful to check if the problem recurs in a case of affected VM`s snapshot creation and possible deletion after the backup job. Bear in mind that VBR does not delete snapshots, it sends a request to VCenter for deletion.

If nothing works you can contact Veeam support team for a personal help.

By the way, the best way to monitor left-over snapshots is to install Veeam ONE (even Free Edition will alarm you about the issue). Veeam ONE is included in Veeam Backup Essentials and Veeam Backup Management Suite.

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 25 guests