Very slow backup with zero load

Hyper-V specific discussions

Very slow backup with zero load

Veeam Logoby dtsp » Mon Apr 14, 2014 1:02 pm

Hello.
I've installed Veeam B&R 7 with latest updates at Windows Server 2012 R2 physical server with a lot of processing, network and memory resources. I try to Veeam Zip virtual machine and get only 1-5 MB/s processing rate. During backup system is totally free, disk queue is empty, a lot of memory available and processor is almost idle. When I stop the job I get load: source 1-5%, proxy 10-15%, network - 0% and target - 0%. Bottlleneck: Proxy.
I've tried to backup the same VMs using Veeam B&R 7 deployed in virtual machine with just 1 vCPU and 2 GB RAM and same version of Windows Server 2012 R2 and I got 30 MB/s despite that is a much slower system.

I have no Idea where to look for solution. I've managed to backup VMs using that physical server some time ago. But once upon a time I've started a job and got slow backup that cannot be accomplished in acceptable time.

Would be appreciated for any help!
dtsp
Novice
 
Posts: 7
Liked: 1 time
Joined: Sat Apr 12, 2014 12:11 pm
Full Name: Dmitriy Titov

Re: Very slow backup with zero load

Veeam Logoby foggy » Mon Apr 14, 2014 1:14 pm

Strange bottleneck stats numbers... What transport mode is used to process this VM by the physical Veeam B&R instance and what kind of connection do you have to the primary VM storage? What kind of storage it is?
foggy
Veeam Software
 
Posts: 14765
Liked: 1083 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson

Re: Very slow backup with zero load

Veeam Logoby dtsp » Mon Apr 14, 2014 1:23 pm

foggy wrote:Strange bottleneck stats numbers... What transport mode is used to process this VM by the physical Veeam B&R instance and what kind of connection do you have to the primary VM storage? What kind of storage it is?


Thanks for reply, Alexander!

B&R is installed at physical server with modern hardware and is connected to Hyper-V Server 2012 R2 server with 1GB Ethernet.
Hyper-V server uses iSCSI storage for virtual disks also connected with 1GB Ethernet connection.
Storage is a Linux based server.

I can copy files using SMB from target VM to Backup Server at 100 MB/s (full gigabit ethernet utilization), but backup is just a couple of MB/s. I've installed B&R at VM with the same OS as backup server and it's working pretty fine, that's strange.

I've tried to reinstall B&R, tried to create new backup repository on separate external disk with no success though. :(
dtsp
Novice
 
Posts: 7
Liked: 1 time
Joined: Sat Apr 12, 2014 12:11 pm
Full Name: Dmitriy Titov

Re: Very slow backup with zero load

Veeam Logoby dtsp » Mon Apr 14, 2014 1:26 pm

And one more thing to mention: I've tried both Off- and On-Host backups as long as different compression methods with no success also.
dtsp
Novice
 
Posts: 7
Liked: 1 time
Joined: Sat Apr 12, 2014 12:11 pm
Full Name: Dmitriy Titov

Re: Very slow backup with zero load

Veeam Logoby dtsp » Mon Apr 14, 2014 4:12 pm

Thanks to Alexander Fogelson I got support ID: 00549983

Dmitriy Titov
dtsp
Novice
 
Posts: 7
Liked: 1 time
Joined: Sat Apr 12, 2014 12:11 pm
Full Name: Dmitriy Titov

Re: Very slow backup with zero load

Veeam Logoby dtsp » Sun May 04, 2014 11:31 am

Solved with workaround.
The issue is related to Veeam realy strange networking algorithms. If you use several network adapters at your backup server you would probably fall into troubles because Veeam use just "lower" (arythmeticaly) IP address. Veeam sends that addresss to clients and they are not always can use that IP. So, if your backup server is connected to several networks, for example LAN and Internet, you may not be able to perform backup jobs without modifying network settings. You may have to use PAT or something like that.
If someone has the same problems - write here and I'll try explain workaround.
Veeam engineers promise me to discuss that questuion at meeting, but they never wrote me result.
Dmitriy Titov
dtsp
Novice
 
Posts: 7
Liked: 1 time
Joined: Sat Apr 12, 2014 12:11 pm
Full Name: Dmitriy Titov

Re: Very slow backup with zero load

Veeam Logoby foggy » Fri May 16, 2014 10:19 am

Just to follow up on this, a private fix was implemented for this and is available through support. So everyone feeling they might experience similar issue, is encouraged to contact support directly to confirm behavior and try the solution.
foggy
Veeam Software
 
Posts: 14765
Liked: 1083 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson


Return to Microsoft Hyper-V



Who is online

Users browsing this forum: No registered users and 8 guests