Discussions specific to tape backups
fate
Novice
Posts: 3
Liked: never
Joined: Apr 08, 2016 1:09 pm
Contact:

[MERGED] : Howto: Spectrelogic t50e guide

Post by fate » Apr 09, 2016 7:59 am

Hey Guys,

it took me a week to get this tape libary running so I thought I would share it here:

Spectrelogic t50e + VEEAM + 2x IBM LTO 4 drives+ Windows server 2012 64bit

What you need:
VEEAM reg key:
https://www.veeam.com/kb1842

IBM driver:
IBMTape.x64_w08_6252.zip
from here http://www-933.ibm.com/support/fixcentral/

Medium Changer Driver: (yes Spectrelogic says do not install it, I say you need it )
http://catalog.update.microsoft.com/v7/ ... 154ad9f089

Do it in this exact order, otherwise it will not work.

Install IBM Tape driver:
simply unzip IBMTape.x64_w08_6252.zip
rightclick on "non_exclusive.exe" make it compatibility windows 7 and run as admin!
double click non_exclusive.exe!

Device Manager sould now report one
"IBM Ultrium-HH6 SCSI Sequential Drive"
and one "LTO Tape Drive"
This is correct!

Install Libary driver:
download driver from Microsoft: (you can try using Windows update, but that always failed me :( )
you get a "AMD64_X86-en-20246909_9247eb5143a0785f0d027d80d1e0de3c36cab2b1.cab" file
unpack it using 7zip.

Go to device Manger update driver and look for "unknown media changer" -> choose update driver -> select folder of extracted AMD64_X86-en-20246909_9247eb5143a0785f0d027d80d1e0de3c36cab2b1.cab file
Should now report "Spectrelogic Media Changer"


Veeam:
do NOT use native scsi commands on "Spectre Pyton 2000 libary"
apply the regkey described in
https://www.veeam.com/kb1842
because the Drives and the Changer were recognized as 3 separate things.

I used "Changer0=Tape0,Tape1" because I have 2 drives.

Cheers!

Dima P.
Veeam Software
Posts: 8589
Liked: 634 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Backup to Spectra Logic T50e

Post by Dima P. » Apr 26, 2016 12:36 pm

Hi fate,

Thanks for sharing – it’s highly appreciated! A side note, it seems you are using old version of the VBR ( v7?), please note that all the described issues (i.e. unknown medium changer support and failover to SCSI commands, tape library and drives being not correctly displayed in the UI) were fixed in latest versions of the product, so if you got a chance - please upgrade your VBR :wink:

chadsugi
Novice
Posts: 3
Liked: never
Joined: Apr 03, 2018 11:44 pm
Full Name: Chad Sugimoto
Contact:

Re: Backup to Spectra Logic T50e

Post by chadsugi » Apr 03, 2018 11:52 pm

Was the cleaning tape issue ever resolved? Do I set the T50E up with a cleaning partition four automated cleaning or do I set automated cleaning in the Veeam software?

Dima P.
Veeam Software
Posts: 8589
Liked: 634 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Backup to Spectra Logic T50e

Post by Dima P. » Apr 04, 2018 1:59 pm

Hello Chad.

Latest version of Veeam Backup & Replication (9.5 Update 3) does not have these problems. You either control cleaning by library itself or use Veeam tape cleaning tracking functionality but you never use both (otherwise you daily tape activity might be affected due to additional and not required cleaning operations)

chadsugi
Novice
Posts: 3
Liked: never
Joined: Apr 03, 2018 11:44 pm
Full Name: Chad Sugimoto
Contact:

Re: Backup to Spectra Logic T50e

Post by chadsugi » Apr 04, 2018 8:19 pm

Hi Dmitry,

You seem to be the expert on this matter. I have a ticket open with Veeam support now because my library (T50E) keeps going offline. I followed this thread to setup my T50E partition and my Windows 2012R2 Veeam server. I currently am running Veeam version 9.5 Update 3. This post hasn't been updated in a while, so do you have or know all the steps that I should follow to get my library up and running in a stable manner?

Dima P.
Veeam Software
Posts: 8589
Liked: 634 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Backup to Spectra Logic T50e

Post by Dima P. » Apr 05, 2018 8:28 am

What drivers are you using for your device? Is that a generic windows drivers or vendor drivers? Please include the case id in this thread for future reference.

chadsugi
Novice
Posts: 3
Liked: never
Joined: Apr 03, 2018 11:44 pm
Full Name: Chad Sugimoto
Contact:

Re: Backup to Spectra Logic T50e

Post by chadsugi » Apr 05, 2018 8:22 pm

I am using IBM's latest drivers and installed them with "non-exclusive" application.

Veeam Support - Case # 02727836

Post Reply

Who is online

Users browsing this forum: No registered users and 12 guests