Installation fails (SQLLocalDB)

Backup agent for Microsoft Windows servers and workstations (formerly Veeam Endpoint Backup FREE)

Re: VEB 110.110 won't install (fails to start service)

Veeam Logoby Vitaliy S. » Tue Aug 18, 2015 11:45 am

There is no direct email that should be used to send debug logs. You can open a support case from any other Endpoint and attache setup logs from this installation.
Vitaliy S.
Veeam Software
 
Posts: 19698
Liked: 1117 times
Joined: Mon Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov

[MERGED] : Re: Installation fails (SQLLocalDB)

Veeam Logoby theprojectgroup » Mon Feb 08, 2016 12:49 pm

Same here, all steps don't solve the problem here on a win 8.1 machine.

tried:
- delete the instance manually
- re-creating the instance manually
- removing the instance and all db files in systemprofile manually
- uninstall sql express, installing it manually (setup upgrades it)
- recreatedb registry trick from https://www.veeam.com/kb2057

Veeam ProgramData: https://www.dropbox.com/s/6w4bspfqfyne8 ... m.zip?dl=0

Can't open VEB cause it only throws the SQL not available error, so I can't open a case from the technical tab!
theprojectgroup
Influencer
 
Posts: 13
Liked: 1 time
Joined: Mon Mar 30, 2015 1:41 pm
Full Name: Florian Obradovic

Re: Installation fails (SQLLocalDB)

Veeam Logoby Dima P. » Tue Feb 09, 2016 2:12 pm 1 person likes this post

Florian,

Thanks for providing the logs - I'll share it with QA team.
Dima P.
Veeam Software
 
Posts: 6385
Liked: 449 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Installation fails (SQLLocalDB)

Veeam Logoby Dima P. » Tue Feb 09, 2016 2:52 pm

Florian,

In addition, can you share the windows event logs for VEB application and windows system log as well (save all events as…)? The logs you shared show the service being constantly stopped but we cannot identify the root cause without the event logs. Thanks!
Dima P.
Veeam Software
 
Posts: 6385
Liked: 449 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

New install, unable to launch Control Panel

Veeam Logoby dgodkin » Fri Feb 19, 2016 11:44 pm

Hello,

Fresh install of VEB on Win 7 Ent, SP1, 64 bit. Installation completes with no errors.

The tray icon doesn't show up and I can't launch the Control Panel either from the start menu (nothing happens, even when running as administrator). I can launch the Configure Backup application, and try to setup a job, but the volume selection fails with "WIM method call failed." I've restarted a number of times and also followed the directions to exclude VEB files from Anti-virus (https://www.veeam.com/kb2034).

I found in the VEB service log file the following repeating error:

Code: Select all
[19.02.2016 17:17:32] <18> Info     [Schedule Events] Service start date: 2/19/2016 5:17:32 PM
[19.02.2016 17:17:32] <18> Info     [Schedule Events] Trying to get startup date from management object.
[19.02.2016 17:17:32] <18> Error    Dispatch thread will be restarted: fault detected. Waiting [5 sec].
[19.02.2016 17:17:32] <18> Error    Invalid class  (System.Management.ManagementException)
[19.02.2016 17:17:32] <18> Error       at System.Management.ManagementException.ThrowWithExtendedInfo(ManagementStatus errorCode)
[19.02.2016 17:17:32] <18> Error       at System.Management.ManagementObjectCollection.ManagementObjectEnumerator.MoveNext()
[19.02.2016 17:17:32] <18> Error       at Veeam.EndPoint.CExternalStartupEvent.Init()
[19.02.2016 17:17:32] <18> Error       at Veeam.Backup.Service.CExternalOrEvent.Init()
[19.02.2016 17:17:32] <18> Error       at Veeam.Backup.Service.CExternalEventsWatcher.Init()
[19.02.2016 17:17:32] <18> Error       at Veeam.EndPoint.CEndPointServiceImpl.DoDispatchLoop()
[19.02.2016 17:17:32] <18> Error       at Veeam.EndPoint.CEndPointServiceThread.DoRetryLoop()


Since I can't launch the Control Panel, I can't submit a support request through the proper channel. Any ideas?

Thanks!
dgodkin
Lurker
 
Posts: 2
Liked: never
Joined: Mon Jun 03, 2013 2:15 pm
Full Name: Daryl Godkin

Re: Installation fails (SQLLocalDB)

Veeam Logoby Dima P. » Sat Feb 20, 2016 12:49 am

Hello Daryl,

Can you share the setup log from C:\ProgramData\Veeam, windows application event logs for Veeam Endpoint Backup and windows system event logs with me (just send a PM with the download link)? Thanks.
Dima P.
Veeam Software
 
Posts: 6385
Liked: 449 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Installation fails (SQLLocalDB)

Veeam Logoby Gehacktesmacher » Sun Mar 06, 2016 5:51 pm

SUPPORT CASE ID: 01718711

Windows 8.1 Pro 64bit, 8 GB RAM, Sophos Antivirus

Veeam Endpoint Install fails "Starting Tray Application", but Tray Application is shown.
Image

If I try to configure a Backup Job it fails with a SQL Connection Error
Image

I tried many things to get this working with no luck.
- Uninstalled Sophos at first
- Uninstalled VirtualBox
- Complete Re-Installs of Veeam Endpoint in different versions
- Re-Installing .NET Frameworks
- Installing Standalone MSSQL 2012 LocalDB befor installing VEB
- all other possible solutions from this thread and more (Repair Installation, Database Re-Creation and so on)

SQL Management Studio connects without any issues
Nothing helps.
Gehacktesmacher
Novice
 
Posts: 6
Liked: never
Joined: Fri Jan 06, 2012 12:53 pm

Re: Installation fails (SQLLocalDB)

Veeam Logoby Vitaliy S. » Mon Mar 07, 2016 9:29 am

Maybe there are other software packages that conflict with this installation, let's see what your support engineer figures out after investigating the debug logs. BTW, do you see the same behavior on any other similar computer?
Vitaliy S.
Veeam Software
 
Posts: 19698
Liked: 1117 times
Joined: Mon Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov

Re: Installation fails (SQLLocalDB)

Veeam Logoby Gehacktesmacher » Mon Mar 07, 2016 12:11 pm

We deployed this machine from an Windows 8.1 Image via Acronis Boot CD. The image was likely empty, only a few installed components but none affecting .NET or SQL Server. This machine is working without any issues except this Veeam Endpoint Installation issue, but at this time we are not able to deploy this machine with a new installation of Windows 8.1

I hope the support will find a solution or workaround.
Gehacktesmacher
Novice
 
Posts: 6
Liked: never
Joined: Fri Jan 06, 2012 12:53 pm

Re: Installation fails (SQLLocalDB)

Veeam Logoby Dima P. » Mon Mar 07, 2016 10:35 pm

Hi,

Try to create the database please with AV being disabled or uninstalled:

1. Go to Control panel > Administrative Tools and run Services. Stop the Veeam Endpoint Backup service.
2. Run regedit.exe and locate the HKEY_LOCAL_MACHINE\SOFTWARE\Veeam\Veeam Endpoint Backup key. Create the following value under this key:
Name = Recreatedatabase
Type = DWORD
Value = 1

3. Start Veeam Endpoint Backup service
4. Allow some time for the new database instance to be created (5 minutes should be enough).
5. Stop Veeam Endpoint Backup service
6. Run regedit.exe and delete the Recreatedatabase value from HKEY_LOCAL_MACHINE\SOFTWARE\Veeam\Veeam Endpoint Backup key.
7. Start Veeam Endpoint Backup service.
Dima P.
Veeam Software
 
Posts: 6385
Liked: 449 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Installation fails (SQLLocalDB)

Veeam Logoby Gehacktesmacher » Mon Mar 07, 2016 11:50 pm

Hi,

tried exactly that way. Error on second screenshot persists.

Sorry, any other ideas?
Gehacktesmacher
Novice
 
Posts: 6
Liked: never
Joined: Fri Jan 06, 2012 12:53 pm

Re: Installation fails (SQLLocalDB)

Veeam Logoby Dima P. » Tue Mar 08, 2016 10:37 am

Please, share the application logs from C:\ProgramData\Veeam\EndPoint with me via dropbox or google drive. Also if you opened a support case - please post your case ID to this thread. Thanks.
Dima P.
Veeam Software
 
Posts: 6385
Liked: 449 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Installation fails (SQLLocalDB)

Veeam Logoby Nathan » Tue Mar 22, 2016 8:36 am

Hi

I have the same problem with Gehacktesmacher. I also tried uninstall the VEB by using PSTools and the procedure above. But the second screenshot that Gehacktesmacher uploaded persists.

I uploaded log file to sendspace. The download link as follow: https://www.sendspace.com/file/9g4iuj

Please kindly check and advise.

I hope the support will find a solution or workaround.
Nathan
Influencer
 
Posts: 18
Liked: 2 times
Joined: Tue Mar 22, 2016 7:41 am
Full Name: Nathan.Lu

Re: Installation fails (SQLLocalDB)

Veeam Logoby Dima P. » Tue Mar 22, 2016 11:02 am

Hi Nathan,

Are you installing the latest version? Thanks for logs - I'll forward it to QA team for investigation.
Dima P.
Veeam Software
 
Posts: 6385
Liked: 449 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Installation fails (SQLLocalDB)

Veeam Logoby Gehacktesmacher » Tue Mar 22, 2016 8:05 pm

No success with 1.5, error message is the same for all versions
Gehacktesmacher
Novice
 
Posts: 6
Liked: never
Joined: Fri Jan 06, 2012 12:53 pm

PreviousNext

Return to Veeam Agent for Windows



Who is online

Users browsing this forum: No registered users and 10 guests