[SOLVED] Veeam 9.5 not detecting REFS volume

Availability for the Always-On Enterprise

[SOLVED] Veeam 9.5 not detecting REFS volume

Veeam Logoby dgomes » Fri Dec 02, 2016 12:50 am 2 people like this post

TLDR: wasted whole afternoon because of windows update. Thanks microsoft :P

EDIT: Please disregard. It seems there are some windows updates that must do something for this issue. My colleague just called me as I posted this message and informed me after running updates and reformatting the iscsi volume, Veeam is behaving as it should.
So just leaving this information here for anyone who runs into this unusual issue.


I'm currently trying to test the new REFS functions from 9.5 on server 2016 but having some issues.
Our lab setup for this is as follow:

Fresh install of server 2016 datacenter on a VMWare 6.0U2 host.
10 TB volume on a Synology NAS presented to Windows directly via iSCSI (bypassing vmware).
Synology block size is 64K and so is our REFS block size when formatting.

We tried both a direct partition (windows disk manager -> format REFS), as well as creating a storage space with the single volume also formatted REFS.

Veeam 9.5 sees the storage fine but the 2 big signs that REFS is not being detected properly are being shown:
1) the "align blocks" option is NOT ticked and greyed out
2) when completing the setup of the repo, it says "specified volume does nto support fast cloning API. proceed anyways?"

The veeam install is on a trial licence so I think everything is unlocked, though I think the REFS functions work on every version?

Is there something wrong in this setup?

Thanks,
dgomes
Influencer
 
Posts: 20
Liked: 7 times
Joined: Sat Jan 17, 2015 7:16 pm
Full Name: David

Re: [SOLVED] Veeam 9.5 not detecting REFS volume

Veeam Logoby Mike Resseler » Fri Dec 02, 2016 7:07 am

David,

Thanks for sharing (including the solution which will most probably help others). One of the items you do must know (I ran against it this week...) is that when you are creating a repository (even if it is ReFS and fully supported) that the checkbox is indeed not ticked and greyed out. It becomes like that AFTER you create the repository. But yes, the second step (the one with the warning "specified volume does not and so on...) should indeed be the indication for that.

Thanks
Mike
Mike Resseler
Veeam Software
 
Posts: 3150
Liked: 362 times
Joined: Fri Feb 08, 2013 3:08 pm
Location: Belgium, the land of the fries, the beer, the chocolate and the diamonds...
Full Name: Mike Resseler

Re: [SOLVED] Veeam 9.5 not detecting REFS volume

Veeam Logoby lesterclayton » Wed Dec 21, 2016 3:09 pm

Just wanted to add that I've also run into this issue, but Windows Updates did not fix it for me. My server was 2012 R2 with some huge ReFS volumes for repositories, and we reinstalled the OS. I got the abovementioned error, but simply deleting the ReFS volumes and re-creating them made the errors go away. I suspect that this feature it's looking for is only enabled in the newer formatted ReFS volumes, and not volumes formatted with the earlier version of ReFS.
lesterclayton
Service Provider
 
Posts: 5
Liked: 1 time
Joined: Mon Sep 17, 2012 9:47 am
Full Name: Lester Clayton

Re: [SOLVED] Veeam 9.5 not detecting REFS volume

Veeam Logoby foggy » Wed Dec 21, 2016 4:04 pm

That's correct, it should be a freshly formatted volume and repository should be re-created so that Veeam B&R could recognize ReFS 3.1 and use the benefits it provides.
foggy
Veeam Software
 
Posts: 14728
Liked: 1076 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson


Return to Veeam Backup & Replication



Who is online

Users browsing this forum: v.Eremin and 31 guests